Welcome to discussions

Quick Suggestions

  • Ubi-Mark.
    Ubisoft Support Staff 1050 posts

    Hello Vikings,

    Sorry to hear that you are unable to proceed.

    Our development team is currently investigating this issue. Can you please provide us with your save files in order to speed up the ongoing investigation? Many thanks and apologies for any inconvenience caused by this. If you have any additional questions, please let us know.

    Official Response
  • LyricalMango
    8 posts

    Exact same problem as this thread.

    The Hamtunscire quest is not triggering upon pledging.

    I tried an earlier save and did the entire Norway quest again and the same problem.

    I recently upgraded to Xbox Series X and the problem is exactly the same. Tried leaving animus, Going to Vinland, Changing gender. No work around.
    Also the most recent patch did nothing to fix this.

    I have clocked over 200 hours in a game I literally can not finish.

    I sure as hell am not buying the DLC (which ironically I was looking forward to) until this is fixed.

  • flick-_-
    24 posts

    you are a momo . This was first reported November 20th . [censored] this [censored]


  • Thretosix
    25 posts

    @ubi-mark How do I provide a game save? I'm playing on the Xbox Series X, though I know this issue persists across all platforms I'm sure PC would be the easiest. Are you able to access cloud saves? When I get home I can look for a cloud save. My current manual save is before the incident so I can check after patches if it has been fixed. Thank you for the response.

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts

    Hello all!

    I apologise for the delayed update. Thank you for continuing to post within the forums to share your experiences of this issue. I've now merged together several threads into a single megathread, so I apologise if any ongoing conversations or discussions have been broken up by this.

    By creating a megathread, we can keep all the information and updates regarding being unable to proceed with "Kingdom's End" in one place. This helps to prevent loss of information and miscommunication. If you have been affected by this issue, please can you update this thread rather than starting a new one. Thank you!

    The development team have been made aware of this issue and they are currently investigating further. We are interested in collecting the save files of players who have encountered this in their games. If you play on PC/PS4, please can you open a support ticket and submit your saves as a .zip file for further investigation. Once you've opened a support ticket, please can you share your ticket number within the thread so we can pass this information on to the development team.

    We would also like to gather images and videos that shows you have started an alliance with this region, but no quest has been added to the quest log. Please can you share these within the thread as well? I have already gone through the thread and submitted all of the information shared already.

    @CCox053 & @TheManta076 - Thanks for sharing videos! I've passed these on to the development team.

    @AirbornePants0 - I'm sorry to hear you're unable to start the Snotinghamscire arc. As this thread is about "Kingdom's End," I recommend that you either start a new thread about the issue you're encountering, or find a similar one and share your experience there. That way, we can keep the investigations separate and avoid any miscommunications.

    Thanks all! 😊

    Official Response
  • jonmango
    9 posts

    I’m having this issue too on PS5. I opened a separate thread a few days ago - I must have missed this one or it was just added to the mega thread.

    I can try to get a video, not sure if I can get a save file.

    Here’s hoping for a fix soon!

  • Thretosix
    25 posts

    This issue is now in the official Megathread for issues with Valhalla. I personally feel a lot better knowing this. I now have confident that while it may not be right away, that this issue will be resolved. I want to thank Official Support for responding and engaging with the issue and my gratitude for others having the same issue sharing what they have to assist in raising awareness of this issue.

  • Swan674
    1 posts

    Nothing happens after I pledge to hamuntscire. Been stuck at this point since December unable to proceed with no quest marker

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    Hey all! We appreciate the continued reports for this issue. Our team is still investigating this bug at this time. We ask that those affected by the issue create a new ticket and attach a copy of their save game files to it for review. If you'd like, feel free to post your case number here after the case is created so we may ensure things are in the right place! 

    Official Response
  • cocline123
    2 posts

    I'm experiencing the same issue on xb 1. No I will not take pictures or go through the hassle of getting my save files to you guys.someone posted a video of the exact issue I'm having in this thread. Get it fixed and I'll buy the dlc. Otherwise I doubt I'll ever buy an ac game again.

  • dem0n259
    2 posts

    Kingdoms end is still bugged for me. Thought it would have been fixed by now but guess not. They rather give new content instead of fixing the game. Guess I won’t be able to ever finish this game. Thanks Ubisoft

  • LyricalMango
    8 posts

    Still not fixed as of new update.

    200 hours and I can't even finish the game.

    I'm just going to watch the ending on youtube so I know how the story ends and I sure as hell am not going to purchase the DLC stories.

  • reisch78
    6 posts

    Still not fixed with update 1.1.2. and to be honest, I didn't really expect it. While this issue was reported way back in November / December they only began their investigation two or three weeks ago. At least they have finally acknowledged the issue.

    However, what makes me really sad is, that there is no feedback and no indication that suggests that fixing this bug is highly prioritized. After all it is a bug that is affecting the main story in a way that makes it impossible to complete the game. In my opinion game-breaking bugs should be fixed asap and patched in with a hotfix.

    Here's hope that I will be able to complete the game... soon-ish.

  • Thretosix
    25 posts

    @ubi-wan I'm still trying to send the save files for this game from my Xbox Series X to add to my support case. The link you provided doesn't help me.

  • Thretosix
    25 posts

    @reisch78 It's at least now mentioned in the megathread for game issues. I actually do think this has been moved up on the list of priorities. Many people weren't complaining before because this happens later in the game very close to the end of the main story. If more people play this far and get the same issue it will be a real problem on their hands. Hopefully it gets resolved soon. When you finish late game achievements the game and it says like 5% of the people playing the game achieve it, with so few people playing through the full game, even less will have the issue. It is very discouraging, I'm not even excited for the newer content because of this one issue. It sucks, a lot.

  • Luk-asz-2884
    2 posts

    The bug is still there and prevents you from completing the story and getting the platinum trophy. I can't report it via email because of covid.

  • flick-_-
    24 posts

    ive been at a stand still because of this glitch since mid November. You are a joke of a company .

    [censored]. You !!!

  • flick-_-
    24 posts


    i want a refund . This is complete [censored] . Since mid November I’ve been stuck at kingdoms end

  • MalokSpotted
    4 posts

    Hallo, im a bit concerned diz i ser all this ppst from december and this bug that happen same to me is not solved yet . Very baD 😞 i was really enjoying the game... nothing we can do? I tryed evething they said u to do.. plz ubisoft fiz it so i can finish the game and bit ur dlc after

Suggested Topics

Community Details