ubisoft discussions

Quick Suggestions

  • mreljp
    3 posts

    hi. Thank you for the response. How do I send my save files from my PS4? Do I need go to the Ubisoft forum on my PS4?

  • Elle0111
    3 posts

    @shadowofajoke1 already finished that one. Received a mail from Ubisoft saying the quest was in my log. Opened the game, still nothing. I am not about to start from scratch again. The idle save nailed me. Last save is Nov. 14th 😕

  • dinounit67
    21 posts

    @thretosix Just hopping by to say I have this issue as well! Come on Ubisoft, do your job!

  • TheLastofHim
    1 posts

    I have a similar issue but it occurs after Kingdoms End, won't post spoilers for others here who haven't been able to play that one yet, but the next quest just won't start and I've tried everything, it simply does not appear in the quest log, does not initiate when you go to the spot on the map where it's supposed to initiate. Honestly this could have been a decent game and I never review games but I will be posting a scathing review of this one after it crashed on me dozens of times, had to be reloaded after getting stuck inside of the landscape multiple times, almost went mad with audio of dialogue overlapping, the game is an absolute mess and should never have been released in such a state tbh, or else it should have been massively discounted as it's not the finished article in any sense of the word.

  • Thretosix
    25 posts

    I've gotten better support since. But still nothing more than a response saying the information has been passed on. They were at least didn't shoot me the blanket response I have been getting. Hopefully this will be resolved soon. It's quite annoying all the smaller things that have been fixed. Something as game breaking as this is a bit disheartening to be ignored like it is.

  • reisch78
    6 posts

    I have the exact same issue - no quest after pledging to Hamtunscire. I'm playing the game on PS5, 162 hours into the game. Support has not been a big help, honestly. I found their answers rather generic, along the lines of "have you tried to turn it off and on again?". On the bright side: after A LOT of trouble, I was finally able to extract a save file. I sent that file to the support and they replied, that they passed it on to the dev team for further investigation. So here's hope that they will at least start working on this issue in the near future. Fingers crossed...

  • mreljp
    3 posts

    I have also experienced the same issue after pledging to Hamtunscire. It shows I’m committed but the Kingdom’s End Quest does not appear. I tried everything to try to get it, load previous save and repledge, exit in and out of animus, went to Wertham, nothing worked. Ubisoft replied to me with a generic response as well. Hopefully with this many players having the same game changing experiences, Ubisoft needs to come up with a fix for this. So many players unable to finish the ending of a game will leave a lot of players not wanting to support by of their games in the future!!

  • Ubi-Mark.
    Ubisoft Support Staff 2623 posts

    Hello Vikings,

    Sorry to hear that you are unable to proceed.

    Our development team is currently investigating this issue. Can you please provide us with your save files in order to speed up the ongoing investigation? Many thanks and apologies for any inconvenience caused by this. If you have any additional questions, please let us know.

    Official Response
  • LyricalMango
    8 posts

    Exact same problem as this thread.

    The Hamtunscire quest is not triggering upon pledging.

    I tried an earlier save and did the entire Norway quest again and the same problem.

    I recently upgraded to Xbox Series X and the problem is exactly the same. Tried leaving animus, Going to Vinland, Changing gender. No work around.
    Also the most recent patch did nothing to fix this.

    I have clocked over 200 hours in a game I literally can not finish.

    I sure as hell am not buying the DLC (which ironically I was looking forward to) until this is fixed.

  • flick-_-
    24 posts

    you are a momo . This was first reported November 20th . [censored] this [censored]


  • Thretosix
    25 posts

    @ubi-mark How do I provide a game save? I'm playing on the Xbox Series X, though I know this issue persists across all platforms I'm sure PC would be the easiest. Are you able to access cloud saves? When I get home I can look for a cloud save. My current manual save is before the incident so I can check after patches if it has been fixed. Thank you for the response.

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello all!

    I apologise for the delayed update. Thank you for continuing to post within the forums to share your experiences of this issue. I've now merged together several threads into a single megathread, so I apologise if any ongoing conversations or discussions have been broken up by this.

    By creating a megathread, we can keep all the information and updates regarding being unable to proceed with "Kingdom's End" in one place. This helps to prevent loss of information and miscommunication. If you have been affected by this issue, please can you update this thread rather than starting a new one. Thank you!

    The development team have been made aware of this issue and they are currently investigating further. We are interested in collecting the save files of players who have encountered this in their games. If you play on PC/PS4, please can you open a support ticket and submit your saves as a .zip file for further investigation. Once you've opened a support ticket, please can you share your ticket number within the thread so we can pass this information on to the development team.

    We would also like to gather images and videos that shows you have started an alliance with this region, but no quest has been added to the quest log. Please can you share these within the thread as well? I have already gone through the thread and submitted all of the information shared already.

    @CCox053 & @TheManta076 - Thanks for sharing videos! I've passed these on to the development team.

    @AirbornePants0 - I'm sorry to hear you're unable to start the Snotinghamscire arc. As this thread is about "Kingdom's End," I recommend that you either start a new thread about the issue you're encountering, or find a similar one and share your experience there. That way, we can keep the investigations separate and avoid any miscommunications.

    Thanks all! 😊

    Official Response
  • jonmango
    9 posts

    I’m having this issue too on PS5. I opened a separate thread a few days ago - I must have missed this one or it was just added to the mega thread.

    I can try to get a video, not sure if I can get a save file.

    Here’s hoping for a fix soon!

  • Thretosix
    25 posts

    This issue is now in the official Megathread for issues with Valhalla. I personally feel a lot better knowing this. I now have confident that while it may not be right away, that this issue will be resolved. I want to thank Official Support for responding and engaging with the issue and my gratitude for others having the same issue sharing what they have to assist in raising awareness of this issue.

  • Swan674
    1 posts

    Nothing happens after I pledge to hamuntscire. Been stuck at this point since December unable to proceed with no quest marker

  • Ubi-Wan
    Community Representative 636 posts

    Hey all! We appreciate the continued reports for this issue. Our team is still investigating this bug at this time. We ask that those affected by the issue create a new ticket and attach a copy of their save game files to it for review. If you'd like, feel free to post your case number here after the case is created so we may ensure things are in the right place! 

    Official Response
  • cocline123
    2 posts

    I'm experiencing the same issue on xb 1. No I will not take pictures or go through the hassle of getting my save files to you guys.someone posted a video of the exact issue I'm having in this thread. Get it fixed and I'll buy the dlc. Otherwise I doubt I'll ever buy an ac game again.

  • dem0n259
    2 posts

    Kingdoms end is still bugged for me. Thought it would have been fixed by now but guess not. They rather give new content instead of fixing the game. Guess I won’t be able to ever finish this game. Thanks Ubisoft

  • LyricalMango
    8 posts

    Still not fixed as of new update.

    200 hours and I can't even finish the game.

    I'm just going to watch the ending on youtube so I know how the story ends and I sure as hell am not going to purchase the DLC stories.

Suggested Topics