Welcome to discussions

Quick Suggestions

  • Katack2011
    2 posts

    Hi,
    I think i can reply to your question.

    From what i've seen on internet, the vase (and thus the key), only spawn if you have are on the quest arc : The Legend Of Beowulf.

    And this quest is only available with the season pass (which is included with the gold, ultimate and collector edition of AC valhalla).

    For the standard edition, you can purchasse the season pass for 39€99, available at the following link :
    https://store.ubi.com/fr/assassins-creed-valhalla-season-pass/5f5f3b930d253c154cccdbc4.html

  • Faramous
    2 posts

    @inetrans Did you manage to resolve this? I'm there now and have just destroyed the curse, but have no key. The key icon is showing, but nothing on the table. Tried smashing everything up, lighting all the braziers, leaving and reentering, restarting game, and more.

  • TQWorld
    7 posts

    Same for me. I see the key indicator on the table but there is no visible key and no way to interact with anything.

  • ManicFury69
    3 posts
    This post is deleted!
  • ManicFury69
    3 posts

    Hi, I'm also having this same issue. Odin's Sight shows the key icon, above the little stone table where the key should be, but there's no key there, and no "collect" button appears.

    Also, nearby, in the same room, is one of the white lights revealed by Odin's Sight (as for artefacts or keys etc.) inside a rock in the corner. There doesn't seem to be any way to interact with it.

    I've tried saving and reloading, to no avail. If Katack2011 is correct, and this is part of the Legend of Beowulf DLC, it absolutely should not be appearing as though it were part of the base game.

  • BaconMacGowan
    4 posts

    Same for me. After using Odin's Sight, I see the key icon, and the white glow in the rocks to the far right of where the key should be, but there's absolutely nothing on that table.

  • Kennyannydenny
    121 posts

    This also happens on Xbox One.

    Even when not being able to do The Legend Of Beowulf due to not owning the season pass, when using Odin's sight a key indicator comes up, like there should be a key. I don't think the indicator should point you to the key's location when you don't have the season pass installed. It's confusing and doesn't make sense.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi everyone! I'm sorry to see that this issue is impacting more of you since our last update to this thread. Is anyone able to provide a YouTube link here which shows the key icon, but that there's no key to be collected?

    Official Response
  • Kennyannydenny
    121 posts

    @ubiexcellent Here's a video I just made:



    So for clarity. I don't own the season pass. So I can't do the Beowulf missions. When I go to Grime's Graves, the key indicator still shows up in Odin's Sight, which is very confusing and doesn't make sense. Please make it so it actually only shows up when the actual key is there (and thus you have access to the mission).

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    Hello all!

    I've merged a couple of similar threads into this one, so apologies if any discussion has been disrupted by this. We'd like to try and keep all discussion regarding this investigation in one place, as this prevents miscommunication and loss of information. Thanks!

    Please be assured that this missing key is only part of the Beowulf questline, and it should not prevent you from collecting the Treasure of Britain that can also be found in this location. I understand if this is a little confusing, so I've passed on your reports to the development team for a closer look.

    @Kennyannydenny - Thanks for sharing this video! I've passed this on as well.

    Thanks all! 😊

    Official Response

Suggested Topics

Community Details

161
Online
140.0k
Users
24.7k
Topics
127.7k
Posts