ubisoft discussions

Quick Suggestions

  • heca8
    1 posts

    Same bug was happened to me! Now,here is a solution" or not?" Go back to Clee Hill Spring and save the blind man again. some how, he is still there.
    HOWEVER, somehow, I could not save the lame guy!
    Besides, Eivor keeps saying "someone is following us, don't move."
    What is wrong with my Eivor?!
    I guess this is just a bug thing. hopefully, UBISOFT will fix it soon.

  • LoreDarkclaw
    1 posts

    @griffen346 I've had the same issue. Tried other fixes including fast travelling to another point, but the message keeps coming up in the middle of my screen "you must be anonymous"

  • KBiggens
    1 posts

    Same problem, I'm unable to carry the old man. On the Series X

  • nedetrebor
    4 posts

    I didn't find the spring first. I found the blind man first, took him to the spring, found the lame man, but can't carry him. Was I supposed to go to the spring first? Like [censored] Ubisoft, why is this game so buggy. So much [censored] is buggy and glitchy.

  • americankhatru
    1 posts

    @nedetrebor I have this exact same issue as well. Encountered the blind man first, led him to the spring, and I don't have the option to pick up the lame man.

  • KyleOrr87
    1 posts

    I am trying to do the blind and lame man world event,I have moved the lame man to his destination but when I tried to get the blind man to follow me he won't,I have spoken to him already but he won't move and just keeps repeating his lines,can't complete this world event because if this.

  • Griffen346
    6 posts

    After today's update, I went back to the mystery quest on both saves and both are still bugged, Seems people can't pick up the lame man or talk to the blind man, it's different but it's the same quest that's bugged, I'm hoping for a reset option on these mystery quests or at least a fix so people can continue on

  • x3ro-Shikari
    Original poster 21 posts

    Logged in today to title update 1.0.4 to see if it was fixed. It's still an issue. Any update? It's still not even on the "known issues" list even though a few people have posted about it...

    I've stopped playing the game until it's fixed now because I'm about 60 hours in and don't want to start a new save to get my 100% achievement.

  • x3ro-Shikari
    Original poster 21 posts

    Still happening to me on 1.0.4 patch. Still not listed in "Known issues" either. What's the deal?

  • x3ro-Shikari
    Original poster 21 posts

    @griffen346 Yeah can confirm it's also still bugged for me on latest patch too... Come on Ubisoft...

  • XVII_Sam
    21 posts

    Exact same for me. Led the blind man up the hill, Lame man keeps shouting but I don't get the option to pick him up.

  • gvolpe15
    1 posts

    I got a bug for the blind and lame man mystery in sciropescire. i got the lame man up the mountain and talked the the blind man, but he does not follow me and just keeps screaming “cursed” . cannot reset or get him the follow me up the mountain. is the my last mystery in england.

  • GarlicEgg
    1 posts

    Just Happened to me too - PS5.

    Chatted to the poor chap on the ground. Picked him up fine. Carried him up the hill. Splash - Dumped in the water. He made some comment on allowing the breeze to run over him and feeling better. I got distracted by the cairn puzzle. Next thing I know he was face down in the spring. Assumed part of the mystery but I can't seem to interact with him now or do much of anything.

    Lost a load of hours on two other mysteries that bugged out so I had to re-load. Going to put this game down now until fixed as can't face the time loss. Ubisoft please let me know this is one actively being looked at so I can continue my Viking adventure!

    Edit 1: Fixed a number of spelling errors.

  • Khaleesi1440
    1 posts

    I had the same issue but fixed it (on PS4 btw). I reloaded to when I had first talked to the blind man, whom i had found first. I had him follow me (running, no horse) and went around to avoid coming into contact with the lame man. No glitch. Then went and got the lame man and carried him up to finish the quest. Could be that once you've come close enough to hear the dialogue with either one, it interferes with your anonymity. Hope this helps someone else!

  • x3ro-Shikari
    Original poster 21 posts

    @khaleesi1440 didn't fix it for me unfortunately. Still seeing this issue.

  • Conn_Eremon
    1 posts

    I traveled to the top of the hill where the World Event marker was placed (near the Cairn marker). Seeing no way to progress the event at that spot, I started looking around. Found a Lame Man who needed help carrying him up the hill. As I placed him, I received constant notifications that I should be anonymous, and the Lame Man spoke as if I was still carrying him.

    I googled to see if I missed something, and found that there was a second individual. After some searching, I found the Blind Man. However, I receive no speech prompt and have no means of interacting with him.

    I am unable to progress with this World Event. I found threads regarding other issues with this World Event, but didn't find any that discussed the same issue I was experiencing. I have tried these attempts:

    1. Quick saved and reloaded
    2. Loaded an earlier save twice to approach in different ways
    3. Fast-traveled to a different location and walked back
    4. Closed and reopened the game
    5. Completed other world events and quests before returning

    Thank you

  • Scathane
    1 posts

    I've had the You Need to be Anonymous bugin more than one mission. Reloading a previous save (a few saves back) usually helped for me...

  • UbiExcellent
    756 posts

    Hi folks! I'm sorry to hear that all of you are unable to complete the World Event "Miracle" due to this "you need to be anonymous" bug. Are any of you able to submit a video showing this happening? If so, that would be extremely helpful for our teams when they look into this further.

  • EmmaB_3
    2 posts

    Clee Hill Spring AC Valhalla Mystery - Blind & Lame Man Locations - Sciropescire Miracle World Event.

    Carried the lame man to his destination. Spoken to the blind man however he doesn’t follow me. He just repeats his phrase over and over. I have tried pushing him, whistling and he does not follow.

    This a bug. When is it likely to be fixed? 😊

  • Danieljreid1987
    1 posts

    Carried the man up the hill could not put him down restarted the game it worked spoke to the blind guy but he won't follow me over 100 hours in and can't get platinum now why put a game out that's not ready greedy ducks

Suggested Topics