Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ALVI182
    2 posts

    Hi guys! Hope youre doing great
    I have an issue with the World event "the green children of anglia" at the moment I follow the green footprints and find the children, nothing happen, they are just there, I cant talk to them.
    Hope you can help me

  • OdionTheMesiah
    3 posts

    Even tho the update has been rolled out still having the same issue

  • ALVI182
    2 posts

    Same problem here. Followed the footprints from the altar unable to speak with the children

  • rologas13
    2 posts

    @ubisoft Suport staff hi same too me i spend 120 euro and many bugs its unxcepteble for this game its make many studios the game and full bugs im east aglia i complete all mysteries artifacts and wealth axcept green children fixed fast

  • x_kerrywood
    1 posts

    Use the horse and run into them lol that worked for me.

  • SirSmacksYou
    1 posts

    I too am suffering this glitch and have tried to exit the animus simulation, restart the game, switch genders, disconnected and reconnected my internet connection. Everything I can think to do, but I can find no answer to this issue now get a response on how to attempt even, to fix this glitch and I have very few things left to do to get the completionist trophy, so this is very irritating. Thank you.

  • Ubi-Borealis
    Ubisoft Support Staff 1883 posts

    Hello all!

    I've merged together a few similar threads regarding this issue, so I apologise if this has disrupted any ongoing conversation or discussion. Creating one thread allows us to keep all information and updates regarding the investigation in one place. Thank you for your understanding 🙂

    I'm sorry to hear that you're having trouble completing the "Green Children of Anglia" mystery. I can see that the development team are aware of this issue and are currently investigating further. If you have encountered this in your game, please can you provide us with the following information:

    • What was the current active quest when you first encountered this?
    • What was Eivor's gear setup?
    • Can you let us know the steps taken that lead to this issue? This will help the team in reproducing it themselves.

    Additionally, if you play on PC/PS4, the development team would be interested in collecting your save files. Please can you open a support ticket and submit your save for further investigation. Once you have done this, please share your ticket number within this thread so we can ensure everything is forwarded correctly.

    In the meantime, a number of you have reported that if you push the children towards the ladder (using the horse or bodies), this will cause the event to trigger and the mystery to continue. If you haven't already, would you be able to try this to see if this helps you to continue the mystery yourself?

    Thanks all! 😊

    Official Response
  • Larissalock03
    1 posts

    There is a glitch within the side quest: Green Children of Anglia. The first time I got to this quest I actually came across the children first. Nothing happened, so I used odins sight and saw the footprints, I interacted with them and followed them to the sacrifice side mission. I did give the silver, and read the book next to it, I then followed the footprints back to the boy and girl but nothing happened. I decided to carry on with the story as I thought “oh maybe it’ll fix itself”, I’ve tried everything from fast travelling to Norway, to exiting “back to the real world”. Still nothing, I am aware that loading a previous save works to fix it, as I’ve done it on different quests, however I can’t do that now as I’m max level, and I don’t feel like restarting the whole game. Please fix this as it’s the last thing I need to do in England and I complete games fully.

  • Shadowaid2114
    2 posts

    @ubi-borealis can we get a date of fix by any chance we all spent money for a game that we cant complete

  • Ubi-Borealis
    Ubisoft Support Staff 1883 posts

    Hey there @Shadowaid2114!

    I'm afraid that we are unable to provide a definite ETA for a fix to be deployed for this issue. We apologise for any disappointment caused by this. Once we have any new information or updates to share, these will be posted in this thread and within our News & Announcements forum. I recommend keeping an eye out in these places for the most up-to-date news.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details