Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • b4st0un3
    Original poster 28 posts

    Here is the link to the video I made.
    To explain what I did :

    • Go to Ravensthorpe, talk to Randvi and change the quest to Snothinghamscire's arc
    • Go in Norway and save my game
    • Quit the game, restart the PS4, launch the game, load the backup I made before
    • Go back to England and talk to Randvi

    You'll see what happens...

    https://streamable.com/xldeq5

  • b4st0un3
    Original poster 28 posts

    @UbiExcellent
    Just saw a new update will be released tomorrow...
    I’ll download it ASAP and let you know if my issue is solved, or not but to be perfectly honest, after reading the release note, nothing seems to be addressed about my issue...

  • b4st0un3
    Original poster 28 posts

    @UbiExcellent @ubi-borealis
    FYI, nothing changed with TU 1.2.0
    is my issue at least investigated ?????
    I’m facing exactly the very same issue I have for months... how is it possible ?
    Have you ever tough about any compensation for the delay ?

  • Ubi-Borealis
    Ubisoft Support Staff 1402 posts

    Hello there @b4st0un3!

    Thanks for taking the time to tag me in this thread. I apologise for the delayed update. I understand that you're unable to interact with Bishop Deorlaf in "War Weary," as the cutscene doesn't trigger.

    I can see that @UbiExcellent has passed on your report and the video you provided to the development team, who are investigating the issue further. We currently have no new updates to share from the investigation. Once we have any new information to share, it will be posted within the forums.

    Please note that the player support team is unable to offer compensation, as this would be at the decision of the Assassin's Creed: Valhalla team. If they are to offer compensation to players, this will be communicated on official platforms and in-game via notifications.

    If we require any additional information from you, we will reach out within this thread. In the meantime, I would recommend keeping an eye out within the News & Announcements forum for future updates.

    Thanks! 😊

    Official Response
  • b4st0un3
    Original poster 28 posts

    Hello @ubi-borealis

    it's been more than 2 weeks since your reply... No news, my issue is not listed in the last Know Issues post...
    I spend some time on your News & Announcements forum, nothing...

    The last updates/patches didn't change anything to the behaviour of the game.

    Just to be clear, imagine, you go to see a movie in a theater, in the middle of the show, the movie stops due to a technical issue.
    How long would it take for the owner of the theater to resolve the issue before giving back their money to the customers ?

    You sold a game that obviously is not working properly. You tried several times to resolve the issue, i grant you that, but 3 months after, it still not working properly !
    It is unacceptable ! Any company would have refund their customers for a failing device or service.

    Well, you know what i have in my minds
    It is time for you to do something tangible !




  • UbiSucs96
    10 posts

    @Ubi-Borealis @UbiExcellent any update? The bug is blocking progress since December! The game price has dropped so is this how you treat customer paying full price. Ridiculous!

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hello @b4st0un3 & @ubisucs96! First, I'd like to apologize for the lateness of my reply here. Second, I want to let you both know that I've checked on the team's on-going report about this cutscene not triggering properly, but the teams are still looking into this. With this being said, I have requested an update from the teams, which we will post here once we've heard back.

    Official Response
  • Stewart_001
    4 posts

    1.2.1 has done nothing regarding this bug. This has been a problem since December, how has this not been fixed yet? I refuse to go back and replay 40+ hours of progress. Either fix the bug or refund me my money!

  • b4st0un3
    Original poster 28 posts

    @Ubi-Borealis @UbiExcellent

    As it was said just before, the new update doesn’t change anything to the issue, once again…
    How long will it take for you to admit you are totally incompetent to solve the problem ?
    It’s been more than 4 months we are waiting patiently for a solution.
    You have no answer to provide us but the dev team is looking to your problem, wait and go to the forum to seek for an answer… how this can be possible ?
    As I said before you sold us a product that is not working properly so take actions now. All companies around the world would have done better than you.
    Your dev team is a fraud, releasing a game with bugs and not being able to solve them for more than 4 months !!!!
    I also do want a full refund of my money !

  • UbiSucs96
    10 posts

    @b4st0un3 even worse - there are working on the new paid content ignoring users like us.

Suggested topics

Community details

37
Online
124.1k
Users
21.4k
Topics
110.2k
Posts