ubisoft discussions

Quick Suggestions

  • s10cameo
    13 posts

    I'm having the same problem on PS4

  • G0DAPE
    4 posts

    yup getting this too switching on and off doesn't work either

  • JRW28451
    1 posts

    Today I cannot assassinate any opponent, not even an archer; all of them are showing as stronger than me and requiring at least 2 hits. Yesterday I assassinated 46 towards my 100 target. My power is 406, 59 Mastery points and all skills completed. Is there an issue?

  • jetblackfighter
    34 posts

    Same. Playing on ps4. Tried with toggling the mode off as well, and re-engaging guaranteed assassinations. No luck.

  • MaxCrasher1992
    1 posts

    I have it turned on in the stealth settings. But every time i assisinate an enemy i have to do the button press. This has started happening after the most recent river raid update. Am i the only one who is having this problem?

  • Marta97M
    22 posts

    @maxcrasher1992 You're not the only one


  • MK_2014
    14 posts

    Yeah I have the same problem too on PS4.. I noticed first time when I played and tried to solo raid on raid river mode, as I have to do the Ubisoft connect challenge 100 Assassinations.. I'm like Level 352 and the Assassinations like 155 dmg.. I was surprised that qte appeared for every type of enemy including the weak ones such as Archers.. even if I'm level 352 I can't Assassinate someone with level 10.. it's definitely bugged, I tried to enable disable guaranteed Assassinations on and off still the same, enable and disable Advanced Assassination from skills tree still same.. it's bugged as it only kill in stealth mode which means you have to do qte, won't prompt the Assassination, it's like stealth + Assassination, not fully Assassination, and yes might be because of river raid mode.. I hope they fix it as soon as possible, because without Assassinations I don't think I can play this game.. and we can't wait for another update to have something important fixed.. it's like the Assassination disabled from the game ..

  • t_wil
    2 posts

    My guaranteed assassination does not work for some reason. It worked fine before I got the new update. Now it doesn’t work at all.

  • ThaScorpionKing
    7 posts

    When I go to use the assassin's blade for a assassination on every npc it gives me the slow down ring. Doesn't matter if it's a boss high level or low level. The only time it doesn't do this is if most of the health bar of the npc is gone then you can assassinate it. I delt with the drunk character during the yuletide and 16 arrows. Now on top of that I get to see all the work I put into my Spartan bow is gone....?! I can deal with the blue screen boots that kill my entire game and make me reboot the game and lose any progress I had or the days I couldn't get anything from the store or Reda. Please fix this problem I'm going crazy.

  • Magpye
    16 posts

    @thascorpionking I’m having the same issues with assassinations. Since the recent update, guaranteed assassinations no longer works. I get the slowdown ring even when guaranteed assassinations is on. I’m using the Xbox Series X version of assassins creed Valhalla.

  • braga_assassin
    8 posts

    after the latest update i am unable to one hit assassinate anyone even with the option of guaranteed assassinations

  • dylanorr1372
    1 posts

    Ever since the update that brought river raids, the guaranteed assassination option is permanently off even when it says its on.

  • braga_assassin
    8 posts

    @dylanorr1372 i also have this problem

  • braga_assassin
    8 posts

    @magpye i also have the same issue on ps5

  • braga_assassin
    8 posts

    i´m also having this problem, but i could swear that yesterday while doing river raids i could one hit assassinate but today i just couldn't.
    and yes i tried switch the guaranteed assassinations on and off and nothing works

  • rctx81
    12 posts

    @s10cameo same, power lvl 404 currently and having the QTE displayed on every single NPC and dummy

  • ThaScorpionKing
    7 posts

    @magpye yet for some reason when I went back to my first game that I beat the game with I had no problem. I'm so confused as to why this is happening to us lol

  • cld1974
    1 posts

    This is happening to me even with the dummies in Ravensthorpe.

  • longjohn119
    1340 posts

    @rctx81 Well that explains why the two attempted assassinations in a fort didn't work ..... I hadn't played the game in a month or so and haven't even tried to assassinate anyone for more than 2 (I'm just testing patches to see if things are fixed) so I thought it was just me ..... It was really frustrating considering I did a one shot assassination of Cultist Kallias in Odyssey the night before with a pure Hunter build (Got lucky and got a Crit) and the next day in Valhalla I couldn't assassinate a gnat

  • JediSlayer05
    14 posts

    Same thing here on PC. It's very frustrating....

Suggested Topics