Welcome to discussions

Quick Suggestions

  • Melrsa
    1 posts

    I just came across this problem while playing. After search online to see if others had the same problem I found this discussion and thought I'd let you know that I can't proceed either. I'm a completionist so this is a little annoying that I can't get it done. Hope it can be resolved soon but I see it's been a persistent problem for a while.

  • Alyssa0
    1 posts

    Hey I am still having an issue with being unable to speak to the priest in this world event. I have over 140, almost 150 hours in this game and would like to have this resolved. I personally believe that this should have been resolved a while back but the most recent update that was supposed to solve the issue has not fixed the issue. Starting from the beginning is not an option for me, or anyone else in this forum. I am playing on a ps5 if that makes any difference.

  • SuomiKissa
    12 posts

    .
    Same problem / bug. I can't talk to the monk. There is no dialogue bubble.

    I remember the area when I ran past it on the way to Wincestre and then it showed a speech bubble, but I didn’t stay to do it.

    Conclusion The mission is broken if it leaves the area without doing so. The fault also suits the blind man and the ramp man who also had me broken.

    280h behind with a new game, just because the previous one had broken missions. Pisses me off.

  • guest-4pQ8uQvz
    1 posts

    Same issue with my game...on XBOX Series X and the latest updates.

  • guest-8lRqdANo
    1 posts

    I also have the same issue. My game is up to date, but the priest still has no speech bubble and there is no way to interact with him. I'm getting really close to the platinum and I don't want this quest to ruin it for me 😞 I play on PS4 btw.

  • DarkSilhouete99
    1 posts

    PC player here, same issue. Walk up to him, he says the same 3-4 generic lines over and over, but no matter what I do I cannot interact with him. Game is fully up to date.

  • Sunnykid1256998
    1 posts

    I have over 100 hours in the game and this is THE LAST event I have to do for the avhievement and it is STILL broken in the newest update. I go up to the priest, but there is no option to speak wih him. When are they going finally fix this??
    as someone who has played every assassains creed in the franchise, I expect better from them.

  • ezglide3
    2 posts

    Can't speak with monk. Says same few lines over and over again. All NPCs are immune to any attack. Meditation does nothing. Fast travel and back no changes. Save and quit does nothing. Currently at 163hours in.

    Have a save file from before I ever encountered the world event (roughly 151 hrs in). Will give it a try and see if I can complete.

    BTW, another user said that if you speak to the monk when he is in the water, this will glitch the NPCs and remove any prompts for speaking to monk. This is what happened to me. Monk was in water talking, I replied and then followed him to his location next to the water and that is where he remains bugged.

  • ezglide3
    2 posts

    Update: Loaded the older save before ever discovering Hamtunscire or Wincestre.

    1st attempt: Fast traveled to suthsexe and rode horse to location. Still unable to speak to monk. All NPCs immune. No speaking prompts

    2nd attempt: Loaded same file (before discovering either area). Fast traveled to dock at Glowecestre. Took horse to location point. Same issue. No speaking prompts and all NPCs are immune.

    Thought maybe riding through Wincestre and getting the autosaves might cause an issue to occur, so I tested that idea but ended up with same results.

    Since I had not discovered either Wincestre or Hamtunscire prior to patch 1.2.2. It appears the issue was not completely resolved.

    FYI: I am a product owner for IT. I know debugging is a pain.

  • Henksel
    1 posts

    Hi,

    downloaded latest patch and i have also the problem that the priest doesn’t have the speech bubble. Tried reloading different save points. (10H back) and it stil does not pop the bubble. Hope that this is resolved with the next patch. Can’t get the plat because of this. It is sad and frustrating that this game is so extreme buggy with the many hours you put in this game 😔. Im playing om PS5.

    Henksel

  • KITT3651
    1 posts

    Saint faith still bugged on ps4 last one for 100%

  • ShakeThatBear14
    2 posts
    This post is deleted!
  • carcrasher34
    1 posts

    Saint Faith glitched for me. 104 hours in. Ps5. I knew giving Ubisoft a chance again would somehow come back to bite me. Paid full retail price for this game. Talk about regrets.

  • DaTechnoD00d
    2 posts

    Same issue with me: PS5, 167 hours in the game to date, NPC speech bubble won't appear to start the world event.

    I made periodic saves throughout my playthrough, so reloaded a previous save file, from when I was at the Essexe arc (118 hours). I tried going to the world event but it was still glitched.

    I was planning on buying the season pass after getting the platinum trophy, but until this bug gets patched I don't see that happening. A shame too, despite its many flaws the game was somewhat fun up to this point.

  • digaormt
    2 posts


    The problem remains, even after upgrading to version 1.2.2 we couldn't complete this mission, we just need to complete it 100%, very sad about it, how many complaints we have about this matter for so many months without a solution.

  • digaormt
    2 posts
    This post is deleted!
  • ShakeThatBear14
    2 posts

    I play on PS4. I have the latest patch (3.20I), and I cannot start the Saint Faith world event. There is no text bubble above the priest when I arrive at the island on the pond. Instead the priest just says the same three or four things on a loop. He does show up blue when using eagle vision, , but not able to start conversation. I included a clip so you can see I had not been the area before that (since the location marker is still a dot and not a world event icon), however there are dead bodies in the water that I have not seen in other gamers videos. 

    I’ve tried every common known fix:

    fast travelled to Norway/Vinland.
    Changed genders. 
    Left animus and re entered.
    closed the game and restarted.
    i tried an earlier save.

    I had just finished the new Mastery Challenges and was going to make my end game run. With the amount of time I sunk into this game, this is very disheartening. I’m an completionist and a trophy hunter.. This is keeping me from platinum and I don’t have another 200 hours. Please, this seems like an issue that is effecting your customers whom it would hurt the most. People who dedicated significant time to your product. After going the distance to 100 percent a game of this size... not fixing an issue like this would make it hard to pick up another Ubisoft game in the future.

    Please. Help.




  • mralexan11
    2 posts

    Can confirm this is also still happening to me on ps5 post patch. Like many other I am a trophy hunter and this is the only thing preventing me from getting the platinum.

    To make matters worse this glitched event occurs in the very last region of the game after I already spent 110 hours slogging though this unnecessarily bloated game. Like many others I don’t have the time of patience to restart the game and complete every region all over again, it was already painful and boring enough doing the first time.

    its embarrassing that this has been an issue this long and Ubisoft still hasn’t fixed it. I intentionally held off buying this game so bugs like this would be worked out. Based on my experience with this game I will never buy another AC title ever again. And based off of Ubisoft’s incompetence with this issue I will think twice before ever buying an Ubisoft title ever again as well.

  • MCYarali64
    1 posts
    This post is deleted!
  • VeryStableGamer
    1 posts

    Bugged here as well on PS5 with 131 hours in. Just cleaning up missed quests and can't speak to anyone to proceed.

Suggested Topics

Community Details

77
Online
195.9k
Users
33.2k
Topics
165.7k
Posts