Welcome to discussions

Quick Suggestions

  • MasterWicha
    1 posts

    I'm also having this bug even after the latest update, I haven't even encountered the event before the update, this is one of the last things that I need to complete for platinum achievement ,Please have this fixed as soon as oossible, I am trying to complete it for a couple of days already, tried pretty much every possible recommended fix. at this ppint if you cannot fix this or do not care just provide me the save game with with all completed mysteries so I can complete the achievement, yes I'm that desparate, remove it, switch it to atone cairn quest, I don't care, at this point I'm not even interested in the event itself, please help, I want that mistery marked as complete and off my map

  • bdon48jc
    4 posts

    @masterwicha I agree. Ubisoft - quit trying to 'fix' this by sending through the development team cycle that takes waaaay too long to get anything accomplished. Just remove the damned quest and put a cairn there or just give us the completion.

  • h1ck0k
    4 posts

    Hello,

    Im also having the Saint Faith issue.
    I'm playing on Xbox One S, and I first found the mystery two days ago, so definitely after the Title Update which should have fixed it.

  • danbton
    1 posts

    also having this problem. doesn't seem any way to get the speech bubble needed for this to work

  • MichaelGG66
    8 posts

    Same problem for me: I'm not able to talk to that baptist.
    PC - Windows 10
    Patch 1.2.2

  • CPMcG1996
    2 posts

    @ubi-keo Why can’t you be straight with this issue? This has been know and reported since the games release. It’s a gamebreaking bug at the end of the game which is likely one of the last things for most players. I’m at 130 hours and am presented with this wall, it’s just a joke.

    Just vaguely saying “it will be fixed in a future update”, “the team are working on it” when this thread was created in January is shocking and complete lies. You’ve released two major updates adding to the game but overlook a simple bug fix? This is surely a day job - complete disregard to the consumer and laziness incarnate, there’s no two ways around it. Just speechless.

  • LaiskaPummi
    1 posts

    I also have this issue on PS5 (PSN: LaiskaPummi).
    I cannot talk to the priest. There is no speech bubble option.

    I was working really hard and diligently throughout the game to complete every region to eventually get the trophy and then ran into this problem in the final region. Feels like a waste of time even though many of the mysteries have been fun and memorable. Shame about the trophy.

  • Crispin27
    1 posts

    Also having the "Saint Faith" world event issue on the PS5, and it's persisted for a while now (even through the latest patch that had a fix for this issue).

    While I'm happy to learn it's not just me, it sucks that it's affecting so many. I've tried many things such as:

    • Reloading a few previous saves
    • Reloading a save from early in the story (15-20h in) 
    • Changing gender
    • Travelling to Vinland
    • Travelling to Norway
    • Meditating
    • Meditating, then loading the quick save
    • Leaving / reentering the animus
    • Closing the game entirely
    • Throwing bodies to knock the NPCs over
    • Catching the NPCs in enemy AoEs
    • Attacking the NPCs with various weapons / abilities


    However none of them have worked. It's actually the last thing I need for the platinum now, so it's kinda frustrating. I really don't want to restart 100%ing from the very beginning.

  • guest-iF90YCfC
    1 posts

    I I am encountering the same glitch on Xbox One. The monk is standing in the correct position repeating generic dialogue, and I can't interact with him. I have installed the latest patch before I even discovered this mystery but it doesn't seem to have stopped the glitch from occurring. In fact, based on this thread I'd say the latest update has only increased the bug's occurrences.

  • Skurkitty
    2 posts

    Experiencing the same issue of not be able to speak with the Priest, he just continues his general dialogue with no prompt to speak with him.

    Platform: PS5
    Version: 1.022.000
    Troubleshooting Tried:
    -Reload previous saves
    -Leaving the area and returning
    -Exiting and Entering Animus
    -Changing Gender
    -Approaching Priest from several different angles
    -Reinstalling Game
    -Uploading save to cloud, deleting from console, downloading save

    Nothing I do will trigger the ability to speak with the Priest. My save is at 77hrs currently and I've just been clearing the map (even the non required loot chests with iron/leather). So there's no chance I'll be restarting. I truly hope this is still being looked into and fixed in the near future, as the support responses seem to have stopped in this thread. Very frustrating to have one quest locking myself (and others) out of their Platinum/100%.

  • Dalt1n
    1 posts

    I am playing it on a PS4 and can confirm the glitch is still there. Just got to the mystery for the first time and can't interact with the priest whatsoever. Already reloaded plenty of times and relaunched the game, nothing works. Fix it ASAP, Ubisoft.

  • Ubi-Keo
    Ubisoft Support Staff 2387 posts

    Hello Vikings!

    I can confirm that the development team are intending to fix this with a future update, however we have no ETA on when the update will be released.

    Please keep checking the known issues list and the news and announcements page for updates.

    Official Response
  • Stylez226
    2 posts

    Hello,

    I'm having trouble trying to start the mystery quest Saint Faith. When I approach the NPC there isnt a speech indication icon used to start the event. I've tried restarting my game on Ps5, changing locations, re-entering the animus and still I cannot start this mystery event. It's directly to the left of Wincestre in Hamtunscire. I don't have any past saves to go back to and it's stopping me from getting my platnium. Any advice would be apprdciated

  • sneakybeaver202
    1 posts

    experiencing the exact same bug others have described here, can’t speak with the npc to initiate the world event therefore can’t get my platinum trophy. Please Ubisoft fix this! Guess I’ll play the DLC and hope it’s fixed in the next update!

  • TheFluffs.
    6 posts

    @skurkitty Saint Faith is the very last thing on my map as well. Cleared ALL chests even the small ones with Iron and stuff. Only thing left is that dumb Nun that won't die. Real shame a speech bubble bug is gonna ruin that. Should take them like 10 minutes to fix with the size that Ubisoft is and how big their Valhalla team is. I mean we are over 15 people that have complained and we have already been recognized so they know about the issue. Such a same.

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there,

    Thank you for continuing to share your reports and experiences with "Saint Faith" following TU 1.2.2. I apologise for any disappointment that has been caused following this update.

    As shared earlier within this thread, the development team have been investigating what could be potentially causing this issue in-game further. They have announced that they intend to release a fix for this issue in a future update. We don't yet have an ETA for when this update will be deployed. As soon as we have any new updates to share with you, they will be posted within this thread or within the News & Announcements forum.

    Thank you 😊

    Official Response
  • DragonWarrio136
    1 posts

    Hi i am having problems with the world event Saint Faith i cant interact with the world event and its the one thing i need to get the trophy for completing all territories i have tried leaving the area and coming back, closing the game and nothing seems to be working so can you fix this please Ubisoft

  • PlayToes
    5 posts

    Not working for me ps5. Can't speak to priest. PS5 up to date have tried various things to no avail. Please fix as preventing completion

  • Stylez226
    2 posts

    This just happened to me and stopped my Platnium Throphy. Can't talk to the priest. Hes illuminated blue with Odins Sight and talks outlook but doesn't give me a speech icon to start the mystery.

  • captainall
    3 posts

    This just happened to me too, can't talk to the priest. I hope this gets fixed soon.

Suggested Topics