Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Gladeel
    4 posts

    Same issue, equiped the torch. Still didn't work. ๐Ÿ˜•

    Can you guys tells me if the loot is important here or not? Thank you.

  • Gladeel
    4 posts

    Same issue, modified the framerate, equiped the torch as mentioned here. Still didn't work. ๐Ÿ˜•

    Can you guys tells me if the loot is important here or not? Thank you.

  • CapCheeks
    40 posts

    @gladeel It's the first Drengr that you can fight. I don't think there's any loot per se or maybe he drops something after you defeat him. Can't recall.

  • Gladeel
    4 posts

    @capcheeks Thank you for your quick answer. ๐Ÿ™‚

  • dbgager
    158 posts

    thats not the only way in...I entered through a path of jumping on ledges and paths in the cave. I did leave by the crack though. Might have even been a different cave entrance. not sure.

  • TheBlazinM3nt0r
    1 posts

    Yea I am also having the same issue, last thing I need to do in the region.

  • SoloTheLol
    1 posts

    Guys I found a fix, hopefully it works for you too:
    Go to settings and lower your FPS (I put it on 60) and try again

  • Costatiax
    1 posts

    I cannot seem to walk through the second barrier in the cave (that forces you to go sideways) when I want to get to Erik Loyalskull.

  • znizzel
    1 posts

    On attempt to pass through the cavern hurdles in hildevini's crag they push me back, blocking the path and not giving access to this area for the world event of the lost drengr Erik Loyalskull. I don't get any message of the sorts that this content should be locked, so I'm assuming its a bug. I restarted the game and everything but the bug stays present. (added a screenshot of the obstacle, as a gif was not allowed to be uploaded here)

  • stoned019
    Original poster 19 posts

    @solothelol there is another entrance on the other side an actual entrance

  • LtCommander417
    1 posts

    I'm having the same exact issue too. Wife was able to do it on her game, but I "teleport" back outside the crack in the wall too. Oy vey.

  • AceProps13
    1 posts

    There is a bug at the location of Erik Loyalskull. In the cave your character needs to pass through a small thin opening in the wall. When I do this however my character glitches into the wall and is forced out the same side I tried to enter from. This made it impossible for me to get to Erik Loyalskull. Another possible bug I noticed while playing, is when I am pulling/pushing an object like the large bookcases my character can not let go of the item, causing me to have to load a previous save.

  • Shadowbreather
    4 posts

    if your on pc hold g to pull up your horse and stuff and use the torch it will let you pass through the opening im having a different issue after i beat him i cannot speak to him also having the same issue with the rolf the raider quest get it done and cannot speak with him either :S

  • Schmittarn
    3 posts

    @gladeel There is another cave entrance at the other end, up the hill. Can't remember the loot though ๐Ÿ˜‘

  • Brynjar_Odinson
    22 posts

    had this too. if you pull out torch and then walk trough it works

  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    @solagratia83 Hey there, sorry to hear this! Do you not get the button prompt? Could you please provide a video of this issue? The developers area ware but a video would help.

    Official Response
  • darlnv
    1 posts

    You are right. There is another entrance. I left over it after. This one is just easier to find.
    Torch did the trick for me too.

  • Eog4rd
    7 posts


    I had the same issue and found the answer on youtube. You have to limit your framerate to 60 and you can go through. Very weird bug.

  • Adrianjwleong
    4 posts

    @solagratia83 I have the same issue as well, kept pressing space bar until I managed to jump through. On another occasion I was stuck between and couldnt move. had to load an earlier game.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Hi guys,

    Thank you for reporting these issues to us.

    Glad that you've been able to get around this with a few workarounds.

    Could anyone confirm if they have tried using the Torch and locking FPS if you are on PC, and this didn't allow you to progress?

    Official Response

Suggested Topics

Community Details