ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to proceed with "Pilgrimage to St. Albanes" as the cutscene does not play after rescuing Fulke | POST HERE

    0 Likes/185 Replies/6426 Views
    3 posts

    Come on man both pilgrimage at St. Albans and chipping way missions at oxenfordscire are not getting tracked similar problem to the one like seers quest resolve these issues.

  • Shadows.k
    1 posts

    I started a Raid while i had the Quest active but now the Quest doesn't track anymore and no cutscene will play if i enter the Cell. Please fix this Bug Ubisoft.

  • ErickLeftazs117
    6 posts

    I raided the settlement and killed everyone, expect the monk. When i left him alive, he gave me the keys. After the conversation my fellow vikings killed him immediatly. I opened the door and... Nothing happened. Fulke just stand there, and did nothing. Sigurd and the assasins go outside of the church and staying there while do nothing. What went wrong? I can't load a previous save, everything is overided by the automatical saves while i did everything to make the quest run again. I'm playing on PS4. Thanks in forward for everyone!

  • jdolan06
    5 posts

    I had to restore an old save and lost 5 hours worth then had to redo everything up to that point. It worked the second time I tried but it was very tough stomaching the loss of progression.

  • Ubi-Baron
    Ubisoft Support Staff 796 posts

    @ErickLeftazs117 Thank you for reporting this to us.

    This is an issue we have passed on to the AC team to be looked into.

    To help us with this, if you are able, please providing us with a copy of your Save Files through the Support Site here

    The save can be located here:
    Settings > Application Saved Data Management > SAVED DATA IN SYSTEM STORAGE > Assassin's Creed Valhalla

    Official Response
  • Yaros811
    1 posts

    After finding Fulke in the crypt, I open the door to her but nothing happens. No Talk option nor a cutscene. Can't progress without her, haytham and Sigurd stay outside of the monastery and can't talk to them either.

  • zKingSparTaCx
    3 posts

    Hi there!
    Unfortunately I can't progress the story at Oxenefordscir "pilgrimage to st. Albans" where I have to rescue Fulke.

    After you're in the basement of the monastery's crypt you speak to a priest who has the key for Fulke's cell. After I got it from him by using my Charism I opened the door but the cutscene wouldn't trigger in which Eivor, Sigurd and Basim speak to Fulke.
    I can just open the cell and walk in on Fulke but nothing will happen, she never moves. And Basim and Sigurd just left the room and went outside.
    I tried a few things but I can't progress anymore maybe you can help me!

    I'm playing on playstation 4 if it matters


  • LoonScan
    7 posts

    I'm having the same issue on PC. I'm on patch 1.0.2.

    Some more details (not sure if relevant):

    • I was in a Raid when entering the basement
    • The talk with the Monk happened and I have the key. After getting the key, the Monk got killed by the raiders
    • Both Fulke, Basim, and Sigurd are just standing around. Fulke in her cell. Sigurd is in the basement and sometimes walks up to the Church door.

    Here are a few screenshots:

    I have also tried finishing another region first and coming back but I'm right back where I started. Also reinstalled the game, fast travelled to Norway, left the animus, as well as some other stuff that was mentioned in other issues.

    My earliest save before this one is 15 hours back 😞

  • ErickLeftazs117
    6 posts

    Sadly, i can't. How much time it will approx.? Thank you at forward!

  • wbm20
    3 posts

    @northoto i am having the same EXACT problem. Please let me know what they say to do

  • wbm20
    3 posts

    Fulke is in her cell, looking down, and I cant talk to her, she won't me, Sigurd, Basim, and her just stand there. I can't load back a save because my last save before this mission was at least 6 hours ago. I had to restart my game after the mission "Seer Solace" and im not loading back a save. Any help would be appreciated

  • Ubi-Swaggins
    Community Manager 438 posts

    Hey there,

    I am sorry you have encountered this issue.

    The team has been made aware of it and they are looking into this further.

    Apologies for any inconvenience caused, once we have further info we will share it.

    Official Response
  • Kkauan191
    1 posts

    i'm unable to progress the fulke, mission i can't talk to hear in the crypt

  • L8v3lyn
    39 posts

    @ubi-baron this is really annoying. After finishing the raid and got the key there is no cutscene after i unlocked Fulke’s cell and she just stays there. So I went to do other quests and raiding still no progress after I went back and check Fulke. Grrr... please help. Dont want to restart the game 😞

  • L8v3lyn
    39 posts

    @wbm20 please let us know what they say. Dont want go back too ☹

  • m4g-tul
    1 posts

    @zkingspartacx I have the same bug and nothing helps. also the second quest of this arc, „chipping away” doesn’t progress to cutscenes either... eh I’m so done

  • L8v3lyn
    39 posts

    @ubi-baron hi pleas elet us know if there is a patch or something needs to update or what so we can progress the game. Thank you.

  • heartattackGuy
    6 posts

    So update for you guys, for me at least the patch hasn't done anything. Quest is still bugged.

  • LoonScan
    7 posts

    Patch 1.0.4 did not resolve this issue for me.

    Something I noticed but forgot to mention in my previous post. The eagle vision is showing me that the monk still has the key but I can't loot it.


    I've submitted my saves in the support page.

    Also, I'm never buying an Ubisoft game on launch again.

  • guest-kbe5PSKH
    1 posts

    @zkingspartacx did you end up getting this issue fixed? I am also having this issue

Suggested Topics