Welcome to discussions

Quick Suggestions

  • AlZaGhoul
    2 posts



  • NIGHTSTALK3R150
    1 posts

    On my playthrough I manged to stun attack fenrir and then all of a sudden he's on the other side of the mountain and now there's no health bar or nothing and all 5 of my autosaves with the fight are just the same with me trapped in the circle and no way out! The earliest I can go back is 5 hours without it being glitched!

  • StateOfApathy
    2 posts

    @nightstalk3r150 Fight him where Tyr was sitting prior to the fight. Try not to leave that area. If you must grab rations/arrows, stick to the edges and only grab what you need while he is above ground, then get right back to that spot.

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    @stateofapathy Thank you, that's a great workaround.

    We hope to have a fix for everyone soon! ❤

    Official Response
  • kimscott1
    1 posts

    Fenrir got stuck for me as well and on a second attempt when he got stuck, in my frustration is started shooting arrows at the ground where he was stuck and i noticed that he moved toward me when i did that. So long story short, i stood on the log Tyr was sitting on , Fenrir came to me and being so close to the edge he popped out of the fighting area so i ran to the other side of the area and he jumped back into the fight zone and i was able to kill him.

  • dave_84
    1 posts

    Putting Higher graphics and capping the fps to 80 did the trick for us, Fenrir goes underground but comes back normally. ON PC*
    turning on motion blur migth help. For some reason, the game looked more fluid with the capped fps....

  • Outlander1982
    123 posts

    @rooster-roost I don't know if you finally got through the quest but after two days of frustration of not playing the game,I don't know if I was lucky or not but locking the fps to 60 did the job,I was able to do the mission first try after doing that.

  • Smoolio
    1 posts

    Still waiting on that patch, pull your finger out please. The workarounds dont work for me, Ill give it a few more days of trying then im done.

  • SpiritpPotato
    11 posts

    I finally got to the end of the second Fenrir fight, and when I delivered the final blow, I got shot out of the world and died, and didn't get credit for the victory.

  • Tunes999
    1 posts

    this is incredibly annoying. I see its been noticed for 8 days at least. Huge mood killer.

  • harmo40
    2 posts

    I've just encountered this as well. I can damage him for some time and then at some point he goes into the ground and continually circles around the battlefield. I've tried dying to him, waking up, reloading save. It happens every time i fight him and it always early into the fight, before i can even get a third of his health down. (PC if that helps at all)

  • AlZaGhoul
    2 posts


    still existence is not possible to move the story
    (after update pc 1.04)

  • Schoujagd
    3 posts

    The Issue is still not fixed. Fenrir is stucked under ground.
    So sad 😞

  • farls1981
    9 posts

    I can't travel to asgard now without desyncing straight away, it's completely broken

  • Qcbanane
    1 posts


    fix bind spell please

  • DelleWaps
    1 posts

    Hallo im at the fight with the lost wolf and it keep´s going undergrund any fix to this

  • Tea.--
    1 posts

    same problem! when do u fix it? fighting and trying everything i found for like 6 hours. i cant take it anymore. really..

  • MrClap
    3 posts

    I am having the same exhausting issue... keeps circlign underground forever in the second part of the fight. I have tried staying in the Tyr spot but he still stays stuck. I manage to make some parts of his body pop out on the edge of the map but only for half a second and I won't do any damage to him.
    This really should get fixed soon or I want a free season pass 😞

  • MrClap
    3 posts

    He hits me once and after that i can walk through it without getting hit.

    Oh and now I've got this ^^

    https://streamable.com/0rpufp

  • MrClap
    3 posts

    @ubi-raziel You guys please fix this 😞 even today's update didn't do anything for this major bug ...

Suggested Topics

Community Details

72
Online
191.2k
Users
31.9k
Topics
160.8k
Posts