Welcome to discussions

Quick Suggestions

  • XxXBatmanXxX
    6 posts

    Absolute garbage game that this is in the final release of the game. What absolute trash. You have known about this for over 2 weeks and have not fixed it. What a joke.

    /Even worse, it was in BETA and NOT FIXED.

  • l2ockl2oll
    1 posts

    @ubiexcellent same issue here it keep going underground please do something

  • justin.j.simmon
    1 posts

    I had a glitch where during the Binding Fate fight, Fenrir gets trapped behind the mountain and doesn't come back. I "woke up" to continue playing the game. When I try to go back to Asgard to try again, it acts like I left the fight area and desynchronizes and makes that mission unplayable. The rest of the game outside of Asgard seems to be fine but I believe that is one of the required missions in the game.

  • limpepneo
    3 posts

    Having eh same issue, it just goes underground around and aroud.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Thanks for updating this thread, W0ffeh and l2ockl2oll. I'm happy to say that this bug is slated to be resolved in an upcoming patch! While we do not have a more approximate timeframe to provide at the moment, I do hope this brings you both (and anyone else that's facing this issue with not being able to defeat Fenrir) some relief. 😊

    Official Response
  • GaaDunkGaAhab
    1 posts

    i still cant progress.... i have opened a thread for that already but no response and its not in the "under investigation" tab

    its impossible to kill fenrir because he does his "dig underground like an autistic mole" attack an does not come back up

  • Bushwickedly
    109 posts

    First time I fought him, he exited his arena on the cliff edge, and just did that stupid underground thing in place and was invulnerable, because you know, tunneling wolves formed from bestiality were a thing in England back then apparently.

    Other issues (was before 1.04 so dunno if an issue) was it'd reset it's health, it's arena border was buggy, etc.. I dodged it's tunnel attack near the edge of the arena border, and it reset his health because it stated I left the arena. Was like level 40 then, so it was a big deal.Terribly buggy fight. Would think they'd prioritize earlier quests and locations considering a larger chunk of people will be doing them.

  • Zeus-X-Machina
    10 posts


    had the same problem, read somewhere that you should not skip the cutscene before the fight and it worked for me, hope it helps

  • smooth_suave
    1 posts

    @xxxbatmanxxx Agreed, just shows how all these companies are greedy these day, and don't care about the final product. It does not take long to see how this game is infested with bugs, but did they care to try and fix it no, and they are not worried about it now as they already got our money. And I just dealt with the bugs cause I wanted to see this trough, but now its preventing me from continuing the story. Happy I didn't get the season pass. They, don't deserve anyone's money. At least Cyberpunk will be out in a few days, CDPR has no issue delaying a game to ensure a better final product.

  • XxXBatmanXxX
    6 posts

    True Smooth. On top of that, there are 31 challenges, of which, 2 do not work in the game. There is no Swordfish in the game and there is no ability to revenge a player like other games. How is the later left out? It is in previous games. Also no achievements. I feel this was majorly rushed to market as they thought Cyberpunk was going to originally released at the same time.

    Valhalla shelved, probably won't come back.

    Onto Cyperpunk, which is preloading in 2 minutes.

    /Even worse, the bug isn't mentioned in the MegaThread of issues, so it will never be addressed.

  • XxXBatmanXxX
    6 posts


    You have known about the Fenrir underground bug since early BETA according to HUNDREDS of threads about the issue.

    Why is it not listed in your MegaThread of known issues or in the known issues list?

    Many videos have been posted of the issue.

    Take 2 minutes and read through the threads or go to Redditt.

    Game breaking.

  • XxXBatmanXxX
    6 posts



    Your response was WEEKS ago and the bug isn't listed anywhere in your documentation.

  • Co11ision
    1 posts

    Had this for ages, various bugs, fennir got stuck mid ground, but was able to range his neck - game crashed at the end.
    My next attempt was going well, until I clicked "raid" and got thrown across Asgard in the air for good few seconds until desynchronized and died.

    Not going back to this until it's fixed - might be never as Cyberpunk is being released and that's a company I can trust...

    Ffs, Ubisoft, stop being a joke.

  • oWallis
    1 posts

    The boss fight in Binding Fate is still bugged. No matter what I do or how far I can make it into the fight, eventually Fenrir digs underground and stays there. To the point where he doesn't even do damage to me if I run right into him. I uploaded a video of it to streamable https://streamable.com/1zp1b4

  • Souky271995
    2 posts

    Hi are there any fix for this bug ? ... because its really frustrating stuck in the boss fight

  • Souky271995
    2 posts

    @souky271995 And by the way ... if i try to jump on mount on the edge of the circle i leave it ... the Fenrir reapear on the ground but that will cause desynchronization. And on forums i read that this bug is appear month ago but still not fixed ...

  • eemmrraaoo
    1 posts

    When Fenrir did his underground attack at half hp, he completely glitched out of the arena and is in the lake. I was stuck in the combat zone. Tried reloading saved game in Raventhorpe and i appeared in the exact same position after Fenrir glitch. Opened load game to reload again, the save game i used was overwritten with my current progress.
    However i load one that was 4 hours before the boss fight, same thing again and overwritten.
    My only hope was to fast travel out of there to the big tower-throne, wich worked.
    Upon my arrival, the screen goes dark red (like red when low health) and Eivor dies. Reload from last checkpoint, instant death.
    I now could use the Wake up on the eye icon in the map wich i used. Got back to asgard after 1.04 patch (4days later) and still die instantly.

  • Hunt_Ells
    2 posts

    I've tried every work around possible, even reinstalled. This is embarrassing honestly. Ubisoft needs to get it tf together. Unbelievable that I paid for a game this broken. Shame on you ubisoft.

  • UncoveredPluto8
    2 posts

    Dec.8 and its still bugged. I get to when fenrir has a quarter life left, after the binding and he jumps over the cliff and never comes back. This has happened 3 times now.

  • UncoveredPluto8
    2 posts

    I went back to ravensthorpe, then drank the potion to asgard again and I had no trouble this time around. Fenrir didn't bug out once. Strange

Suggested Topics