ubisoft discussions

Quick Suggestions

  • caliban99
    4 posts

    Same thing has happened to me. Can not fox it so far. Please help Ubisoft

  • BekkerJs
    7 posts

    The binding fate quest is still BUGGED.
    After talking to Fyr the screen turns towards the tree but then Eivor returns in the screen.
    After that I cant move my character anymore...
    Quest does not start.
    Please fix I cant progress in the game anymore....!!!!!

  • gforceman7
    2 posts

    When approaching Tyr in Asgard under the Blinding Fate quest, after the scene play, Eivor stays stuck and after a few seconds the camera changes position and Tyr comes back and sits on the log, but Eivor stays stuck and cannot move. Therefore, I can't proceed to battle Fenrir.
    Can anyone please help??
    Even after the update it is still not fixed.

  • roby_robert
    1 posts

    Please tell me you found a way to fix this, I just encountered this bug too

  • silviuflorescu
    4 posts

    Same problem here. Same [censored] as in Walls and shadows quest. After the cut scene i'm unable to move.
    How the [censored] they are alowed to sell those games?

  • thorsteinnsh
    1 posts


    The video of the glitch can be viewed on YouTube, scroll too 2:35 to see when it happens.

    When this occurs I cannot move the character at all, he stands still and does not react to any key inputs. Only key bindings to open Skills, Quests or some menu action like that. I tried "Wake up" (before starting the quest) and going back to the settlement and run around and do stuff for a while and come back to this quest but still breaks at the same place.

    I was playing Valhalla (18.1.2021) when the internet went out for about 2-3 hours. During that time I got the "Worthy" achievement (I have almost completed the game). Nothing weird happened then. Then the next day (19.1.2021) I got "Failed to synchronize Achievements" and didn't think much about it and clicked "Skip" and played a little bit. When I started "Asgard - Blinding Fate" quest the game breaks and I have to quit the game or reload older manual save to get out of being stuck.

    I thought this might be because of this "Failed to synchronize Achievements" problem (I have never gotten that before) so I eventually managed to get that resolved. I tried the following in this order:

    • Did "Verify files" for AC Valhalla
    • Tried "Go offline" and "Online" back again
    • Logged out and changed the account password
    • Logged back in and then the issue got resolved

    But the save-game and the quest are still broken regardless of getting that fixed. However it might have had something to do with that failing in the first place.

    If you guys what to take a look at this problem the Cloud save game is "Manual Save CLOUD - 19.1.2021 - 17:49". I have sent log files to the ubisoftconnectcommunity email and that has the same title as this post, and the name before @ matches my username, if that helps in any way.

  • BlackFangOO7
    1 posts

    @gforceman7 Hey, there is a workaround i found on reddit, lower graphics to low then start the cutscene, it worked for me.

  • UbiKoality
    448 posts

    @Albatros866 @Jellyfish_SK Hey there! I'm sorry to hear that you both were experiencing this issue in Assassin's Creed Valhalla. Please be advised that I merged your two separate posts together since you're both dealing with the same problem. This makes for easier tracking and reporting when it comes to in-game bugs and glitches! Moving forward, would either of you be able to provide a video exhibiting what happens specifically? Also, it would be incredibly helpful if you could upload your save files in a case at support.ubi.com! I will be able to include these files in the team's report. 🙂

  • Ithilix
    1 posts

    Every time I try to talk to Tyr, after they leave the bench the game glitches and makes me go back to the bench and doesn’t progress with the quest. Then I’m stuck and can’t move and Tyr walks back to the bench. Wutsup?

  • gr1mr34p3r007
    1 posts

    cant advance in game because when i start binding fate after cutscene my character moves backwards and freezes cant move around can you please fix this plz

  • Alcoigna
    1 posts

    Same issue here, and also a PC gamer. I've tried reinstalling the game and also launch it as an administrator, but nothing seems to change. I also changed the graphic settings and it seems to work, the cinematic continues but suddenly the game shuts down.

  • Gionny301
    1 posts

    @seiren13 are you playing on PC? Because I've got the same problem here. I tried all the ways to resolve this bug, but nothing.

  • catito89
    1 posts

    I tried to search for someone with the same problem, but couldn't find.

    When I come to fight Fenrir, I need to speak with Tyr and after that, the game simply didn't continue. Tyr stays in the same place, and I lose control of Eivor/Havi, just the camera.

    I need to restart the game, don't even open any menu option.

    Can someone help me?

  • UbiExcellent
    756 posts

    @catito89 Warm welcome to the forums! This issue with Eivor becoming stuck after speaking with Tyr during "Binding Fate" is slated to be fixed in a future patch! For details on when this patch will go live, please continue checking the game's official website, since this information will be posted there at some point in the future. Currently, no specific date has been announced.

  • jamgordo
    1 posts

    Just joined the gang. Game halted at the scene with Tyr exactly as described above.

    While I'm here, what's with the new birthday login that only goes back to 1952. I'm an old veteran of computer games; I even helped make some of the early ones (Strategic Simulations). Be nice not to be a victim of your ageism.

  • UbiKobold
    Ubisoft Support Staff 916 posts

    Hello everyone! I am very sorry for the late reply to this thread, but thank you all for your continued patience during these times. The Game team has been actively looking into this issue, and it has been added to our Known Issues list as well. As soon as more information becomes available we will let you all know.

    Also, jamgordo, you should be able to set your date of birth year prior to 1952. If you need to update your date of birth on your Ubisoft account please create a ticket and one of our agents would be happy to update this for you!

    Official Response
  • Cxnni8
    1 posts

    Hello everybody

    I'm in Asgard:
    I am talking with tyr and we are about to fight the wolf. Tyr gets up from the bench and he and Eivor are walking out of the field of view. A few seconds later Eivor glitches back in the field of view and freezes there. Tyr sees that Eivor isnt walking and also sits down. Eivor (me) is unable to move, I tried with the controller and keyboard, nothing worked. They are now just waiting and I am unable to finish the story.

    What I tried and didnt work:

    • save and reload the scene
    • take other ways to Tyr
    • restart game and PC
    • quit Asgard and rejoining

    The problem is currently unsolved and im kinda disappointed that i am unable to finish the story. What can I do?

    Thank you for a quick answer.


  • Wyrdfeel
    1 posts

    So i need to speak with Try, and after that scene is supposed apear fenrir to give the necklase, and what is happening is just after the talk, the scene freze, i can't move the character and thy just sit again, and i cant attack, move, interact nothing..

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there @EvilNegative! Welcome to the forums 🙂

    I'm sorry to hear you've encountered this issue. Please be assured that the development team has been made aware of this, and that they are currently investigating further. We hope to resolve this in a future update, though at this moment we are unable to provide a definite time-frame for this. Please keep an eye out within our News & Announcements forum for further updates.

    In the meantime, we have found that some players were able to continue by changing their settings to ultra graphics first, then restarting the game and trying the mission again. The graphics settings can then be changed back. We would also recommend setting the game to full-screen (if it not already), and limiting the FPS to 60.

    Thanks! 😊

    Official Response
  • Vasamard
    1 posts

    yeah how about you stop adding an n+1 number of issues to your list and start rolling out some fixes?

Suggested Topics