Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • skydive19822
    5 posts

    I'm having the same issue but the medium or even low graphics settings doesn't change it. Multiple restarts and it still does the exact same as you describe. I don't like being stuck!!!

  • kalex100
    22 posts

    @skydive19822 Did you change the resolution to 1080p? try changing it to 1080p or even lower. I can add, that I pressed space a bunch of times to power through the dialogue and it got me past it... i hope lowering your resolution helps bro! this was the stupidest thing i've encountered so far.

  • Tuttgrabber
    1 posts

    Soo when i was doing the binding fate boss battle Fenrir disappeared and so i woke up to do the quest later, but now I can't even enter asgard without desynchronizing instantly. It's really frustrating and sadly it wasn't fixed in the latest patch 😞

  • paulbaginski
    1 posts

    Same issue here, PC also. after the conversation with Tyr the camera freezes, Havi slides back into view as if pulled on a trolly and stays put. Tyr walks back and sits down.... no controls respond. all you can do is hit ESC and quit.
    Would love to hear what i'm doing incorrectly or if its a bug and when the fix is on its way.

    thank you guys, awesome game up until now!

  • KnifeKitty22
    1 posts

    Everytime i bind Fenrir for the 3rd time in the quest Binding Fate, he glitches out of the circle and I cant fight him! I've redone this fight multiple times and it happens the same way! I can't finish the game! I was told this bug was fixed but I guess not!!

  • alumini86
    1 posts

    I am currently experiencing this bug. What can I do to resolve it. I am on PC. I thought the update fix these things? I did the graphic change and still nothing.

  • TEPESHvoda
    1 posts

    I hawe same ffffff problem, REALLY????


  • Blood_DarkLord
    1 posts

    @kalex100 yes is the same with me and I can't ask support how to solve this. I also find it outrageous that spends on for a game 60 Euros that still has gamebreaking bugs, even though it is already published 1 month before

  • skydive19822
    5 posts

    @kalex100 that eventually worked. I had to adjust resolution and lower graphics settings to low. Restarted several times and it finally let me through. Now to the next bug lol now the Eurvicscire end quest blood and bonds was completed but it doesn't acknowledge and I can't complete it on alliance map. I have 2 more areas to complete and then I'll be stuck again 😕

    https://discussions.ubisoft.com/topic/82558/alliance-map-issue-game-breaking-bug

  • XXXNari
    3 posts

    I am unable to play the fenrir boss fight due to me having a bug just before the boss fight. When I talk to the character Tyr, just when he finishes his sentence before the boss fight the screen zooms out and I cant move my character. Help please.


  • Trendkilla_DK
    2 posts

    Just ran into this *sigh*

  • Miokama
    1 posts

    Like all these others post about this quest I speak to Tyr, you see them move out, it freezes and then Eivor moonwalks back and you are stuck. Can't open the menu or anything, only thing you can do is move the camera around.

    Went to youtube to find some footage since all the footage that's being put online seems to be ignored.


    In the video above you can see the bug happening but this lucky lad can open his menu so it seems.
    https://www.reddit.com/r/ubisoft/comments/jtxrch/valhalla_binding_fate_bug_cant_progress_spoiler/
    Another video of the same issue.
    Can't continue cuz of this bug that's been reported for over a month.
    Any fix ?

  • Finnscool
    1 posts

    I cannot go any further in Binding Fate
    After the conversation with Tyr the camera freezes, Havi slides back into view as if pulled on a trolly and stays put. Tyr walks back and sits down.... no controls respond. all you can do is hit ESC and quit.
    Regards Leon

  • wimstille
    1 posts

    @l0shadow0l thx, it helped. I had this bug more than a month ago, removed the game, played Cyberpunk successfully, it worked great on my pc, loaded ACV again and MORE THAN A MONTH LATER the bug still exists. Shame on you Ubisoft!!!

  • jandraelune
    117 posts

    Another cutscene that can not play under ' low graphic setting ' and forces players to up the graphics quality to at least ' medium graphic setting '.

    Except this one is WORSE, it forces the player to play under extreme load for low end systems due to not being able to save until AFTER a boss fight.

  • UbiKobold
    Ubisoft Support Staff 518 posts

    Hi again everyone, and thank you for your continued updates! I appreciate you completing the steps that I suggested. Since this is still persisting, could you each create a ticket and submit your save files if playing on PC or PS4? If playing on Xbox, can you send an image or video from your gameplay? I would like to forward up this information to the Game team while they investigate. For videos, just post them to YouTube as unlisted and drop the link here. Thanks!

    Official Response
  • seiren13
    3 posts

    After I talk to Tyr, both of them walk, but the camera freezes and then Havi slides back and I am unable to move, just tab and esc work.
    I have a clip of my stream to show how it is:
    https://clips.twitch.tv/BashfulEnticingAnteaterGivePLZ
    I already tried going back the save, but no success.

  • BekkerJs
    7 posts


    After I talk to the guy sitting in front of the arena where the Fenrir fight takes place, Havi suddenly walks backwards in the cut scene and is unable to move after it. Boss fight is supposed to start I think but it does not.
    Reloading didn't help. Tried alot 🙂

  • Tented_Assassin
    1 posts

    Immediately after speaking to Tyr, I progress through the dialogue until they begin to walk toward the cave entrance......

    ......After about 5 seconds Eivor glitches backward into her starting position and is frozen in place from then onwards, no actions or movement can be performed. Tyr simply walks back toward his original seat.

    I've tried this 3 times now, same result each time. I have to exit to the title menu or close the game completely to continue.

  • nerowrought
    1 posts

    I still cannot fight the boss in Binding Fate. On my first try, I fought him normally but died rather quickly. Whenever I try again, Eivor just stands there and is unable to move or do anything. The boss does not appear either.

    I am then forced to quit to title screen and load back in. I suspect this is a different bug from the stuck underground bug that was recently fixed.

    Please advise.

Suggested Topics

Community Details

27
Online
129.1k
Users
22.2k
Topics
115.3k
Posts