Welcome to discussions

Quick Suggestions

  • Yuko-da
    1 posts

    In Jorvik, there are two task.

    1. Burning the Firebrand
    2. Pricking the Needle

    Select "Burning the Firebrand", then killed 3 people, but if you Do NOT go back to report it to LJUFVINA, and finish the "Pricking the Needle" task, then the story is stopped.
    LJUFVINA doesn't move from her table, and the Jorvic story cannot finish.
    I had to go back the game which I saved before.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.2.2, we will now be locking this thread.

    If you encounter any further trouble when progressing in "Pricking the Needle," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • Forest25515
    1 posts

    @desperadoz2010 I submitted my game files so i'm waiting to see if they are able to do anything or if we are just screwed.

  • UbiKobold
    Ubisoft Support Staff 646 posts

    Sorry for the delay in response!

    DESPERADOZ2010, if you are able to provide a video that would be great! Just post it to YouTube as unlisted and then provide the link here. Also, I have forwarded up your suggestion of adding in the ability to restart or reset missions in the game!

    Forest25515, would you be able to provide your ticket number that contains your save files? Thank you for providing these!

    Official Response
  • Sefphy
    1 posts

    I'm playing on PS5.

    I had both "Burning the Firebrand" and "Pricking the Needle" active, so I killed the Firebrand and had the objective to return to Ljufvina, but there was no quest marker so I assumed I needed to go ahead and do "Pricking the Needle" first. After killing the Needle, that quest was completed. Now, when I return to Ljufvina, it shows a cutscene then she gets up, walks a few steps, then returns to the table and sits down. Any further attempts to interact with her simply cause her to repeat the cutscene and return to the table, as I've seen other people mention.

    Fast traveling doesn't change anything. I tried reloading older saves, including one where I hadn't yet killed the Needle, but that didn't make a difference. It just replayed a slightly different cutscene and told me to go check the trade depot, so I followed the Needle's quest to completion again, but that didn't fix the Firebrand's quest issue. Unfortunately, I don't have any older saves to try to salvage this, so hopefully the issue gets resolved soon - though, considering people have been having this issue since around the time of the game's release, I'm not sure...



  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @sefphyroth Hello there! Thanks for reaching out about this. The team is aware of this issue at this time, and are investigating. At this time, our teams would like those who are affected by this issue to submit a copy of their save game files by attaching them to a new case created with our dedicated support team, who will forward things up from there!

    Official Response
  • Hutchguv
    1 posts

    @ubikobold

    I cannot complete pricking the needle as well

    cannot assassinate the needle Assassinate does not appear as an option

    here is a link to the video on Twitter



  • JRabbit94
    3 posts

    @ubikobold
    im playing on ps4 and I have no saves to reload, I haven’t been able to proceed in the game since November.

  • DESPERADOZ2010
    19 posts

    @ubikobold Thank you. The problem still remains after the patch from yesterday. Unable to progress in the main story , do the the order quest etc because of this
    here is a video

  • Huggybug
    4 posts

    On PS4 same problem. Most recent patch hasn’t fixed problem. Also bought season pass so want to finish game to get on with dlc content.

  • a-geologist
    2 posts

    @ubikobold I also fast travelled out of the underground which may have contributed to the bug.

  • GaimerLady
    10 posts

    @UbiKobold Just submitted my game files with the ticket number 13689963 for PS4.
    For some reason it wasn't allowing me to upload my game files as an attachment so I commented with a google drive link with the files.

  • OoKIEZoO
    2 posts

    I have the same problem also but I'm playing in the xbox series x. I can go back to an earlier save file but it means I loose 8 hours of gameplay. Also, the file I can go back to is an episode save cloud file and it says I will loose all previous data which is fine but it says that free roam won't be available after. Does anybody else know what this means?

  • Damage99
    1 posts

    This is 100% caused by fast traveling out of the sewers. I did that the first time and you miss a few dialogs (probably some trigger variables) and come into the market from the wrong direction. If you exit from the sewers as intended you come on The Needle and the poor guy hes attacking from above.

    If Ubisoft just disables fast travel from within the sewers during this quest it will fix this bug.

    Good luck all!

    I was lucky and had a save to go back to from before I entered the sewers. Did everything the same but found the intended way out and The Needle was attackable.

    Great game Ubisoft - thanks so much!

    Edit: Playing on PS5, in case that matters.

  • StreetSRC
    1 posts

    I've got this problem on xbox one as well. as it gives you both quests I thought id do both before returning, the dialog from Hjorr talks about both of them being killed so it can be done like that but Ljufvina just gets up turns around and sits back down, trying to talk to her again Eivor just goes through the what I assume is the dialog after killing the Firebrand, then she gets up and sits back down. I don't have a quest waypoint on the map and no previous save to resort back to prior to this questline.

  • NelznSWE
    2 posts

    Okey so I got stuck in this quest aswell but I was not able to continue after I had searched the trade depot (the quest shows up in the quest menu but as soon as I close the menu it does not show the quest I'm tracking) so I pledged to another area and continued with that. I noticed that I had to repledge to Jorvik after I finished the other region so I did that but the progress I made in Jorvik was still saved and I was still stuck at the same place. A couple of days later (today) I did a contract for the kid in Ravensthorpe and as soon as I finished it Eivor started to talk about the quest in Jorvik like I just finished searching the trade depot. I tracked the quest and suddenly it shows that I'm tracking it so I travel to Jorvik and finish the quest without any issues (YAYY). Now I can continue the story and hope I won't run into any more bugs.
    Have a great day

  • GaimerLady
    10 posts

    @nelznswe I have the same problem with the trade depot being bugged--tried what you did and unfortunately didn't work for me. Not sure what made it work for you : /

  • NelznSWE
    2 posts

    @gaimerlady That's too bad, I have no idea if it was because of the contract or something else but I think it was because the second I finished the contract the bug went away. Fingers crossed your bug goes away.
    If you have other regions to complete you can do that or just sidequests, I really enjoy those small rune stone quests were you line up the symbol on the stones.

  • J0COPA
    3 posts

    Well, I no longer get the green icon of the needle mission. I still can't kill him, but the green mission icon has disappeared on the map. I still can't kill him and I can't advance in the game.

  • semplerfi
    7 posts

    @damage99 Totally agree. I got luck and had one last save game before the bugged ones. I almost pushed it off the list trying to figure out what went wrong. There are a couple of things that might be triggers on your way out of the sewer for sure.

    @UBISOFT - How about a do over option for missions.

  • FroggyKid61
    2 posts

    @desperadoz2010 I'm going around picking up things I missed, but eventually I will run out of them. I guess I'll just quit playing and give bad reviews on the game. Support said they want save files but give no solution to getting them.

Suggested Topics

Community Details

103
Online
192.5k
Users
32.4k
Topics
162.3k
Posts