Welcome to discussions

Quick Suggestions

  • darnalle
    1 posts

    The target icon doesn’t even come up for me.. I have searched the trade depot.. killed everything, looted and searched everything. Nothing. Cannot get it to do anything. Cannot even make it to the part I learn that I need to kill the Needle? Give up? Shame really wanted to max out a couple gear packages to legendary.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.2.2, we will now be locking this thread.

    If you encounter any further trouble when progressing in "Pricking the Needle," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response
  • TomArchSausage
    1 posts

    @ubikobold
    Hi 🙂
    sorry i'm late to this thread, but I'd like to help out if i can.

    I can confirm that I DID fast travel out of the sewers, instead of taking the intended path up the ladder

    my support ticket number is 13527680
    and here's a video of the issue: https://www.reddit.com/r/ACValhalla/comments/k7a2c7/of_all_the_bugs_ive_tolerated_ive_finally_come/

    I am also in the unfortunate position of being 92 hours in, so no chance of reloading a save.
    hopefully this helps and a solution can be found! 🙂

  • guest-M9LaDryd
    2 posts

    @pigr0t I have the same issue. When I speak to her she just sits down again and doesn't go to archive. Tried going back to other saves and then it bugged other parts of the mission (killing targets) so had to stick with the save where I had actually killed both targets but couldn't then reach archive. I have submitted a ticket but who knows if it'll be picked up.

    Frustrating as it's preventing me completing arc and I'm nearly done on all others!!

  • Lin-KD0079
    1 posts

    This is worked for me : back to the previous quest, before you triggered this bug, while going to the needle's area, don't directly encounter him face to face, because once you did this, after the CG, his guards will spot you immediately, I think this causes the bug. So just approach his area from the rooftop, right above him, then the CG will automatically play, after he stabbed the merchant, nobody spots you, bug will not occur so you can assassinate him from the rooftop.

    I paly it on PS4 slim, hope this can help you guys

  • J0COPA
    3 posts

    It is very difficult to fix that problem. They have to patch that bug, but you have to go back to a saved game and start from there again. I hope they come up with another solution, but I don't think so. It's a shame to lose so many hours of gameplay due to a bug, but that's what we have for now. Good luck to everyone.

  • guest-M9LaDryd
    2 posts

    @ubikobold can you look into my ticket. I cannot progress any further I'm the game and Yorvic is the only arc I'm left to do. I have killed both targets but then I can't progress further after speaking to her in great Hall and she won't go to archives. Just sits down again.

    Ubisoft Support Ticket: 13967599

  • UbiKobold
    Ubisoft Support Staff 663 posts

    Hello again everyone! Thank you for your continued updates and information regarding this issue of not being able to proceed in 'Pricking the Needle.' The Game team is still actively looking into this issue. If you have not already, please create a Support ticket and attach your save game files. Then return here and provide your case number and I can forward them up to be included in the investigation. Thanks so much for all of your patience and assistance with resolving this!

    Official Response
  • Magonus
    1 posts

    I completed Burning the Firebrand and Pricking the Needle, then went to speak to Ljufvina. Each time I speak to her it goes through the dialogue about the Needle being dead and that we need to search the council's offices in the Archives, then Ljufvina sits back down and I am prompted to speak with her again. The only quest showing as incomplete is Burning the Firebrand.

  • Karmiti
    2 posts

    @magonus I am also experiencing this issue. Playing on PS5.

  • dooper_2
    6 posts

    @rapturea021 Nearly 3 months after your original post I am having the same issue on PS4.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Warm hello to everyone that has posted here about not being able to progress with "Burning the Firebrand" due to the quest not registering the interaction, and apologies for the delay. I'm delighted to share with you all that this issue will be addressed in the next update. Our teams will post more information about this update on the official website, so definitely make sure to keep a close eye on that.

    Official Response
  • JRabbit94
    3 posts

    @ubikobold
    Ubisoft Support Ticket: 14115492
    heres my support ticket and a link to the video

  • SoProTho
    1 posts

    Here we are in February of 2021 and this glitch still isn't fixed, I mean c'mon. I've already submitted my ticket, replied back to your auto generated message and let you know that no the needle is still standing in the same damn spot as he has been for hundreds of people for the past 3 months. How you gonna have him be such an integral part of "the order" and yet disregard this glitch as if it's not important. Do you devs even give a [censored] about your game? I mean an occasional side quest or whatever fine but a quest as significant as this one and it hasn't been addressed or resolved in three months time? [censored] are you guys doing?

  • dooper_2
    6 posts

    @ubiexcellent This is great news thank you!! All the @ubi people have been very communicative and I truly appreciate that!

  • Huggybug
    4 posts

    5 months down the line and still no update to resolve this. Spent £150 and can’t finish the game. First AC that has been a bitter disappointment. FIX IT!!!

  • Spida219
    3 posts

    PS4, Jorik Questline, Quest Pricking the needle, sub quest return to ljufvina.

    No quest marker given. Once returned to ljufvina inside of royal hall, dialogue happens, she says lets go to the archive. She then sits back down and repeats upon talking to her again. I did not teleport out of sewers before killing the needle, but did kill firebrand and needle prior to talking to her. Also killed needle with arrow then killed his guards then confirmed the kill. Cannot progress story anymore with no recent previous save point( closest save point is over 60hrs of gameplay ago) Please assist!!!!!!

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello there @Spida219! Welcome to the forums 🙂

    I'm sorry to hear you've encountered this issue. The development team has been made aware, and they're currently investigating further. At this moment in time, we have no further information available to share regarding the investigation. Please keep an eye out within our News & Announcements forum for further updates.

    Thanks! 😊

    Official Response
  • beanofwar
    11 posts

    @ubikobold This issue has been reported for months. I love these AC games but I won't buy one in the future if this is the support we get. I've already entered a ticket, requested that this be reported to devs as a bug, shared the same types of videos our friends in this thread have shared.

    We need either
    A) a bugfix to allow us to continue on this quest or

    B) a way to reset quests and restart them from the beginning.

    This is unacceptable.

  • deathngravity
    10 posts

    Begin Rant!
    UGH!!!
    Still not fixed & has been reported for months!
    How about instead of adding new content, you fix the issues first!

    End Rant!

    (I've worked in QA... it's a thankless task... cheers)

  • dooper_2
    6 posts

    @ubiexcellent After the update that happened today (2-16-21) I am having the same problems. Will this be addressed in the next update, or was it supposed to be taken care of with the most recent update?

Suggested Topics

Community Details

89
Online
192.7k
Users
32.5k
Topics
162.5k
Posts