Welcome to discussions

Quick Suggestions

  • Karmiti
    2 posts

    @magonus I am also experiencing this issue. Playing on PS5.

  • dooper_2
    6 posts

    @rapturea021 Nearly 3 months after your original post I am having the same issue on PS4.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Warm hello to everyone that has posted here about not being able to progress with "Burning the Firebrand" due to the quest not registering the interaction, and apologies for the delay. I'm delighted to share with you all that this issue will be addressed in the next update. Our teams will post more information about this update on the official website, so definitely make sure to keep a close eye on that.

    Official Response
  • JRabbit94
    3 posts

    @ubikobold
    Ubisoft Support Ticket: 14115492
    heres my support ticket and a link to the video

  • SoProTho
    1 posts

    Here we are in February of 2021 and this glitch still isn't fixed, I mean c'mon. I've already submitted my ticket, replied back to your auto generated message and let you know that no the needle is still standing in the same damn spot as he has been for hundreds of people for the past 3 months. How you gonna have him be such an integral part of "the order" and yet disregard this glitch as if it's not important. Do you devs even give a [censored] about your game? I mean an occasional side quest or whatever fine but a quest as significant as this one and it hasn't been addressed or resolved in three months time? [censored] are you guys doing?

  • dooper_2
    6 posts

    @ubiexcellent This is great news thank you!! All the @ubi people have been very communicative and I truly appreciate that!

  • Huggybug
    4 posts

    5 months down the line and still no update to resolve this. Spent £150 and can’t finish the game. First AC that has been a bitter disappointment. FIX IT!!!

  • Spida219
    3 posts

    PS4, Jorik Questline, Quest Pricking the needle, sub quest return to ljufvina.

    No quest marker given. Once returned to ljufvina inside of royal hall, dialogue happens, she says lets go to the archive. She then sits back down and repeats upon talking to her again. I did not teleport out of sewers before killing the needle, but did kill firebrand and needle prior to talking to her. Also killed needle with arrow then killed his guards then confirmed the kill. Cannot progress story anymore with no recent previous save point( closest save point is over 60hrs of gameplay ago) Please assist!!!!!!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @Spida219! Welcome to the forums 🙂

    I'm sorry to hear you've encountered this issue. The development team has been made aware, and they're currently investigating further. At this moment in time, we have no further information available to share regarding the investigation. Please keep an eye out within our News & Announcements forum for further updates.

    Thanks! 😊

    Official Response
  • beanofwar
    11 posts

    @ubikobold This issue has been reported for months. I love these AC games but I won't buy one in the future if this is the support we get. I've already entered a ticket, requested that this be reported to devs as a bug, shared the same types of videos our friends in this thread have shared.

    We need either
    A) a bugfix to allow us to continue on this quest or

    B) a way to reset quests and restart them from the beginning.

    This is unacceptable.

  • deathngravity
    10 posts

    Begin Rant!
    UGH!!!
    Still not fixed & has been reported for months!
    How about instead of adding new content, you fix the issues first!

    End Rant!

    (I've worked in QA... it's a thankless task... cheers)

  • dooper_2
    6 posts

    @ubiexcellent After the update that happened today (2-16-21) I am having the same problems. Will this be addressed in the next update, or was it supposed to be taken care of with the most recent update?

  • UbiKobold
    Ubisoft Support Staff 664 posts

    Hey there everybody! This is continuing to be investigated, and I greatly appreciate the patience that you all have shown during these times. I do understand just wanting to be able to continue, and we are working hard to continue gathering information as the Game team works towards a fix! Thank you to all for your continued assistance. I have gone through the ticket numbers provided and have forwarded your information to the Game team. If you have not created a ticket and provided your save files (if on PC or PS4), please provide these files and return here to post your ticket number. I can then send up your save files for further investigation.

    Thank you all again, and please continue to keep an eye out for updates and further information.

    Official Response
  • DESPERADOZ2010
    19 posts

    OMG I'm going insane here. I have bought the Ultimate Edition and so many skins etc and I am being excluded from the game for MONTHS now. I have never been so disappointed through the whole AC Series before. I have always backed up Ubisoft even after so many people complained for AC Unity being unplayable etc etc . Nope I have always backed you guys up. And now , after so many people complain and are being locked out from playing this game NOTHING happens . NOTHING in months. It has not even made it to to the Bugs megathread etc .. Nothing. And You have asked to send Videos and people did. And you have asked to send Savegames and people did. Yet, nothing. We spent so much money and we cant finish this game. Thats not acceptable. With all the love i have for Assassins Creed, Far cry etc i have literally bought every game in this series i really got to the point now where i will wait half a year before i buy anything from Ubisoft again 😞 I mean C'mon we bought it early , paid the full price and now it was on sale already and we are still not able to continue. It feels so pointless.

  • Strattan2021
    1 posts

    @ubikobold
    Case number 13994446. Been 20 days an have gotten the story of " you may continue to play the game, our dev team is working on it.". But have not heard anything from the dev team. Loaded saves and made link to video on case. After every 4 days, my case gets automatically closed. Most problematic game for crashes and bugs I've played on PS4.

  • Spida219
    3 posts

    Many people are stuck with some variation of bug with this quest. It is game breaking and many of us cannot finish the storyline. Do something ASAP please

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello all!

    I've merged together a few threads in which players are unable to proceed with "Pricking the Needle" after interacting with Ljufvina. I apologise if any discussions have been disrupted by this. By creating a single thread, we can keep all the information and updates surrounding an investigation in one place.

    If you're unable to proceed in "Pricking the Needle" as you cannot kill The Needle, please check out this megathread!

    Thanks to everyone who took the time to share their experiences of this issue, and shared images/videos within the forums. Thanks to all who also took the time to submit their save files. These have been passed along to the development team as part of the investigation.

    I can confirm that the development team are aware of this issue, and they have been investigating further. At this moment in time, we have no further information to share from the investigation, including an ETA for a resolution. Once we have any new updates to share, these will be posted within this thread or within our News & Announcements forum. Please keep an eye out here for any further updates.

    Thanks all! 😊

    Official Response
  • guest-WEapd0mI
    1 posts

    Can’t complete the quest Burning the Firebrand because after killing The Needle, when returning to Ljufvina and after talking with her she stands up to take you to the archives but then she sits back down. I have tried fast travel, meditate, going to sleep and nothing works. I’ve read that many others have the same issue and when they load previous save there comes other bug with the quest.

  • Szithis
    1 posts

    I am also stuck on this quest on Xbox all old saves are the same and 140 hours of playtime I am not restarting. No goal on quest screen and ljufvina says come to the archive and just sits back down. Dissapointed it hasn’t been fixed yet

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @Szithis! Welcome to the forum 😊

    Thanks for taking the time to share your report with us. I'm sorry to hear you're unable to proceed with "Pricking the Needle." I've passed this report along to the development team so they can take a closer look.

    Once we have any new updates from the investigation, we will share these within the thread.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details

92
Online
196.3k
Users
33.2k
Topics
166.1k
Posts