Welcome to discussions

Quick Suggestions

  • Osbolity
    1 posts

    I am having the same problem! Cannot kill the Needle after teleporting from the sewers.. Please fix this..

  • deathngravity
    10 posts

    Same... XBOX & latest patch. How has his not been patched? It's been reported numerous times & almost 4 months now!
    Ljufvina says come to the archive and just sits back down.

    19 posts

    smh. its still not working. not mentioned in the patch notes at all.
    After all this time i still cant progress. I spent 150$ for a game i was only able to play halfway through and i cant continue with. I'm done 😞

  • hclu0228
    1 posts

    Still not fix this issue.
    Ubi is hopeless...
    I will never buy any fxxking game of ubi

  • Huggybug
    4 posts

    as someone who’s played far cry and ac since the beginning I’m appalled at the lack of help provided by Ubisoft. Will not be buying any Ubisoft titles in future. Thanks for nothing.

  • darthstrings
    2 posts

    I ran into similar issues on this quest, but not quite the same thing.

    On Monday night (3/15/2021) I progressed the Jorvik questline to where I needed to enter the large church with the book burning. I was not being hunted by the vikings in the city and left and went to some treasure spots in the surrounding area, and solved the mystery with the 2 girls in the tower (their Dad drowned - sad).

    Then I quick traveled back to the Minster and I manually saved my game and suspended my game.

    On Tuesday night (3/16/2021) I continued the game from the main menu.

    I noticed that I didn't have a quest marker for the Firebrand quest. I entered the Minster, got the cut scene and then needed to locate the Firebrand, but all of my quest markers and player direction related to this main quest were gone. So I went into the city and started killing all the red highlighted enemies. By luck, I killed her just by killing random Firebrand Vikings in the city. Then the quest updates in my HUD to tell me to return to Ljufvina, but still no quest marker.

    Then I open my quest log and I see the entire Jorvik questline is missing, as well as all mainstory quests. The only quests that show up are the Ravenshome quests, the River Raid Quest, the quest in Vinland, and the quest in Asgard.

    I was able to finish Pricking the needle by speaking to Ljufvina, getting the quest, and then stumbling through the quest steps by following an IGN guide since there were no quest markers or highlights. I eventually killed the needle, and picked up the next quest "Closing the Vault" - but I don't want to continue the game this way. It's really no fun to have to rely on a guide to know what to do for the main quest. The main quest shows as active on the Quests screen, and I get the on screen text telling you what step you are on, but he the quest tracker for the main story quests and quest player direction are just...gone.

    I have over 110 hours into the game and I wanted to see the end.

    Ubisoft Support Ticket: 14313569

  • Spida219
    3 posts

    Second patch since I personally reported the issue. Just a shame Ubisoft. Prioritize this issue and lets get it fixed. Many people cant even finish the story because of this lingering, previously reported, MAIN QUEST BUG.😠😠 😠 😠 😠

  • Ubi-Mark.
    Ubisoft Support Staff 1361 posts

    Hello there,

    Please accept my apologies for the delayed reply.

    I can see that this issue is still being investigated by the development team at the moment. Once we have an update, we are going to let everyone knows through this thread and the patch notes.

    @darthstrings - I'm really sorry to hear about your experience and thank you for sharing more details with us! I also checked your case and I can see that all of the details shared there have been passed on to the development team for investigation purposes.

    @Spida219 - As I can't personally prioritize bugs, I can see that the development team are working on this issue. While we don't have an update on this yet, we're passing on every piece of information that can help in order to speed up this investigation, so all of our affected players can soon complete this quest 🙂

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • J_Edmund_Squid
    2 posts

    I am having a similar issue. I killed the needle and then the game crashed. I reported the problem. Now the quest for pricking the needle shows as being non-completed, but when I select the quest, there is no quest marker on the map and no way to replay the scene to progress in the game. I am at level 320 on the game and don't want to start over. I am a huge fan of the Assassin's creed series, but this is really disappointing and makes me really unsatisfied with the game overall. I was hoping that the recent version 3.0 patch would have corrected the glitch given all the posts that have been talking about it for months, but was again disappointed that it did not. Ubisoft, please, please fix this bug or let the community of gamers who have written about this know when you will have a fix.

  • J_Edmund_Squid
    2 posts


    Please quit talking about about fixing this glitch and get 'er done! Really maddening.

  • kdun2280
    1 posts

    I'm lvl 408, 203 hours in, and have been waiting on this bug to be fixed for months. I've completed everything in the game except for the storyline which I can't progress because of this bug. I'm stuck doing festival junk and contracts until this is fixed. It's just not right.
    Ubisoft Support Ticket: 14516012

  • deathngravity
    10 posts

    Maybe... instead of releasing new content... they fix the bugs first?
    I realize in a game this size, you are going to have bugs. Having worked in QA, despite best efforts something will slip through. You stop all further new development & address the current issues.
    I played Odyssey almost a year after it was released... no more Ubisoft games @ launch.


  • JRabbit94
    3 posts

    Problem still not fixed this is crazy

  • deathngravity
    10 posts

    How is this not fixed yet!!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there!

    Thank you for continuing to update this thread with your experiences with "Pricking the Needle." I have passed these reports along to the development team as part of the ongoing investigation. We don't yet have any new information to share with you all from the investigation. Rest assured that once we have any updates to share, we will post this information within this thread and in the News & Announcements forum.

    @J_Edmund_Squid - Thank you for taking the time to share your report with us. I apologise for any disappointment that has been caused by this issue.

    Please note that the agents you see posting within the forums, such as myself and @Ubi-Mark, aren't members of the development team. We have passed on the reports that have been shared by players so the development team can take a closer look at these as they work on a fix. We don't yet have an ETA for this. As soon as any new information is made available, we will let you all know within the forums.

    @kdun2280 - Thanks for sharing your ticket number with us. Your report has ben passed along to the development team as part of the ongoing investigation.

    @deathngravity - Thanks for sharing your feedback with us. We have passed this on to the dedicated teams. I would recommend checking out the recent Dev Blog, if you haven't already, as this provides more insight into the internal development processes and how investigations take place.

    Thanks! 😊

    Official Response
  • deathngravity
    10 posts

    @ubi-borealis Thank you!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    You're welcome, @deathngravity! Please keep an eye out within this thread and in the News & Announcements forum for any future information and updates 🙂

    Official Response
  • Punished88-
    2 posts
    This post is deleted!
  • randomvirus0
    1 posts

    So when will this be fixed? I’m concerned by your response to other post that this may never be fixed as it should have by now. This is really not cool Ubisoft you are letting a lot of people down

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @randomvirus0!

    I'd like to reassure you that the development team are working on resolving this issue. They have confirmed with us that they intend to release a fix for "Pricking the Needle" in a future update. We don't yet have a confirmed release date for this fix. Once we have more definite information, this will be shared within this thread and in the News & Announcements forum.

    Thanks 😊

    Official Response

Suggested Topics

Community Details