Welcome to discussions

Quick Suggestions

  • TimKnuettel
    1 posts

    I cant complete East Engla.
    I finish all task.

  • queenmargotfox1
    4 posts

    I haven’t seen this issue on the known issues list so I thought I’d make it known. After completing the East Anglia arc (I dueled Rued and everything), when I talk to Randvi it does not complete. I can still pledge to other regions, and re-pledge to East Anglia. When I re-pledge to East Anglia there is no quest available for me to do. I have done some more regions but have reached the point where I can’t continue unless East Anglia is completed.

    My last manual save is at the beginning of the Grandebridgedescire arc, which is 30 hours behind my most recent save. I would love if Ubisoft could fix this very significant bug so I don’t have to replay 30 hours of the game.

  • QTANTOBA
    1 posts

    Have either of you had this solved? I'm in the same boat - East Anglia for me as well! On PC.

  • queenmargotfox1
    4 posts

    Side note:

    Some more information. Finnr has joined my settlement and is hanging out at the docks. He is also available to be part of my longship crew.

    Does anyone know of any workaround or fix for this issue? Or do I just have to hope that the next update fixes this issue?

  • genchild-001
    6 posts

    @queenmargotfox1 I would highly recommend you don't continue the game play. I'm having the same issue, but I continued pledging to available alliances hoping it wouldn't impact me. I'm 90 hours in and nothing will new will unlock because it thinks East Anglia hasn't been completed. I'm 280 power. I'll so disappointed to have spent so much time to get to a game stopping bug. The regions of Cent, Essex, Suthex, and Euviscire, never opened on my map and I am quiet literally out of any quests to complete. The alliance map is a massive bug. If you aren't terribly far along, I would recommend starting over. There is something that is happening during gameplay to make this happen. Either a game crash or a corruption. I saved my main game and I am playing over again just to see if it happens again. Best of luck!

  • queenmargotfox1
    4 posts

    @genchild-001

    Alright, thank you! I still might wait a few more days in the hopes that a fix rolls out but if not I'll just suck it up and start anew. Thanks for your input!

  • Bushwickedly
    109 posts

    Are you guys READING the mail in your long ship mail box after completing EACH story arc? There's at least one quest where you have to read a letter from Hytham and then go talk to him, before it'll update Randvi and a new map unlock IIRC. Any mail, you'll see a scroll icon in her room.

  • queenmargotfox1
    4 posts

    @bushwickedly

    Yes, I've already gotten a letter from Hytham. It unlocks a new area that is 100+ power over my current level, and doesn't help with the fact that the East Anglia region is glitched and won't complete.

  • bewaremag
    5 posts

    @kikikc @Ubi-kAn anyone ? come on.

    can't finish the game and still no reaction from you folks.
    so disapointing

  • bewaremag
    5 posts

    @epiphany0369 @UbiWan any news ? weeks have past

  • maurogiona
    9 posts

    THE MISSION DOESN'T START, IT ISN'T IN THE MISSON LIST, IT'S IMPOSSIBLE TO CONQUER EAST ANGLIA AND PROCEED WITH THE STORY, PLEASEEE! HELP ME!

  • I_BiG_AiDaN_I
    6 posts

    As suspected I can't progress with the game, I only have areas to pledge to which are way above my power level.

  • Kikikc
    10 posts

    Up, bug not fixed in the last version 1.1.0
    75H played, close to have anaything done and can't proceed the main quest 😞

  • IcemanTheMeme
    3 posts

    @kikikc Same problem here the main story line cannot be completed and ubisoft has been very quiet about this bug.

  • xSpecialOpsx
    5 posts

    Even after the new update this is still not fixed!!! East Anglia is the only remaining to plegde, I can’t continue with the story. The quest are already finished, finnr already joined my settlement and even got the trophy.

    please look into this!

  • Chacarron_9
    4 posts

    Hello, East Anglia was completed but the alliance map displays it as available and allows me to pledge even though I completed it. Because of this, I can’t complete the main story line and it’s extremely upsetting. I’ve had this issue for weeks now and none of the updates have fixed issues regarding the Alliance Map. I’m 50 hours deep into the game, and don’t want to restart because of something like this.


    if anyone else has this problem, is there a fix?

  • xSpecialOpsx
    5 posts

    I’m playing on the ps4 and even after the new update this is still not fixed!!!

    East Anglia is the only remaining to territory to plegde, I can’t continue with the main story.

    All the quests regarding pledging East Anglia are already finished, finnr already joined my settlement and I even got the trophy for completing it.

    I’m already 90 hours in, so not looking to start over again..

    please look into this!

  • ShmuelValenci
    5 posts

    After I finished East englia saga and return home it did not pledge to me and now i cant continue the cent, essexe, suthexe, Lincolnshire sagas.
    i can go to wincestre,sontinghamscire and jorvik and they all above my skill rank.
    here how is see it my Alliance map: https://www.photobox.co.uk/my/photo?album_id=5997252780&photo_id=503593893185
    and if i try to pledge again its mark the mission wedding horns like this: https://www.photobox.co.uk/my/photo?album_id=5997252780&photo_id=503593895870

  • iBankstro
    7 posts

    @ubiwan Unable to progress with "Wedding Horns" | POST HERE | Ubisoft Forums

    This thread has a screenshot and a few vids

  • Jimmys568
    3 posts

    I've got the same issue as well. The quest Wedding Horns is marked as completed but I never received the follow up quest to tell you to speak to Randvi is complete the arc and cross off East Anglia. I've since played 50+ hours without noticing this and killed off all but the last 4 Order members locked behind the Main Story. I can't continue with any other zones or stories until this completes. This is a game breaking bug and I'm stuck.

Suggested Topics

Community Details

85
Online
217.7k
Users
36.7k
Topics
182.3k
Posts