Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • talmilivne
    15 posts

    Hi..did u checked the game today? Cause some players here say the problem was solved..

    15 posts

    I have tried today and it's still not working/fixed. All the foliage, etc. in England vanishes still. When I go to Norway there is no problem/issue the foliage stays - just seems to be in England the issue. Hope they get it fixed soon, I'm staying in Norway until they do, as England is unplayable.

    15 posts

    @pbmcmlxxi that said, Norway does seem to have flicker issues around foliage, trees etc. It can get annoying. May have to revert to playing Odyssey at this rate!

  • guest-4q9x0szr
    3 posts

    Ubisoft please do something for this issue... I tried everything, changing parameters, performance/quality, suppress and recharge the whole game, changing from Norway to England... Nothing is happening. It is a clear shame when you think we are playing on PS5, latest technology and the game has been released for months..
    Please act in a professional manner and keep us updated !

  • pedroesdrubal
    2 posts
    New gamer here.
    Just bought the game last week and gave it a try during the weekend. First time I saw the disappearing grass while chrouching I thought it was on purpose ( I was that naive..) It was after trying the first "flying papers" challenge that I notice something was clreary not right. So, I have no ropes whatsoever, I'm just walking in the air. And I mean no ropes at all. I haven's seen one in the game. So you can imagine how frustating it is trying to do anything...
    Also the disappearing grass, foliage...etc.
    It was really disappointing. Never I thought a game I was so eager to play had this kind of basic issues 5 months after being realesed.
    Any date to solve this? Because I can't play like this obviously...

    So, as an update, I tried today and I got ropes! yey! What a sight! A thing of beauty...ropes!

    The issues with foliage and trees continue though.
    Ubisoft, please?

    5 posts

    Only thing you can do at the moment is restarting the console and reloading an earlier save before it happened. I had to play hours worth gameplay to reach where I was before. It happened again once I finished everything there is to get in Ledecestre and fast traveled out of there. Luckily I was more prepared and saved right before entering the town since I suspected that the big towns have something to do with the trigger of this bug(not sure exactly what though). So every time I opened loot or did a side quest, I would fast travel back to my boat, which is near the town, and see if the bushes would disappear. If they didnt, I would manually save and run back to town to open or do something else there. I did that repeatedly numerous times till there was nothing there for me to do. I never got the bug when I did it like that, and havent had it since. But once I reach lunden, Im going to do the same because Im worried that staying in the town for long will trigger it.

  • talmilivne
    15 posts

    Ubisoft plz do somthing we want to play valhalla!!

  • greed4life
    2 posts

    Im 180h in game +- 10.
    And as evry 1 Else stuff disappear.

    Fix it. Game is unplayable.

  • greed4life
    2 posts

    Just started

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi all, and thank you for keeping this thread updated since my last reply. I've added the information you all have added to the team's on-going report for this issue, but I'm afraid I do not have any updates to share as of yet. Please stay tuned on this thread and on the News and Announcements thread for updates. For those of you on the PS4/PS5, can you confirm if the workaround @rapidoct shared resolves the error for you?

    @rapidoct Thank you for this information! To confirm, everything is working properly for you now? Do you need to constantly adjust your HDR settings?

    @pedroesdrubal I'm extremely sorry for the disappointment caused by this error. The teams are aware of this issue with the disappearing visuals, but are still investigating.

    Official Response
  • cheat2winPT
    4 posts

    @rapidoct what do you mean with logoff? Quitting to the main menu or quitting the game?

  • Chill.Shot85
    3 posts

    So I had this happen before, but it went away once I logged out and then back in while changing the settings. But it has come back right after I went into a camp to loot the treasure after killing the witch (in the western part of the map). Now grass and leaves are disappearing again. I can't see ropes nor can I see the walls of the tents. I did notice that when I go into Eagle view, all the overlays come back until I switch back to Eivor. Then they all dissappear again. When I go to where the grass is, I can still go into stealth mode when crouching... just can't see how far the grass goes.

    Things I've tried....
    - Resetting console
    - Turning off console
    - Changing settings to off then logging back in and switching them back
    - Changing from performance to the other setting (can't remember the name right now)
    - Loading with out being connected to the internet.
    - Fast travelling
    - Sleeping
    - Switching gear
    - Removing gear

    I really enjoy this game and want to play steathly... but have to go in swinging because I can't see how/where to hide or ropes or lines of blocked sight.

    Super annoying. If this doesn't get fixed I think I'm done with the series. Between the glitch in Black Flag that made it so I couldn't get a platinum trophy, to the major glitch in origins, I think I might be done with the series.

    I'm on PS5

  • Chill.Shot85
    3 posts
    This post is deleted!
  • rapidoct
    5 posts

    @ubiexcellent everything is working properly as if the glitch never happened. I don't have to adjust any settings and I have HDR on, just as I did before.

    @cheat2winPT i quit the game and played something else for a few hours

  • vishalr121
    2 posts

    @Ubi-Raziel Am playing the game in PS5. 25 hrs in I started getting this issue. I opened a save which was 2 days old and that did not have the issue so loaded the game from that save and started playing again. Now, I save every one hour just to be sure and guess what, the issue started happening again when I accepted a side quest. When I tried to load from a previous manual save point and the issue still persists. All my saves are nor corrupted and having this issue.

    Looks like the issue has been active for a while. I've tried all possible fixes i.e., HUD setting change, etc. Please advice if there are any sure fixes for the issue.

  • Zai_RoC
    3 posts

    This thread was started November 12 of 2020 & it is March 31st of 2021 & ubi is still "investigating". It makes no sense whatsoever that they haven't found a solution yet or better yet the "Problem" but they're patching settlement decorations, its wierd how they found out the problem & fixed that one so fast but we still can't play without **** disapearing 4 months later smfh. BIG THUMBS DOWN FOR THAT MOVE UBI. If your really worried about the player you guys would have fixed that problem back in 2020. We didn't give a **** about settlement decorations WE WANT A PLAYABLE GAME!!!! FIX THE REAL PROBLEM SMFH

  • Ubi-Mark.
    Ubisoft Support Staff 533 posts

    Hello @Chill-Shot85,

    Sorry to hear about your experience.

    This sounds like corrupted data, to honest. Have you tried reinstalling your game by any chance? It will help us to resolve any corrupted data issues (if applicable).

    As I haven't personally encountered anything similar on my PS5, can I kindly ask you to provide us with a short video of this occurring, so we can investigate it further for you? Many thanks and if you have any additional questions, please let us know.

    Official Response
  • MDMayerjr
    6 posts

    This is a looooooooooong standing issue that many players are dealing with, and very unlikely to be a personal corrupted data issue. Many videos and descriptions of the problem in the thread below. Many tickets have been open. By now, I'd be happy to see an all-hands-on-deck effort to fix it.


  • talmilivne
    15 posts

    Well today i went in to check the after few days i havn't played. It was ok at the start and i thought thats it problem solved. But the the foliage problem came back!!! Like c'mon ubisoft do something!!

  • Fenniboii
    2 posts

    18 hours in and this problem started for me in Ledercesterscire. First noticed it on invisible ropes during an artifact collection. I’ve tried everything I can in this post with regards to rebooting, visual settings, earlier saves etc. I’m on PS5. What a bummer.

Suggested topics

Community details