Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • guest-4q9x0szr
    3 posts

    @TooBadToWin : How did you fix it please ? I updated the game as everybody yesterday and still nothing change.

    @UbiExcellent : Any updates please ? Would you be professional enough to provide your clients with a detailed status update ?

  • TooBadToWin
    8 posts

    @guest-4q9x0szr I opened my save today and everything was back to normal. I’m playing on the digital ps5 version

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    Thank you for continuing to report your experiences of missing grass, foliage, tent coverings, and other supporting scenery to us here in this thread, and I sincerely apologise for the delay in our reply. I have chased an update on this issue from the development team, as I am aware that it has been ongoing for a considerable time now, and the status of the investigation continues to be in progress. I will keep you all updated with the latest information I receive, and thank you for your understanding in the meantime.

    We continue to appreciate your submission of videos of the issue to forward onto the investigating team, and would encourage you to keep providing these for reference, particularly now that TU 1.2.1 has been applied. It would be great if we could receive evidence of the issue still occurring on this version of the game. Thank you.

    @LatinFlyer - Hey there! The issue with "A Brewing Storm" should now be resolved as of the deployment of TU 1.2.1. If you find that you are still experiencing this issue, please report this over on our dedicated megathread and make sure to provide a video of the issue, showing that the latest version of the game is installed on your console. With regard to the issue that this thread concerns, please refer to my above comments. Thanks!

    @stroodle_910 - Thank you for updating us, and letting us know that the issue has not reoccurred since you reloaded a save before it started. Please do keep us updated as to whether the issue ever comes back.

    @Spades1961 - We're still investigating this issue with the missing grass/foliage/tent coverings etc., for which I sincerely apologise. Regarding the missing fish, if you weren't aware, a partial fix has been implemented in TU 1.2.1, which allows you to find all of the fish that were previously missing! You can join the discussion regarding this in our dedicated megathread if you're struggling to find them. Regarding the final issue you mention, with Reda's contracts - can you please elaborate on this, so I can fully understand which issue you are referring to? Do you mean that you have accepted them from Reda, but then do not have them in your quest list to complete? Thank you!

    @filterdoesntjam & @TooBadToWin - Thank you both for letting us know that this issue is no longer occurring for you on TU 1.2.1! I am very glad to hear that this is the case. Would you both mind confirming whether you loaded your most recent save, or an older one, after the update for our reference? Many thanks!

    @PBMCMLXXI - Hello there! If you are continuing to experience this issue since TU 1.2.1, it would be helpful to us if you could provide us with a video demonstrating this, as well as confirmation of your platform. Regarding refunds, our refund policies for digital and physical purchases can be found on the hyperlinked pages respectively. For us to consider a refund request, you must have purchased the game from the Ubisoft Store; if you purchased the game from any other retailer, your request must be submitted to them. Refunds are considered on a case-by-case basis, and you can request one either from your order history or via our support website. Thanks!

    @LatinDeus, @gufrann_sid, @pastryunit247, @Mshalabi, @dazzy983 & @guest-4q9x0szr - Thank you for your reports of this issue, and I am sorry to hear that you have all been impacted. Are you able to provide a video of the issue occurring, if it is still present for you on TU 1.2.1? Have you also tried what other players have suggested previously, which is to try reloading an older save game after reopening the game client?

    Official Response
  • PBMCMLXXI
    13 posts

    @ubi-woofer this is from the Essex area, though it doesn't seem to make much difference where in England. There's enough footage on YouTube already showing this bug. Here's mine Xbox X, HDR latest patch.


  • filterdoesntjam
    7 posts

    @ubi-woofer I loaded my most recent save after the update and the issue was gone.

  • Arbitrary-Larry
    1 posts

    I started getting this exact issue on PS5. I think it was after going to Lunden first time. Foliage progressively disappears as you get closer, tent fabric seems to have totally gone, and ropes are totally gone. Game is really unplayable now. I’ve raised support ticket as nothing I’ve tried has fixed it (including switching off HDR, changing between performance and quality modes, and turning off all HUD elements). Really hoped the last huge update 1.2.1 would fix this but nope it’s still an issue for me. The only manual save I have is from 2hr so I can’t go back to that! Ubisoft come on this is clearly a widespread issue and it’s such a great game but this needs to be sorted out!

  • PBMCMLXXI
    13 posts

    @arbitrary-larry exactly, ubisoft take your money and run away with it, leaving an unplayable game. I tried but at points I was walking on air, where I guess a rope was, I couldn't see, I jumped expecting to jump to the ground, but landed midair on something I couldn't see. You can't stealth play, it's pointless. Unbisof obviously don't care, if they did they would have pulled out all stops, viewed all the footage people have uploaded since November clearly showing the issues. There's more proof the issue exists than there is that ubisoft support/decelopment team still do, seems they got rid of people during covid and not get them back, or fired them for producing such a flawed game.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    @PBMCMLXXI - Thank you for your video of the issue - I have added this to our ongoing conversation with the developers. Once we have an update to share, we'll let you all know here in this megathread. I'd also like to ask that you refrain from spreading misinformation; both my team and the developers are working hard to investigate and work on this issue, and we'll share new information as soon as we are able to do so. Thank you.

    @filterdoesntjam - Great to hear, thank you for the clarification!

    @Arbitrary-Larry - Hello there! Thank you for joining the discussion and sharing your experience of this issue. I am sorry to hear that you are also impacted. Could you possibly share a video of the issue as it appears on your PS5 version of the game? Can you also let me know your support case reference number so that I can check out any existing information you may have already provided there, and forward it to the developers? Many thanks!

    Official Response
  • pastryunit247
    4 posts

    @ubi-woofer I have my PS5 disc updated to the latest software, as well as the latest patch of Valhalla and so far have been stick with this glitch for 3 weeks now. It’s just like the glitch that others have shared videos of, and happens everywhere I walk. Not near my PS5 now to share video, but it’s just like the videos already shared. Foliage, tree leaves, ropes and tent fabric disappearing around me, anywhere I go. I tried restarting the whole system, not touching it for a week, going to my oldest save and back, changing quality settings, changing tv HD settings, turning off and on again HUD settings, saving and quitting before an animus glitch, just playing for a while to see if it would disappear on cutscenes and nothing has changed. It refuses to go away.

  • Ubi-Borealis
    Ubisoft Support Staff 1426 posts

    Hello there @pastryunit247!

    Thanks for sharing your experience with us, and for including detailed information on your system and the settings you've used/tweaked. I've passed this along to the development team as part of the ongoing investigation.

    Would you be able to let us know what was the last thing you did before this issue started occuring in-game for you? Did you start a new quest arc, or complete an area?

    If you can provide any videos of this issue happening during your own gameplay as well, this will be very helpful.

    Thanks! 😊

    Official Response

Suggested topics

Community details

6
Online
124.6k
Users
21.4k
Topics
110.8k
Posts