Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • josiah_bartlet
    1 posts

    I am having issues in Lunden with elements of the environment not loading or disappearing. As I approach plants they disappear, while crouching and not. I am still hidden in them but the actual plant disappears. Also some beams are not loading but can still be used. First noticed it while in the Lunden Bureau. I jumped into what looked like air and landed on a beam. Again noticed it when assassinating The Leech, walked on a beam that wasn’t visible there. It happened again while chasing a tattoo. I could beat it because there was a beam or rope missing and I couldn’t see where to jump. Found it while jumping down and character landed on something midair. I am playing on PS4 Pro version 1.02. I have shutdown the console for about an hour and problem still exists upon restarting.

  • zombie4hire89
    1 posts

    I just had this happen to ke a few hours ago, the only thing that fixed it was deleting the game and downloading again 😩 this game is so broken, still can't access any of the online features like daily and weekly missions or the free cosmetic rewards.

  • yacula
    3 posts

    Reinstalling the game didn't solve the issue. The game is currently unplayable! BTW it happened to me at the same time exactly - during The stench of Treachery mission.

  • Abeonis
    55 posts

    @ubi-raziel
    I have also encountered this issue on Xbox Series X. Restarting a second time seems to have fixed it (for now), but whilst it was happening, it was constant. The bug also hid the rope and canvas textures (for tents); I could still climb on them, but they were invisible.

    If it happens again, I'll be sure to post a video here.

  • Abeonis
    55 posts

    @abeonis @Ubi-Raziel Here's a YouTube link to a brief video showing the bug:

  • Luggy_Baby
    1 posts

    @darkred00 I have the same issue with the Xbox series X.

  • CruiserKing73
    1 posts

    Having graphics issues on Valhalla. The foliage around my character disappears wherever I move to. Not game breaking,  but definitely very distracting. Have uninstalled both the save game as well as the game itself, and reinstalled, and it is still disappearing. Really takes you out of the immersion. I have video, but unfortunately can't share it here.😒


  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    Hey guys, is this happening in a specific area or is it happening every time you hide? Would you guys be able to provide a video of this?

    Official Response
  • fjmmdo
    3 posts

    @ubi-spud happens every time hide and camp fabric disappear too

  • morianehtar
    2 posts

    @drunkpanda687 same just happened to me as well exactly after the same quest.
    Had been playing for an hour before hand without any issue.
    Right after the ending curscene of the mission it started.

  • morianehtar
    2 posts

    @morianehtar update:
    After saving the game going to the game menu and force quitting the game (by using PS4 button and "close application" it fixed itself after rebooting the game.

  • El_Mattiaso
    55 posts

    I discovered today when I was doing the Grantebridge arc that I could collect food from twigs on the ground. Later on I realised that the twigs were actually raspberry bushes that vanished when I got closer.

    Any way to fix this glitch? I think it started when I was burning down the hamlet with Galinn.

  • dimmkah
    1 posts

    For some bizarre reason those long vertical flags/banners outside of towns/camps/etc will appear, then disappear, then reappear depending on precisely what distance I am away from them. I can be far away and they're fine, or if I'm very close they're fine, but if I'm not too close they disintegrate out of existence. It's not game breaking but it's incredibly annoying and jarring and I wish I could make it stop.

    Here is a video of what I'm referring to:

  • littlet343
    3 posts

    Hello, I have been also encountering the same issue on PS5.
    This happens everywhere, not one specific area. This issue started for me when I first entered Lunden.

  • littlet343
    3 posts

  • RazielX10
    13 posts

    @darkred00

    Having the same issue. Also, some items that that are highlighted are not there.

  • littlet343
    3 posts

    So I had to reload the game 4 times for the textures to work properly again. Hopefully this issue can be resolved soon with a patch.

  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    Hey there! I'm sorry the grass isn't doing its job. I've completed these quests and the grass seemed to be working normally on this end. Could you please verify your game files and test this area again? If the issue persists, could you also provide a video?

    Official Response
  • fjmmdo
    3 posts
  • Bl00dyKill3r
    1 posts

    @drunkpanda687 i had the same issue (PS4), I fixed it by changing a few display settings in the game itself, from the home screen (before loading the back up) : HUD settings & resize the display “safe zone”.


Suggested Topics

Community Details

35
Online
130.3k
Users
22.6k
Topics
117.0k
Posts