Welcome to discussions

Quick Suggestions

  • ishofique
    5 posts

    Just here to confirm. Lasted driver patch. Latest game patch. But still no loot. I suspect it was on the square pool.

  • Ubi-Borealis
    Ubisoft Support Staff 2223 posts
    Best Answer

    Hello all!

    Following the announcement of TU 1.2.0, I would like to reach out to you all with an update. The development team plans to resolve the issue wherein treasure hoard maps remain in the inventory, even after the hoards have been successfully looted, in tomorrow's update!

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
      
    If the issue still persists for you following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • The treasure hoard maps remain in Eivor's inventory after being looted.


    Thanks all! 😊

    Official Response
  • SofaJockey
    169 posts

    @chuckkatse Apparently the Treasure Hoard Map bug for Oxfordshire was fixed with the 1.1.0 patch. I went back to the well and the design was there. The map also was removed from my inventory.

    In which case it's not retrospective. I already have the design so not removing the map from my inventory is no big deal.

    But the Eurvicscire treasure is still missing to me.

  • Magus_Zeal
    3 posts

    @poorkenny I’m on PS5 with patch 1.1 bug still present. Collected treasure but map remains in inventory.

  • Magus_Zeal
    3 posts

    @magus_zeal also if you save and reload the file you can “collect” the artifact again for more XP (you don’t get any items just XP).

  • VanTina94
    3 posts

    Just stared on the hoard maps and just collected the Oxenefordscire treasure and the map is still in the inventory!

  • Phinx-x33
    9 posts

    @ross-boy-89 1.1.0 update made things worse. I had to reinstall my game (PC)

  • mhale24
    2 posts

    Hello!

    I was completing my treasure hoard maps, and noticed that there are three that I have collected the treasure but it doesn't count it as being collected. The three are Eurvicscire, Oxenefordscire and Suthsexe: Witch's House.

    I play on PS4, and have a few other glitches as well. But there are posts for those. I did not see one for this, so I thought I'd post something. If I overlooked it, please feel free to let me know. Otherwise, great game do far!!

  • CorwynGreenleaf
    3 posts

    Xbox One player and it's not there for me either even after the recent update. Also still have Oxenefordshire map in my inventory but already collected it.

  • CorwynGreenleaf
    3 posts

    Acquired the Eurvicshire treasure map, and when going to the obvious location shown in the clue map, where a Drengr is also located, the treasure is not there anywhere.

    Also, I have found and collected the Oxenefordshire treasure and somehow still have the map roll in my inventory.

  • SofaJockey
    169 posts

    @corwyngreenleaf Yep. They are known and outstanding bugs. I hope they will be addressed at some point. 🙄

  • ImaginaryRuins
    382 posts

    The Ledecestrescire treasure is also bugged for me; the location doesn't have anything to interact with.

  • Sam_Boo26
    146 posts

    I also have this bug with the Oxenefordshire treasure. I still have the clue map in my inventory, and every time I go back to the location, I can "take" the treasure, I receive xp, but not the treasure itself.

    I hope they will correct this soon.

  • FatalStatistic
    1 posts

    Rygjafykle is still glitched for me. Saw a thread from a month ago that it was "fixed". The whole island is damn near glitched.

  • Th_White_Snoman
    3 posts

    @corwyngreenleaf Exact same for me too. Also on Xbox One.

  • Th_White_Snoman
    3 posts

    @ubi-raziel Hello, Xbox One here.

    Oxeneforscire Hoard was picked up. The location for me was visible and after I interacted with it, I received the loot. The map remained in my inventory.

    Eurvicscire Hoard is not showing up. I believe there are more threads on this one specifically. No marker, cannot visually see it, nor interact with it. Definitely have not picked it up, but if I somehow have, the map is still in my inventory.

    Also, a new recent thing with the Yule update has made me only able to carry the amount of arrows that you start the game with. I went from being maxed out on it to now having 12, 20, and 5. Can't seem to fix that one yet. Not sure if it's related, but ever since then my quiver is also invisible. Very weird.

  • larrykop1967
    65 posts

    I'm on PC, i too have this bug, i'm on 1.1.0, and there is no treasure to pick up,

  • Lobosilvano
    4 posts

    Same problem in PS4. Patch 1.1.0 dosen´t resolve bug. 😧

  • NerdyGirl1516
    1 posts

    Oh my god it’s still not fixed since November? Dang. I just got to the solution location and it’s still not there. My Oxford map is still in my inventory even though I solved it as well.

  • Rogu3Cowboy
    5 posts

    I'm currently having the same issue with the Oxeneforscire hoard map. I've collected the treasure but map does not remove itself from my inventory. I've also noticed...I can log out...log back in and the prompt to collect the treasure is there but upon activated you don't get the treasure again but you do get the full experience for it.

  • Metroid_Meister
    30 posts

    I still have the bug for the treasure hoard map in Oxenefordscire where the map remains in your inventory when you pick it up. I would like to know when that will be fixed.

Suggested Topics

Community Details

50
Online
131.0k
Users
22.7k
Topics
118.0k
Posts