Welcome to discussions

Quick Suggestions

  • Lysvander
    63 posts

    Can add to this, bit of a minor issue, but maps do indeed remain in the inventory after acquiring the rewards.

    1/ acquire reward, but don't have the map (i suppose) - because i tried to recover several, but it seems they were already in my inventory.
    2/ have map, go to spot, get reward - map remains - this i had happen once so far, and 4 maps remaining, although not sure if i got map or reward first. did not search specifically for them though.

    @ubi Is this a recognized thing? If you need screenshots of map and reward in inventory for clarification, can supply those.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    Following the announcement of TU 1.2.0, I would like to reach out to you all with an update. The development team plans to resolve the issue wherein treasure hoard maps remain in the inventory, even after the hoards have been successfully looted, in tomorrow's update!

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
      
    If the issue still persists for you following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • The treasure hoard maps remain in Eivor's inventory after being looted.


    Thanks all! 😊

    Official Response
  • JSRG1840
    80 posts

    @lysvander whilst it's not in the mega thread list there's been so many threads on this like the fish issue, that its had official responses to it.

    I've got the same bug on the ps4. To the level of actually triggering the trophy for ps4 and ubisoft connect with the oxford treasure map.

    I've collected the lot and still have these two maps in my inventory.

    There are alot of bugs with the treasure maps though as usual its primarily PCs which are affected.

  • cberrya6e
    4 posts

    Confirm that Eurvicscire hoard still not showing up, not picked up. Xbox One platform.

  • Kemp_NL
    3 posts

    @poorkenny Same issue, still present in the game as of now

  • Kemp_NL
    3 posts

    Same problem, still present in the game

  • silacoid
    15 posts

    Same problem, on PS5. None of the usual tricks works

  • silacoid
    15 posts

    Same issue, PS5 1.1.0

  • rankinsect
    52 posts

    Same issue, on PC. I'm absolutely positive I'm at the right place, and nothing to loot.

  • rankinsect
    52 posts

    @chaosandcoffee I actually did get more XP from re-looting the hoard.

  • C06RACOILS
    12 posts

    snakebite figurehead not spawing . i have collected the map and went to the correct place i even doubled checked on the internet but i cant collect the snakebite figure head

  • guest-rShokhyn
    1 posts

    Also bugged on Xbox Series X (but my save file is originally from Xbox One)

  • jasonhenderson
    3 posts

    Same issue- Eurviscire hoard treasure location bugged

  • m_scatterbrain
    6 posts

    same issue....one other
    I would say, near the end, valhalla is plenty of bugs

  • LedoveeeKladivo
    64 posts

    same issue here, PC 1.1.0

  • djAqualim
    1 posts

    Oxford map is still in my inventory after getting the reward and still waiting for big mackeral and big flatfish.

    spoiler

  • Kruwman
    1 posts

    Same here bugged on PC version.

  • DomRyan24
    2 posts

    PS4 still bugged can't complete 100% and still 2 maps shown in inventory that have completed

  • Grgisimus
    1 posts

    Have same problem with the hoard map... I collected the treasure, recive 180 exp and no snakebite figurehead scheme.... The map is remain in inventory...

  • ItsBaxton
    1 posts

    Same here for Grantebridge on Xbone...

  • jetblackfighter
    34 posts

    @ubi-raziel

    Oxeneforshire glows, and I can interact, but nothing gets looted, map remains in inventory.

    Euriviscire no interactions possible, map remains in my inventory.
    PS4.

Suggested Topics

Community Details

51
Online
192.7k
Users
32.5k
Topics
162.5k
Posts