Welcome to discussions

Quick Suggestions

  • RET72089
    2 posts

    @domryan24 same. my oxenfordscire map is still in inventory after being collected

  • Ubi-Borealis
    Ubisoft Support Staff 3562 posts
    Best Answer

    Hello all!

    Following the announcement of TU 1.2.0, I would like to reach out to you all with an update. The development team plans to resolve the issue wherein treasure hoard maps remain in the inventory, even after the hoards have been successfully looted, in tomorrow's update!

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
    If the issue still persists for you following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • The treasure hoard maps remain in Eivor's inventory after being looted.

    Thanks all! 😊

    Official Response
  • shmu__
    1 posts

    @chuckkatse i'm one of those who didn't get anything

    yes, they need to fix this.

  • Albino_Raven
    1 posts

    Still bugged as of today. Funny how Ubisoft can inject micro-transactions and "time savers" with no problems but can't fix a simple missing treasure hoard.

    5 posts

    @chaosandcoffee I am having the same problem. I hope this is resolved in the update tomorrow. I know it said it will resolve the issue of it not being there but it is there but after I pick it up the map will still be in my inventory as if I never completed it. I’m on Xbox oneX.

    5 posts

    I am on Xbox oneX and I found the treasure and picked it up and got my reward but the map is still in my inventory. I know a lot of people have been having trouble with not having the treasure show up, but my problem is a little different and I was wondering if it will be fixed as well in the update tomorrow?

  • TheeElf
    262 posts

    From the Title 1.1.1 update post:

    • Addressed an issue where some treasures wouldn't be at their location or couldn't be looted. (Grandbridgescire, Hamptunscire, Oxenefordscire, Eurvicscire)

    I would assume yes as I think this is the same problem everyone has with this particular location. For the Eurvicscire location the loot pick up option never even appears. Not sure on the other 2 locations as I never encountered any issues with them.

  • Batassassin16
    1 posts

    2 months since this bug was posted and still no fix??? What's going on at ubisoft man. I also have the issue where the Oxenfordschire map doesn't leave my inventory

  • bitebug2003
    106 posts

    I was able to retrieve the Eurviscire treasure now with the latest patch.

    But the Treasure Hoard Map is still in the inventory

    Once again with the Oxenefordscire Treasure I went back to the location and it let me 'retrieve the treasure again' (despite already getting it on my first time).

    But the Treasure Hoard Map is still in the inventory

    And Mouse (wolf) is still missing 😔

  • Youldinho
    19 posts

    I am the same! It’s so annoying 🙄 still doesn’t register that I have completed it and I can keep going back for exp but rather it just be completed

  • Youldinho
    19 posts

    This still happens after the latest patch!!!! 1.1.1

    Ubisoft sort it out please 😫

  • Marintex03
    1 posts

    I was finally able to collect the eurviscire treasure from the hoard map in the center of the water area where you fight the dranger but that map is still showing in my inventory. 1 bug fixed but another still there. Anyone else able to collect on this but map still appearing?

  • stpp1
    11 posts

    Oxenefordscire treasure hoard is still bugged after patch 1.1.1. The loot is visible but when you click on it you only get the points but no loot. Also, the map remains in your inventory.

  • dim344
    28 posts

    I had the same exact problem. The trasure appeared after the patch but now the map is bugged.

  • Overlord587
    1 posts

    The Treasure-maps: eoforwicscire and oxenafordscire dont go away after loot.

    5 posts

    @theeelf it allowed me to loot it and I have the reward but the map is still in my inventory and won’t go away. Even after I looted it, it was still there for me to loot a second time and the map was still in my inventory.

    5 posts

    @jetblackfighter I am having the exact same issue. I’m on Xbox OneX

    5 posts

    @th_white_snoman I am having the same issue with the map and arrows. I’m on Xbox OneX as well.

  • D_S_T420
    1 posts

    The oxenfordshire hoard map is still bugged. I've collected it but the artifact doesn't show collected on my map and the white dot is gone. I've collected the treasure for The horde map and it's still in my inventory it's completely bugged

  • ziggurcat
    167 posts

    One the one hand, the reward for the Eurviscire hoard map has now appeared where it's supposed to be located, but the Oxenefordscire and Eurviscire maps still do not disappear from the inventory when you find the treasure located on those maps, thus allowing you to gain infinite XP by simply creating a save point after collecting the reward, loading that save point, and recollecting the XP.

  • TRITONK-175
    32 posts

    Part of the latest Valhalla update (Update 1.1.1) was that it'd fix Treasure Hoards that were bugged and therefore couldn't be looted. Prior to the update I had three that were bugged; Oxenefordscire, Eurvicscire and Hamtunscire.

    As of the latest update I was able to loot Oxenefordscire and Eurvicscire but their maps stay in my inventory for some reason. As for the Hamtunscire Hoard, it was at first still unlootable but then I was suddenly able to do so... except that I wouldn't get anything from it and the map would stay in my inventory.

    Lastly, all three locations are seemingly infinitely re-lootable. Almost like the game still registers them as unlooted as the maps are still in my inventory.

    I know I'm not the only one who had issues with these and other Treasure Hoards both before and after the latest update.

Suggested Topics

Community Details