Welcome to discussions

Quick Suggestions

  • noa30
    6 posts

    PS4 - Oxenfordschire map is still in my inventory but I got the treasure. If I go back to the well the glow is there and I can interact but I don't get anything.

    Eurvicscire treasure is definitely missing. Have the map in my inventory but the spot it's supposed to be at, there's no glowing spot.

  • jeje_71
    69 posts

    @noa30 same boat here
    oxenefordscire map in inventory, the glow which i can loot, but i get only experience and i don't have the snakebite scheme in my inventory...

  • The_Grayest_Ben
    4 posts

    Same problem here – add it to the list I guess!

  • Draeoth
    24 posts

    After picking up the loot, the map is still in my inventory.

  • hotwheels78
    2 posts

    Title says it all. There is no hoard in the well. Got the hoard map out of the cave, went to the well, and nothing. I check every corner to see if I'll get a prompt, but nothing. I'll use Odin's Sight, but nothing. It's just empty. Checked a few guides online to make sure I'm not missing anything, but I'm in the right place. Went back to a previous save from nearly an hour before, fast traveled to a different region, saved, fast traveled back, saved, restarted the game, went back to the cave for the map, went back to the well, and still nothing.

  • h4andwerkjj
    2 posts

    So I have completed every area and I thought that was enough for the completionist trophy but I guess not. Do I need all treasure hoards for it?
    If so that a problem because two are bugged. The oxenefordscire treasure is there and I've collected it but the map stays in my inventory. The Eurviscire treasure just isn't there at all.

    No disrespect, but if you all can't figure out the treasure hoards can you just remove that part from the trophy? It just a little bit annoying spending 120 hours playing a game then not getting the trophy because of a bug.

  • NKSedya
    1 posts

    Same issue (Xbox One)

  • Pabegelis
    3 posts
  • Jaimew22
    5 posts

    Same issue here on PS5 have the reward and can no longer find anything in the area but the map is still in my inventory

  • SofaJockey
    169 posts

    @pabegelis That's exactly where I went too, but no joy. (Xbox)

  • AzkikrSean30
    1 posts

    I've completed the treasure hoard in Oxenefordscire but it didn't register that collected the loot and the treasure hoard map is still in my inventory. I've since fast traveled, restarted the game and tried completing again and same thing happens. Eivor does the looting animation but no loot is collected. Still showing as my last artifact to complete in Oxenefordscire

  • bmoltz117
    1 posts

    Has anyone else has an artifact not register in Oxenefordscire, specifically the 2nd treasure hoard map by the lake east of Oxeneforda?

  • Matador064
    4 posts

    I am unable to find the treasure at this location. I did fight here, but I never touched the area in question and thus should not have looted it at any point in time.

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @matador064 Hey there - just to be sure, does the game say you've claimed the treasure, or is it still unopened on your map? I'd also love to see a clip of the issue you're encountering so we can best understand what's occurring.

    Official Response
  • VasilyZaitsev42
    13 posts

    Happens on pc. I have the reward but it remains "lootable" and in my inventory. Also ledecestrescire and eurvicsire hoards won't spawn

  • VasilyZaitsev42
    13 posts

    Also ledecestrescire and eurvicsire hoards won't spawn

  • Olishanta
    4 posts

    I have this issue on PC as well.

  • guest-2j588UaI
    2 posts

    Similar issue.
    Still have the map, not schematic, and the loot is not


    I hope they patch this soon.

  • guest-2j588UaI
    2 posts


    I have this same exact issue. I tried to collect it after the latest update. No luck.
    Version 1.0.4

  • oNoZoYoMo
    2 posts


    I'm playing on Xbox One and picked up and resolved everything (treasure chests, artifacts, mysteries etc.) except the Oxenfordscire and Eurvicscire hoards.

    I found the artifact in the pool in Eurvicscire which is marked with an x on my map, but besides that both hoards don't show up in the world with a glowing marker and there is nothing to interact with. The pool is empty and the well in Oxenfordscire only contains a breakable box and two chanterelle mushrooms...

Suggested Topics

Community Details