Welcome to discussions

Quick Suggestions

  • VanadiumCobalt
    317 posts

    Just a thought. Explosive arrows? Oil jars? or throwing a large rock? The rock could be tedious as carrying it from distance you will need no interruptions, no fighting with anything as the rock could vanish.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello there!

    Following the release of TU 1.3.0, I'm happy to announce that the development team have deployed a fix for this issue. You should now be able to interact with Nokkfylla Shine-eye to complete this world event 😄

    If you are still unable to interact with Nokkfylla Shine-Eye, please can you send us a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • That you are still unable to interact with Nokkfylla to complete the world event.

    I would recommend uploading the footage to a sharing platform, such as YouTube or Google Drive. This will allow you to post a shareable link within this thread. We can then forward these reports to the development team for further investigation.

    Thanks! 😊

    Official Response
  • Panthea1974
    Original poster 7 posts

    @vanadiumcobalt i trided everything already, i think i give up 🤣

  • Panthea1974
    Original poster 7 posts

    @ubi-keo i trided everything i give up and hope it resolve it self

  • zDecyfer
    1 posts

    Hey Guys,

    I just came across the same issue taking on this lost drenger. I’ve attached a screenshot of my particular case. Pretty sure I used harpoon impalement to pull him towards me and finished him off. But I guess that got him stuck in the wall and now I’m unable to speak to him.
    Any help or insight would be appreciatedundefined

  • url_bi
    2 posts

    defeated him but pushed him up there so i can't talk to him.. any ideas?

  • Ubi-Mark.
    Ubisoft Support Staff 1324 posts

    Hello @url_bi,

    Thank you for bringing this to our attention! Can you please provide us with the name of the quest/mystery, so we can investigate it further? Additionally, have you tried fast travelling or restarting your game to check if you're able to complete this quest?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • url_bi
    2 posts

    @ubi-mark I've tried restarting way too many times but nothing happened. It's the six Lost Drengr quest. More specifically Nokkfylla Shine-Eye in Eurvicscire

  • Ubi-Mark.
    Ubisoft Support Staff 1324 posts

    @url_bi Thank you for the update! This issue is currently being investigated. Once we have an update, we are going to let everyone know through the patch notes.

    Additionally, we have a megathread for this one, so I merged this thread with the main one for better visibility. Apologies for any inconvenience caused by this.

    Official Response
  • spelldazer
    6 posts

    After the recent update, the missing dialog triggered as I approached the drengr. He then fell off the wall and I could confirm the kill. Yay! I hope it's fixed for everyone else too.

  • Panthea1974
    Original poster 7 posts

    @ubi-mark same problem for a long time trided everything. Unfortunaly latest up date didn't solve it

  • sooupper
    3 posts

    NPC stuck on wall. Cannot not speak to, cannot finish.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @spelldazer I'm pleased to hear the latest update resolved this issue for you! Thanks for letting us know. 😊

    @Panthea1974 Currently, this issue remains under investigation I'm afraid, but I've let the team know that you're still unable to proceed with this mystery following the latest update.

    Official Response
  • ubi-smash
    Ubisoft Support Staff 794 posts

    @sooupper Hey there, thanks for coming to us with this report. We have collected similar reports from players encountering the same issues with this quest. We have made the development team aware of this issue and they are currently investigating it. Once we have further updates, we will be keeping everyone posted. Thank you for bearing with us in the meantime.

    Official Response
  • jbadham
    1 posts

    Have defeated the lost drengr in Brunton Turret but he is glitched on the wall in a crouching position. I have tried fast travel, completing other events, meditation to try and reset this event but nothing fixes it. Please help as this is stopping me gaining 100% completion

  • pauldrkin
    1 posts

    Hi. Just want to share also the bug I still encounter after several patches. Since January (I think), I already encountered this bug and go on with other quests while waiting for the patch.
    However, after patch, the bug is still there. Tried all possible solutions I know, but failed. See screenshot belowundefined

  • Farqualeuh
    1 posts

    Please Ubisoft, can you find a fix to this bug !
    I would get the dagger of Ragnar and it's the last drengr I need to confirm the kill.
    I have exactly the same problem : I killed Nokkfylla but unable to dialog with him.
    I tried everything thinkable : throw everything possible on him, come with horse, explosive arrow..

  • Ubi-Keo
    Ubisoft Support Staff 1472 posts

    @jbadham @pauldrkin @farqualeuh

    Hi all,

    I have merged your posts with this megathread that we have created for this issue. I can confirm that this is still being investigated by the development team. I have forwarded them your cloud saves to help with their investigation.

    Please keep checking here, the known issues list and the news and announcements page for updates.

    Official Response
  • RageboyDk
    4 posts

    This happend back in start of december 2020, made one bug report since, this is my second.
    I am unable to talk to the "lost drengar" in the top of Eurvicscire, at Brunton Turret and thus not able to finish the last mystery.
    I do not have any backups from before this happend, since its a long time ago. There is also a little bit more infomation in the description of the youtube video.

    Video of the bug -->

  • RageboyDk
    4 posts


    • How did you knock the Drengr into the water?

    I used the ability called "bash" where you run towards him and then grab him to then throw him over the cliff into the water, of which he "died" from

    • Which weapon did you use to finish the Drengr?

    Pretty sure I was using a hammer (dont remember the name) but its the one where it applys posion on hits (or crits)

    • Did you use an ability to finish the Drengr, if so which one?

    I used bash

  • Ubi-Keo
    Ubisoft Support Staff 1472 posts

    @rageboydk Thanks for the information provided, I have forwarded this onto the development team. I have also moved your posts to the correct mega thread.

    Official Response

Suggested Topics

Community Details