ubisoft discussions

Quick Suggestions

  • Lwelshy92
    2 posts

    I’ve had two bugs in Norway on two world events/mysteries ..... one with Erik loyalskull, I defeated him but won’t let me speak to him either though there is a button to icon to speak to him and the other is the fly agaric where you have to go through the gates ... i go through the gates in the correct order and then the screen goes white and then I’ve seen that evoir should start saying something but he/she doesn’t and the effects of the fly agaric are still there untill I leave the area

    tried reloading a save, fast travel, gone to England and come but don’t seem to work ..... just wondering if anyone else has had the same problem and managed to fix it

  • crysis_time
    1 posts

    I finished the quest and jumped of the cliff for fun. When I relaoded, the crates were still there and the quest icon still shows so I can't complete the quest because I can't talk to the character who isn't there anymore.

    I've seen on reddit and Youtube that a lot of people have the same issue. I need that quest for the Platinum Trophy. I'll wait until it's fixed.

  • DarkFlyingWolf
    16 posts

    I'm unable to complete Old man on the edge. I'm throwing all stuff of the edge, then talk to the man, he jumps off, and i get no reward or completing message. In my map the quest remains, but the guy is gone, so is his stuff. Unable to complete this quest.

    This also happened with 3 other world event quests. Any solution for this?

  • Ubi-Swaggins
    Community Manager 433 posts

    @darkflyingwolf I am sorry to hear that you are having trouble with World Events.

    Can you remember which specifically you have had issues with? Can you provide a short video detailing this world event issue?

    Official Response
  • Remy83130
    1 posts

    Hi, I had the same bug with Erlend. A wolf attacked him and he died, that didn't end the quest. Here are the screenshots :undefinedundefined

  • BigR0b1972
    12 posts

    Hi i am unable to complete the Mysteries in Norway, even after the 1.04 patch.

    World Events in Rygjafylke not resetting or completed - Fly Agaric, Lost Drengr, The Hunt for Honor and Old Man on the Edge.

    Many Thanks

  • BigR0b1972
    12 posts

    @marathondad2 same for me, World Events in Rygjafylke not resetting or completed - Fly Agaric, Lost Drengr, The Hunt for Honor and Old Man on the Edge. annoying isn't it?

  • Hoggar
    3 posts

    Can't deliver the Comb to the woman in Rygjafylke, can't kill Erik Loyalskull... really disappointed with the game overall, seems like u guys don't even play your own game to see the bugs, should try sometime 🙂
    Game version 1.0.4 - PS4

  • Hoggar
    3 posts

    The guy that needs to prove his courage by defeating the Bear and his body are gone too...

  • Hoggar
    3 posts

    The Prodigal Prince (main mission) bugged too, after training with the blade... For God's sake... why release a game with this amount of bugs? U play a game to enjoy it, but you only get angry, because u can't do side missions, and can't progress on the game's history... [censored] this [censored].

  • Zoruro1
    4 posts

    I cannot reach an earlier save at all where I can finish Hunt for Honor. Please ubisoft make a way to reset world events completely to resolve this. I am posting here to help further provide evidence to tc's claim . I brought an animal to Erlend as well and he was killed and now his body is missing and an event marker remains on the map. This is post 1.04 patch as well.

  • FallenDonger
    1 posts

    I've attempted the completion of the Hunt for Honor quest and brought Erlend the beast he desires. After he is defeated by the beast there is no dialogue and the marker remains on the map, I've tried to fast travel somewhere and come back and reset the game, his body as well as the beast remain there and i am unable to complete the quest.

    After defeating Erik Loyalskull he crouched into the corner, When I attempt to talk to him the option to speak goes away and I can not complete the quest.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    @C06RACOILS

    Hey there, apologies for the bump but the developers would like some more information on this issue if possible?

    • Did you complete the mystery on your first try?
    • Does the issue persist after reloading a save or fast travelling?
    • Has this happened when doing other activities?


    And this one goes out to anyone else reading this - if you have encountered this issue, please let us know!

    Official Response
  • Magnetons198989
    2 posts

    i got the same issue and thats after the update.I beat the Drengers(2 in totall) they lay down on their knee and i cant talk to them

  • Mohisento
    1 posts

    A bear killed the NPC, now i can't get the quest and the corpse remains there, tried fast travel to another location but the NPC is still dead.

  • xBlazinkaoSx
    3 posts

    I fought 2 drengrs so far and after beating them and try to talk to them nothing happens they just stay there kneeling. Also the Mystery lady where you look for her comb in the deep lake can’t interact with her as well after trying to talk to her. I reboot the game and still doing the same thing.

  • ccssdxdx
    1 posts

    A bunch of polar bears followed me to this location without really me knowing they were following me from the nearest summit fast travel point (I thought I would lose them because I was on a horse!). The bears ended up killing the NPC. I tried fast travelling to other locations and coming back, but the NPC was still dead lying on the ground. I tried exiting the game, and I even tried restarting my PS5, but he was still lying dead on the ground after I reloaded the game.

    Out of frustration, I picked up the dead NPC body and threw him off the cliff as a hail mary (saw walkthroughs in Youtube how that's what you're supposed to do in the quest), hoping this would somehow trigger something. I tried reloading/restarting PS5 again, and now the NPC is completely gone & I can't find him anywhere. I even tried going down the cliff trying to find his body, but I couldn't find his body anywhere. The boxes continuously respawn upon revisit/reload/restart even if I throw them off the cliff, so I'm wondering why this isn't the case for the NPC.

    I noticed some users are experiencing similar issue - how they cannot complete the quest even if they completed it. I noticed one other user posted how a bear killed the NPC too (https://discussions.ubisoft.com/topic/85834/bug-old-man-on-the-edge-world-event?lang=en-US).

    I tried completing this quest super early in the game, before heading off to England if that matters.

    Please fix this bug!

  • speedynl21
    79 posts
    This post is deleted!
  • Kuman.sky
    11 posts
    This post is deleted!
  • BioHazard2012
    4 posts

    Is this fixed yet as i am having the same issue on ps5 and dont want to update to .04 as there are more issues with that update.

Suggested Topics