ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to complete World Events in Rygjafylke | POST HERE

    0 likes/214 replies/7629 views
    ubisoft:x-posts, 1

    @kingchallal Same happened with me, but i climbed down the mountain so i could see his body and take a print of it, when i got to his body and pressed f12 the game crashed, i got back in and i was right back on the edge, the old man was gone but not his horse, later that day i went back there and the horse was also gone.

  • Eagel1994
    ubisoft:x-posts, 2
    So first bugged i found is lost denger you cant enter from one side bud bud when you deaft the boss you cant speak to him so you cant fish it. The second bug i found is World Event: The Hunt for Honor erkend got killed and now he wont respawn so the quest cant be finished.
  • UbiKoreanBBQ
    Ubisoft Support Staff ubisoft:x-posts, 390

    Hey there Eagel1994! I'm sorry to hear you've encountered both of these issues! They sound very frustrating. Would you be able to reproduce the steps for the first issue and take a video clip for us? For the World Event where Erlend won't respawn, can you take a screenshot of the location he's supposed to be in and send that our way? Thank you for your help!

  • dcferrari13
    ubisoft:x-posts, 1

    Hi, not sure if anyone else has experienced this issue. Here's what happened:
    I spoke with this guy "Erlend" and brought him back three wolves. The wolf attacked him and he died so I ended up killing the rest of the wolves. Now he's dead and just lying on the ground. All you can do is carry him that's it.. I didn't get the quest complete message, and the icon stays on the map. Does that mean it's stuck and there's no way for the event to be completed now??.. 😞 Is this a bug/glitch? I'm already 7 hours into the game and I don't want to start all over again. Help anyone??undefined

  • longjohn119
    ubisoft:x-posts, 1364
    @torusya My guess is they are caused by a dialogue glitch: all those quests will be marked complete by the game after Eivor makes a comment at the end of the quests, but his dialogues are glitched. I went to Heillboer where Eivor's parents were killed in the opening sequence and interacted with two objects, the sword Eivor tried to pick up and the helmet at the spot where Varin died (it's funny because in one of the side quests Eivor found a guy selling his/her father's helmet). I was expecting him to say something, but instead Eivor just took a look at them without making comments. Although I am not 100% sure this is also a dialogue glitch, I think there is got to be more to those two interactions. Hope someone can confirm my suspicion.

    I just did that quest and you are correct there is supposed to be dialog when you trigger it with a button ..... It's just a short couple of sentences kind of reminiscing about the original event ..... I wonder if some of this may be due to character choice, I've had no problems but I'm playing "Let the Animus decide" and I'm a female Eivor in that part .....

  • YukiWolf_
    ubisoft:x-posts, 1

    In the missions "events of the World" i have one bug, is called "old man on the edge". The old man is not there. I can't finish the mission

  • Ahmn57
    ubisoft:x-posts, 1

    I'm stuck on Eric, loyal-skull, i defeat him, but then when i try to talk to him, nothing happen.
    The same [censored] is happening with the women who asked me to find her comb under water. When i try to talk to her after i found it, nothing happened.
    I tried to reload many times, restart the game, nothing change.
    And to finish, that same bug is happening on the quest the prodigal prince. After i complete the assassination moves, i talk to sigurd, we go on docks, but then i cannot talk to him.
    I dont know what to do exept wait on a fix

  • Nightally
    ubisoft:x-posts, 5

    @ahmn57 wait for a fix. you could try leave the area and come back later, or try blowing your horn a few times (this is not an euphemism) until the character starts talking. Sometimes it makes old dialogue catch up, it's weird

  • OliasTheReeper
    ubisoft:x-posts, 1

    I completed the mystery by throwing the crates off and watching him jump off then I accidentally jumped to my death trying to go find his body, and had to reload my game. When I reloaded it, the map showed the mystery as still active but the man is dead at the bottom of the cliff as if it is complete already. Having this one mystery left in this region is killing me and I have tried everything to get him to come back to life somehow so I can redo the mission.

  • PhillBoBagginz
    ubisoft:x-posts, 1

    2 mysteries quest are complete but will not clear. The first is the warlock quest towards the south. I killed the hunter and can’t progress. The 2nd is Erik loyalskull. I beat him and he is just kneeling there. The speak command doesn’t work.

  • AxellSlade
    ubisoft:x-posts, 7

    So, I got to this guy who asks you to throw the boxes off the cliff. I threw them all, he proceeded to tell some stuff and promptly jumped off the cliff. After that, nothing happens. No quest completion, marker still on the map.
    I fast traveled somewhere else, came back and now the boxes are back and the guy is nowhere to be found.
    Anyone else had this happen?

  • AxellSlade
    ubisoft:x-posts, 7

    Had to go back to an older manual save and do it again.

  • Makosoklas
    ubisoft:x-posts, 2

    I'm having the same issue.

  • MarathonDad2
    ubisoft:x-posts, 2

    In the first area, there are 4 world events I can't get to unlock even after trying multiple times with reloads, fast travels, and fully closing and restarting the game.:

    • Guy who wants to kill an animal. I brought a wolf back to him, the guy proceeded to try and kill it, failed and died, and I killed the wolf. The guy is laying dead on the ground even after reload or fast travel.
    • Lady who wants a comb. I got the comb and when I try to talk to her nothing happens. The talk icon disappears and the event doesn't unlock. When I reload, the icon is there to talk to her, but nothing happens.
    • Guy standing at the top of a cliff. I did what he asked and he does what he does. (No spoilers) Event doesn't unlock. After reload, all of the boxes are back on the ground, but the guy is gone.
    • Guy who wants to give you a tour. I talk to him, he mentions a tour and tells me to follow him but just stands there. After reload, he's ready to talk again, but says the same thing and doesn't move.

    I'm playing on the Xbox Series X with the latest patches, if that helps. For all of these, the events are still unlocked and show up on the map. Hoping these can be fixed in a future update.


  • BerOtar
    ubisoft:x-posts, 4

    I brought him a very injured bear, then killed the bear for him, and he walked of joyfully proclaiming to be the terror of the caves or some such...
    That did count as a completed event.

  • C06RA01
    ubisoft:x-posts, 17

    please ingrore my previous post here is a better post regarden the bug.
    i was doing a mystries mission (fly agaric) to which i completed
    my player after the encounter had been become invincible
    here is a video showing you what i mean it shows u where
    https://www.dropbox.com/s/pnacui71rgacild/20201113004212.mp4?dl=: (https://dropbox.com/s/pnacui71rgacild/20201113004212.mp4?dl=0)1

  • Kerrik10463
    ubisoft:x-posts, 6

    Has anyone had this happen? I will begin a mystery and the quest giver will just do nothing.

    It has happened with multiple mysteries including: A New England and Rekindling.

    In a New England the quest giver mentions following him but then does nothing. If I reload a save, right before it reloads, the quest giver will start to speak and love, but then the game reloads.

    Same for Rekindling. I enter the house and the wife sits next to the husband. Neither speak. The quest cannot progress.

    similarly in the quest to help the seventh son kill a wolf. He promptly died and ... nothing happened. Quest does not end. No dialogue.

    I have also noticed that my crew no longer sings or tells stories.

    any ideas?

  • Kerrik10463
    ubisoft:x-posts, 6

    i have this problem as well. I would be interested to see if you also have problems with other events like I do. Such as quest givers not reacting to you once they give you the quest.

  • WPScorpionWind
    ubisoft:x-posts, 5

    I am thinking this is along the lines of the issue I'm facing. I have only 12/13 mysteries right now and this is the only one I don't remember doing. I know a polar bear spawns near here as well as a triple wolf spawn, so my thinking is somehow the bear or wolves killed him and basically bugged the event entirely. I would like to get this region completed as this is the only thing I'm missing all together.

  • Matthew1994mor
    ubisoft:x-posts, 2

    1) Some of the Mysteries in Norway are bugged out. The one in the port town where you brawl three people gets stuck when you win the fight, It forces me to move at a slow walk and will not progress the dialog beyond the guy calling a halt to the fight, but when i exit game the subtitles of the final guy you fight show up on the load screen asking if he won. No amount of reloading or restarting I do of my console fix it.
    2) the quest involving the warrior wanting revenge on the warlock will not progress after the fight. Both of them died in the fight and the quest wont complete or give me any sort of lead on what to do next.
    3) the crazy hermit living on a island that thinks he is in England wont move after the dialog with him asking if you want to be given a tour.
    4) the Fly agaric gate puzzle wont complete or give me XP for solving the puzzle.
    So far it seems to only be in Norway where the Mysteries is broken as I have had no trouble with the ones in England so far but I will keep a eye out. Any help with the problems i have had so far would be great. Have tried reloading and hard resting Xbox many times and none of that works.

Suggested Topics