Welcome to discussions

Quick Suggestions

  • Ahmn57
    1 posts

    I'm stuck on Eric, loyal-skull, i defeat him, but then when i try to talk to him, nothing happen.
    The same [censored] is happening with the women who asked me to find her comb under water. When i try to talk to her after i found it, nothing happened.
    I tried to reload many times, restart the game, nothing change.
    And to finish, that same bug is happening on the quest the prodigal prince. After i complete the assassination moves, i talk to sigurd, we go on docks, but then i cannot talk to him.
    I dont know what to do exept wait on a fix

  • Nightally
    5 posts

    @ahmn57 wait for a fix. you could try leave the area and come back later, or try blowing your horn a few times (this is not an euphemism) until the character starts talking. Sometimes it makes old dialogue catch up, it's weird

  • OliasTheReeper
    1 posts

    I completed the mystery by throwing the crates off and watching him jump off then I accidentally jumped to my death trying to go find his body, and had to reload my game. When I reloaded it, the map showed the mystery as still active but the man is dead at the bottom of the cliff as if it is complete already. Having this one mystery left in this region is killing me and I have tried everything to get him to come back to life somehow so I can redo the mission.

  • PhillBoBagginz
    1 posts

    2 mysteries quest are complete but will not clear. The first is the warlock quest towards the south. I killed the hunter and can’t progress. The 2nd is Erik loyalskull. I beat him and he is just kneeling there. The speak command doesn’t work.

  • AxellSlade
    7 posts

    So, I got to this guy who asks you to throw the boxes off the cliff. I threw them all, he proceeded to tell some stuff and promptly jumped off the cliff. After that, nothing happens. No quest completion, marker still on the map.
    I fast traveled somewhere else, came back and now the boxes are back and the guy is nowhere to be found.
    Anyone else had this happen?

  • AxellSlade
    7 posts

    Had to go back to an older manual save and do it again.

  • Makosoklas
    2 posts

    I'm having the same issue.

  • MarathonDad2
    2 posts

    In the first area, there are 4 world events I can't get to unlock even after trying multiple times with reloads, fast travels, and fully closing and restarting the game.:

    • Guy who wants to kill an animal. I brought a wolf back to him, the guy proceeded to try and kill it, failed and died, and I killed the wolf. The guy is laying dead on the ground even after reload or fast travel.
    • Lady who wants a comb. I got the comb and when I try to talk to her nothing happens. The talk icon disappears and the event doesn't unlock. When I reload, the icon is there to talk to her, but nothing happens.
    • Guy standing at the top of a cliff. I did what he asked and he does what he does. (No spoilers) Event doesn't unlock. After reload, all of the boxes are back on the ground, but the guy is gone.
    • Guy who wants to give you a tour. I talk to him, he mentions a tour and tells me to follow him but just stands there. After reload, he's ready to talk again, but says the same thing and doesn't move.


    I'm playing on the Xbox Series X with the latest patches, if that helps. For all of these, the events are still unlocked and show up on the map. Hoping these can be fixed in a future update.

    Thanks!

  • BerOtar
    4 posts

    I brought him a very injured bear, then killed the bear for him, and he walked of joyfully proclaiming to be the terror of the caves or some such...
    That did count as a completed event.

  • C06RACOILS
    12 posts

    please ingrore my previous post here is a better post regarden the bug.
    i was doing a mystries mission (fly agaric) to which i completed
    my player after the encounter had been become invincible
    here is a video showing you what i mean it shows u where
    https://www.dropbox.com/s/pnacui71rgacild/20201113004212.mp4?dl=1

  • Kerrik10463
    6 posts

    Has anyone had this happen? I will begin a mystery and the quest giver will just do nothing.

    It has happened with multiple mysteries including: A New England and Rekindling.

    In a New England the quest giver mentions following him but then does nothing. If I reload a save, right before it reloads, the quest giver will start to speak and love, but then the game reloads.

    Same for Rekindling. I enter the house and the wife sits next to the husband. Neither speak. The quest cannot progress.

    similarly in the quest to help the seventh son kill a wolf. He promptly died and ... nothing happened. Quest does not end. No dialogue.

    I have also noticed that my crew no longer sings or tells stories.

    any ideas?

  • Kerrik10463
    6 posts

    i have this problem as well. I would be interested to see if you also have problems with other events like I do. Such as quest givers not reacting to you once they give you the quest.

  • WPScorpionWind
    5 posts

    I am thinking this is along the lines of the issue I'm facing. I have only 12/13 mysteries right now and this is the only one I don't remember doing. I know a polar bear spawns near here as well as a triple wolf spawn, so my thinking is somehow the bear or wolves killed him and basically bugged the event entirely. I would like to get this region completed as this is the only thing I'm missing all together.

  • Matthew1994mor
    2 posts

    1) Some of the Mysteries in Norway are bugged out. The one in the port town where you brawl three people gets stuck when you win the fight, It forces me to move at a slow walk and will not progress the dialog beyond the guy calling a halt to the fight, but when i exit game the subtitles of the final guy you fight show up on the load screen asking if he won. No amount of reloading or restarting I do of my console fix it.
    2) the quest involving the warrior wanting revenge on the warlock will not progress after the fight. Both of them died in the fight and the quest wont complete or give me any sort of lead on what to do next.
    3) the crazy hermit living on a island that thinks he is in England wont move after the dialog with him asking if you want to be given a tour.
    4) the Fly agaric gate puzzle wont complete or give me XP for solving the puzzle.
    So far it seems to only be in Norway where the Mysteries is broken as I have had no trouble with the ones in England so far but I will keep a eye out. Any help with the problems i have had so far would be great. Have tried reloading and hard resting Xbox many times and none of that works.

  • Matthew1994mor
    2 posts

    Update: I found another one that I believe is broken. The one where you help a guy throw his stuff off the top of the mountain wont complete. He jumps and then nothing happens.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hi there, thank you for your report! That is a really odd one....and it happened after the "mushroom taking" mystery? Odd!

    I'm sorry you came across this, the video is much appreciated. I have passed this up to the developers for investigation! 🙂

    Official Response
  • Ubi-Ginge
    Ubisoft Support Staff 257 posts

    @ahmn57
    If you still experience this after going through the steps in our PC troubleshooting guide, can you please contact us via Facebook PM or Twitter DM and send us a copy of your save game.

    Official Response
  • Albetax
    4 posts

    Bug in event story and drengr errant in norway After the fight i can't complete the mission

  • Albetax
    4 posts

    Bug norway second quest

  • Albetax
    4 posts

    Bug in 2 event story and drengr quest After the fight i can't complete the mission

Suggested Topics

Community Details

159
Online
193.7k
Users
32.7k
Topics
163.7k
Posts