Welcome to discussions

Quick Suggestions

  • Matthew1994mor
    2 posts

    Update: I found another one that I believe is broken. The one where you help a guy throw his stuff off the top of the mountain wont complete. He jumps and then nothing happens.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hi there, thank you for your report! That is a really odd one....and it happened after the "mushroom taking" mystery? Odd!

    I'm sorry you came across this, the video is much appreciated. I have passed this up to the developers for investigation! 🙂

    Official Response
  • Ubi-Ginge
    Ubisoft Support Staff 257 posts

    @ahmn57
    If you still experience this after going through the steps in our PC troubleshooting guide, can you please contact us via Facebook PM or Twitter DM and send us a copy of your save game.

    Official Response
  • Albetax
    4 posts

    Bug in event story and drengr errant in norway After the fight i can't complete the mission

  • Albetax
    4 posts

    Bug norway second quest

  • Albetax
    4 posts

    Bug in 2 event story and drengr quest After the fight i can't complete the mission

  • Albetax
    4 posts

    Bug in all event story Mission i can't interact with the quest

  • kizza0721
    63 posts

    This section is for forum feedback, not bug reports.

  • thevalcrist1985
    1 posts

    Completed this quest and old man jumped off the edge. Quest marker is still there and mysteries count won't update. Cannot restart quest.

  • jcriderlpn
    1 posts

    Heck, I was wondering how to even bring a beast back to this guy to begin with! LOL

  • Ayatollah769
    1 posts

    Most of the World Events in the game that I’ve tried have been bugged or broken. I am beyond disappointed in this game.

    The Hunt for Honor - I completed the event at the same time a bear killed the guy. Icon is still on the map, no resolution.

    Raider Recruit - I fight the 3 guys, nothing happens. I move in super slow motion. No resolution.

    Plight of the Warlock - No issues - completed.

    Elk of the Bloody Peaks - No issues - completed.

    Fly Agaric Hallucination Challenge - Make it through the 3 games as required. Nothing happens, no resolution.

    Old Man on the Ledge - Throw his crap off, he dives off the cliff. Nothing happens, no resolution.

    A New England - Start conversation - guys says to follow him and does nothing. No resolution.

    A Desperate Bounty - No issues - completed.

    edit - Wow, blocked the word b l 0 0 d y. Just a real great job Ubisoft. Trash.

  • nimilas
    1 posts

    Some World Events are not completing and the markers are still on the map, including:
    - Bring Me A Beast
    - Old Man on the Edge
    - The Rekindling


    Also, this one World Event 'A New England' wouldn't continue after the initial cut scene conversation with Hysing.

    Help! 😞 I tried going offline, fast travelling and restarting (as recommended), and reinstalling the game, but they still don't work right.

    What else can I do to fix it? Or do I just need to wait for the update? If the latter, how long will it be?

  • LEM.Hero
    1 posts

    I'm playig on PC, after completing the event I jumped off the cliff (Dying off course), then when I reloaded from last automatic save all the boxes had re-spawned but not the old man, I can see the World Event icon in the map and it's also missing from the region's mysteries count.

    I have fast-traveled a few times, completed the rest of the map and even restarted the game but nothing fixed it.

  • Tolkyyn
    90 posts

    I'm probably spelling the name wrong and SPOILER ALERT
    In a town in Norway that may be spelled Stavnger (there's no names on my map so it makes things VERY hard) Eivor finds a man who was at his/her home town when they were betrayed. She chases him to kill him, and every time she assassinates him, my PC crashes.

  • KoaNiolo
    1 posts

    This happened to me as well. Fell off the cliff soon after his event, reloaded at the top with his crates and without him. Unfortunately I didn't have a save I could load so I'm currently stuck unable to finish the event

  • Marquis_de_V
    1 posts

    @kingchallal I have the exact same problem so I can't complete Rygjafylke. I have all wealth & artifacts, but am missing 1 mystery because this mystery side quest won't complete. I threw the boxes, the old man jumped and is dead on the ground below, but the quest won't complete. Every time I leave and come back, the boxes are back at the top, but he is dead below. Please fix. I'd like to complete Rygjafylke with 100%.

  • ongeburz
    17 posts

    @marquis_de_v that is the quest that worked fine for me, it's the one with the viking sleepwalking that bugged out for me. When using the zipline I can not interact with him anymore.

  • satamerlauer
    1 posts

    I have problems with the following world mysteries so far:

    Rolf's request in Stavanger to help him choose the leader. I beat all 3 but when Rolf says ''that's enough'' nothing else happens, and Eivor is not able to do anything, just walk around slowly. Only way to escape is if I quit the game and load a save from before I approached Rolf. Also, when I quit to title screen, it does trigger the dialogue that should follow.
    Next mystery I have problem with is the hallucination challenge on the island of the deserted chalet. I go through the gates in the correct order, then there is a white screen as if something is about to happen, but nothing happens. I saw videos that Eivor should be saying sonething.
    Third mystery I have problem with is the one southwest of Stavanger when I should bring a beast to a guy so he can slay it. I got him a bear (should have been a wolf I know) he died, and doesn't respawn, but the mystery is not solved.


  • Pxichc
    2 posts

    I brought Erlend a beast, it killed him. Now the event marker is stuck on my map. I don't have an earlier save to go back to anymore. Am I going to have to start the whole thing over?

  • PVBuk
    1 posts

    After getting the comb, I tried to speak to Bil, but the ‘Speak’ triangle button prompt just disappeared, with no conversation following.
    I then walked back to Fornburg and found I couldn’t talk to Any NPC.
    Reloaded a save I made just after getting the comb, tried to speak to Bil: same bug.
    Loaded an earlier save before getting the comb, could talk to Bil to start quest, but once I got the comb, got the bug again.
    Playing on PS4 Pro on fully updated console firmware, and game (1.02).
    Video:


Suggested Topics