ubisoft discussions

Quick Suggestions

  • 0 Likes/205 Replies/35276 Views
    1 posts

    I killed max... now I can't get the key. Can you please revive the npc for me lmao.... or how about just making the barred door able to be opened how simple woukd that fix be. Only barred door that I havent figured out how to open in the game so far.

  • bloodlesspyro
    1 posts
    @poorkenny Open the back door by using the dive of the valkyries rank 2 skill. it has to be rank 2. you can open any barred door with that. i just used this cheesy method, since the game left me no choice (the quest was bugged for me too)

    This works. Spent hours. Figured well I tried everything else. Two hand with dive of the valkyries lvl2. Instant access

  • Dastardly44
    4 posts

    @o8sideus Same issue

  • Jeffrysp186
    2 posts

    For some reason I can pick up keys. I first noticed when I couldn't pick up the key in one of the treasures of britain. When I realized it was a bug is when trying to complete the "A rivalry for the Ages" quest. When the little girl distracts Maximilian, I try to pick up the key but it does not.

  • GhOsTMaLiYa
    1 posts

    @lordlenry thanks man it worked 😍

  • bminder
    2 posts
    Lundun completely completed except for the said quest. Ranvi reported at home, back to Lundun (now the key is there), talk to Maximillian again, hire a child, do it!
    This is how it worked for me!
    Translated by Google

  • PiMaC
    29 posts

    Still not fixed, I got the issue right now. 1.04 Xbox Series X

  • streethawkfan
    14 posts

    @aldarys i had the same issue on PS5, but i managed to sort it. if you got to were the quest 'The Demon Odor At The Tithe' is (Not far from this quest) grab a jar of fish oil from the barn, then run back to were this quest is and go round the back of the house to the back door, throw the jar at the back door and it gets covered in oil. then throw a torch at it and it breaks the red lock on the inside allowing you to get the item.

  • BlackIce_xD
    13 posts
    Use valkryie ability level 2 on back door it worked for me !

    Thanks for that. It was the last thing for Platin trophy👍

  • Acedyn22
    195 posts

    @knives-6 Unfortunately in my circumstances, I completed the Lunden's main questline and still have an icon, without a key. The girl is also stuck in an infinite loop with Maximilian -.-

  • GZacchigna89
    1 posts

    i went to the back door and used the ability (dive of the Valkyries) and broke the bar holding the door locked and yes from the outside on the first try and got the statue ran past the girl and loop was over

  • rivainii
    1 posts

    Had the same bug. You can shoot the barred door behind the house with an explosive trap ability arrow, and then shoot that arrow again with the same ability. It will explode and open the barred door. I tried it multiple times on different barred doors and it always works for me. Just make sure you shoot the arrow right where the bar on the door is.

  • Bob_Marely01
    1 posts

    Hi, is anyone still having issues with the key for Maximillians house still not spawning? I have updated my game to patch 1.04 and it still isn't there. And sadly going back and just undoing what I've done is sort of not an option as I have gone and collected everything else, there is only this quest left before I get 100%.

    Any help would be lovely, and hopefully devs if you see this, you can try and figure this out.

  • Whit_Photomode
    2 posts

    Also currently having this issue, I completely closed down the game and reloaded it with no avail. Now trying the fast travel technique as I couldn't shoot through the window even though I could see it, and it was perfectly aligned. Hopefully this one works.

  • ubisysmai
    1 posts

    Thanks @Akarencho
    Valkyrie Dive 2 worked for me.

  • jandraelune
    126 posts

    @whit_photomode The shooting through the window is blocked by the stature inside.

  • Xhopemariex
    6 posts

    Been stuck in this forever since the key is glitched and unattainable

  • OD4CR3K
    1 posts

    Hi everyone! I hope all of you are doing well during this pandemic and you are all safe!

    I'm here due to an issue trying to complete "A rivarly for the ages". Once Maximilian is distracted by the child, you should be able to grab the key from the stool outside and walk your way inside to steal the statue.

    However, in my case, the key does not spawn. I've tried uninstalling and installing the game again and it did not work. I'm left unable to complete the mission due to this bug.

    Any suggestions?

  • tpf1230
    2 posts

    The key shows up with Odin's sight but is not present to collect. There is no way to open the back door that is barred.

  • Shadow_Belthil
    1 posts

    Salve, ho un problema con la Quest "Una Rivalità Storica". Sono arrivato al punto in cui devo recuperare la Statua del Legionario dalla casa di Maximilian rubandogli la chiave ma la chiave non è presente dove viene indicata e non posso interagire con Maximilian o con la bambina che lo sta distraendo. Come posso risolvere oppure riuscirete a risolvere per favore? Ho già esplorato Lunden e non c'è altro che posso fare per risolvere questo bug.

Suggested Topics