Welcome to discussions

Quick Suggestions

  • Bob_Marely01
    1 posts

    Hi, is anyone still having issues with the key for Maximillians house still not spawning? I have updated my game to patch 1.04 and it still isn't there. And sadly going back and just undoing what I've done is sort of not an option as I have gone and collected everything else, there is only this quest left before I get 100%.

    Any help would be lovely, and hopefully devs if you see this, you can try and figure this out.

  • Ubi-Borealis
    Ubisoft Support Staff 3572 posts
    Best Answer

    Hello all!

    I've merged together several threads wherein players were unable to collect Maximilian's key in "A Rivalry for the Ages" into a single megathread. I apologise if any ongoing conversations were disrupted by this merge.

    As shared by @jandraelune, this issue was marked as resolved following TU 1.1.1. As we have had no new reports since then, I will now be locking this thread. If you encounter any further issues with "Rivalry of the Ages," please don't hesitate to open up a new thread so we can investigate further.

    Thanks all!

    Official Response
  • Whit_Photomode
    2 posts

    Also currently having this issue, I completely closed down the game and reloaded it with no avail. Now trying the fast travel technique as I couldn't shoot through the window even though I could see it, and it was perfectly aligned. Hopefully this one works.

  • ubisysmai
    1 posts

    Thanks @Akarencho
    Valkyrie Dive 2 worked for me.

  • jandraelune
    119 posts

    @whit_photomode The shooting through the window is blocked by the stature inside.

  • Xhopemariex
    6 posts

    Been stuck in this forever since the key is glitched and unattainable

  • OD4CR3K
    1 posts

    Hi everyone! I hope all of you are doing well during this pandemic and you are all safe!

    I'm here due to an issue trying to complete "A rivarly for the ages". Once Maximilian is distracted by the child, you should be able to grab the key from the stool outside and walk your way inside to steal the statue.

    However, in my case, the key does not spawn. I've tried uninstalling and installing the game again and it did not work. I'm left unable to complete the mission due to this bug.

    Any suggestions?

  • tpf1230
    2 posts

    The key shows up with Odin's sight but is not present to collect. There is no way to open the back door that is barred.

  • Shadow_Belthil
    1 posts

    Salve, ho un problema con la Quest "Una Rivalità Storica". Sono arrivato al punto in cui devo recuperare la Statua del Legionario dalla casa di Maximilian rubandogli la chiave ma la chiave non è presente dove viene indicata e non posso interagire con Maximilian o con la bambina che lo sta distraendo. Come posso risolvere oppure riuscirete a risolvere per favore? Ho già esplorato Lunden e non c'è altro che posso fare per risolvere questo bug.

  • Dashiva83
    1 posts

    Same here, the key is visible with eagle vision but no key on the stool. I threw an exploding pot on the shop keeper so hes all dead btw. Still the key should have been on the stool anyway.

  • Yangpaine
    11 posts

    You would think if when the devs look at a glitch and try to fix it with a patch, they would actually fix the problem. Unfortunately, it didn't work. There is now a key that shows up with Odin's vision in front of the house in Lunden, but there still isn't a physical key for me to pick up, so I still cannot get the quest done.

  • guest-YxSOyxKJ
    2 posts

    @iicemoke i tried that, didnt do nothing

  • guest-YxSOyxKJ
    2 posts

    @poorkenny travel to Norway and back didn't work for me... dammit

  • Irondane
    1 posts

    I had the same problem so i blew the door with an oil lamp.

  • JessJack0
    1 posts

    I’m on the mission ‘A Rivalry for the ages’ and I can’t gain access to the house because the key isn’t on the stool outside the house but the key symbol is showing. I paid the children on the street to distract Maximilian so I could get the key and enter the house and now I can’t complete the mission because I can’t get in the house. Please can anyone help me as I cant complete the game until this mission is done

  • Theshmee1
    3 posts

    The devs said this was an issue alot of people were having even me, they said there working on fix for this. I just ended up paying for it

  • Gayngel2019
    16 posts

    If you do not have the upgraded Dive of the Valyries you can go to the nearby world event and pick up an oil jar (or anywhere with oil), throw it at the back door so it is covered in oil and throw your torch at it. That will break the inside bar. I just did this today so do it quick before it gets patched.

  • guest-GiPflsqM
    1 posts

    @serbassassin29 this worked for me as well. Thank you so much!

  • TrippinOnMayo
    2 posts

    Same bug for me, will get level 2 dive of valkyries to work around it

  • BomberDuckie
    6 posts

    @jessjack0
    you need to build the museum in your settlement when you done that you don’t need the key to enter the house

  • WastelandStag
    19 posts

    The explosive vase worked a treat for me.

    My favourite part of all these bugs is that no one can even be bothered to acknowledge this.

    What play test size do they have that stuff like this gets missed?

    The mystery where I got the explosive vase from, the guy isn't even there? So I can't complete that one either.

Suggested Topics

Community Details

73
Online
191.8k
Users
32.2k
Topics
161.6k
Posts