Welcome to discussions

Quick Suggestions

  • Irondane
    1 posts

    I had the same problem so i blew the door with an oil lamp.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I've merged together several threads wherein players were unable to collect Maximilian's key in "A Rivalry for the Ages" into a single megathread. I apologise if any ongoing conversations were disrupted by this merge.

    As shared by @jandraelune, this issue was marked as resolved following TU 1.1.1. As we have had no new reports since then, I will now be locking this thread. If you encounter any further issues with "Rivalry of the Ages," please don't hesitate to open up a new thread so we can investigate further.

    Thanks all!

    Official Response
  • JessJack0
    1 posts

    I’m on the mission ‘A Rivalry for the ages’ and I can’t gain access to the house because the key isn’t on the stool outside the house but the key symbol is showing. I paid the children on the street to distract Maximilian so I could get the key and enter the house and now I can’t complete the mission because I can’t get in the house. Please can anyone help me as I cant complete the game until this mission is done

  • Theshmee1
    3 posts

    The devs said this was an issue alot of people were having even me, they said there working on fix for this. I just ended up paying for it

  • Gayngel2019
    16 posts

    If you do not have the upgraded Dive of the Valyries you can go to the nearby world event and pick up an oil jar (or anywhere with oil), throw it at the back door so it is covered in oil and throw your torch at it. That will break the inside bar. I just did this today so do it quick before it gets patched.

  • guest-GiPflsqM
    1 posts

    @serbassassin29 this worked for me as well. Thank you so much!

  • TrippinOnMayo
    2 posts

    Same bug for me, will get level 2 dive of valkyries to work around it

  • BomberDuckie
    6 posts

    @jessjack0
    you need to build the museum in your settlement when you done that you don’t need the key to enter the house

  • WastelandStag
    19 posts

    The explosive vase worked a treat for me.

    My favourite part of all these bugs is that no one can even be bothered to acknowledge this.

    What play test size do they have that stuff like this gets missed?

    The mystery where I got the explosive vase from, the guy isn't even there? So I can't complete that one either.

  • guest-K0SYaBmJ
    1 posts

    Hello, I am unable to progress with A Rivalry for the Ages. I can see the key with Odins sight but cannot pick it up. Max is nowhere to be found. The kids are standing on the corner. There is no means to move forward.

  • drewvicious777
    4 posts

    Still cannot complete or restart quest. The key icon shows up with Odin sight but no key is on the stool. The shop owner is still stuck in an endless loop with the girl distracting him. Tried everything.

  • Grand_310
    32 posts

    there is 3 ways to finish this quest:

    1. get your charisma to lv5 so you can "persuade" him.
    2. pay him.
    3. if you already pay the girl to distract him and stuck with the bug, use lv2 Dive of the Valkyries ability to the barred back door so it will break open and you can access the statue.


  • Keff92
    1 posts

    So I go to Maximilians house and low and behold no key on stool. Also stuck on Ragnar quest so can't proceed with story. Thought maybe I'll do the side quests until they patch it. Nope turns out the side quests have just as many issues as the main quests. Bout done with Ubisoft games tbh. I understand bugs but when it gets to the point of not even being able to finish a quests and there's no work around other than wait for a patch...gets annoying real fast. Will probably shelf this game for the next 6 months to a year like I've done the rest, until its all fixed then ill jump back in and play.

  • DjFunkyMeat
    1 posts

    @poorkenny
    They can with update 2.00 stop you farming in London but can't sort the key problem A rivalry for the ages

  • rutger1504
    1 posts

    Hi there,

    The key in the quest called "A Rivalry for the Ages" is glitched (can't be picked up)
    You need to obtain the legionaire statue.
    If you hire the kids at the corner, they distract "Maximilian" but the girl keeps saying the same sentences over and over again. Could you please fix this?

    Thank you!

  • Akintude
    5 posts

    Same here. Problem persists even after patch 1.10 (PC). Girl distracts Maximilian but still no keys on the stool to grab.

  • Akintude
    5 posts

    I can confirm tha the problem persists even after patch 1.10 (PC). Maximilian is distracted by the girl but still no keys on the stool to grab.

  • MrBohannon3209
    1 posts

    This was in the new patch notes saying that it was fixed and it still has not been fixed...the dialogue between Maximilian and the child is still looping and there still is no key to open the door please fix this the right way!!

  • Defalt._
    1 posts

    @akintude same here.

  • UrsusMagnum
    3 posts

    I am unsure if this has already been reported but for me after returning to Lunden with the new patch installed Maximillian is still being distracted around the corner by the child, however, Odin sight shows a key marker but the key spawns on the stool thus no pick up option displays., and I still can not shot the barred door with any of the three bow types.

  • UbiKoality
    Community Manager 440 posts

    @rutger1504 Hello! First, I apologize for the inconvenience and frustration that these problems have caused you. Second, what platform are you playing Valhalla on? As stated here in the 1.1.0 patch notes, an issue with the Rivalry for the Ages quest should have been addressed.

    Official Response

Suggested Topics

Community Details

96
Online
192.9k
Users
32.5k
Topics
162.8k
Posts