Welcome to discussions

Quick Suggestions

  • Jasette
    27 posts

    @roeken87 idk about Maximilian turning into a kid, that’s weird, but I also don’t have a key on that stool, no matter how hard I stare at the stool and move around it. (Also tried leaving and coming back etc) Kid just keeps going on and on about the guy with the curly hair and a big nose and the lady with the wreath on her head. I tried running into them to get her to stop but they didn’t even seem bothered 😂

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I've merged together several threads wherein players were unable to collect Maximilian's key in "A Rivalry for the Ages" into a single megathread. I apologise if any ongoing conversations were disrupted by this merge.

    As shared by @jandraelune, this issue was marked as resolved following TU 1.1.1. As we have had no new reports since then, I will now be locking this thread. If you encounter any further issues with "Rivalry of the Ages," please don't hesitate to open up a new thread so we can investigate further.

    Thanks all!

    Official Response
  • Roeken87
    4 posts

    Okey, so i guess i solved the missing key part, and a fix for the Maximilan being a kid, Key spawned when i finished the main quest for Lunden, and Maximilan also got turned back into normal when it was completed, the kid though was a "grown up this time" but still worked to use the kid

  • Jasette
    27 posts

    @roeken87 ack I can’t progress on “brewing rebellion” (no one will help me break into the longhouse) so I guess I’m super stuck 😭 glad you were able to get through though!

  • ugobananas
    13 posts

    @eternaljosh yes, it's part of one of the main quest arcs

  • Shadow-Wipeout
    19 posts

    I've got to the part where the little girl is distracting Maximus however the key thats suppose to be on the table next to him at the doorway had never spawned so now its stuck in an endless loop, ive uninstalled and re-installed the game and dont want to have to start a new game to finish the quest

  • TSwarthout
    1 posts

    The rivalry of the ages quest won’t let me continue after I distract Maximilian. I’ve tried loading an old save, I’ve tried meditating, and I’ve done 4 quests since then but nothing is making the key spawn to get the statue inside his house.

  • jxckskye
    1 posts

    I'm also having a bug with this quest but slightly different. I have already completed the main Lunden arc, but on arriving to speak to Maximillian, he is dead.

    I can't then complete the quest as it tells me he needs to be distracted.

    undefined

  • Diegoez16
    12 posts

    @fatalitywolf same issue no fix along with another bug of the island of eels quest never appeared this game is beyond broken how did they release it like this?

  • PieterDeMeyer
    1 posts

    When retriving the statue for Osbert in Lunden you have the option to bribe a girl for distracting maximus so you can steal his key and statue. When you interact with the little girl and she starts talking to him the key is nowhere to be found and they are stuck in a dialogue loop.

  • cybren2
    4 posts

    Same Problem here.

  • M1ST3R-S1R3
    1 posts

    I have been searching for days and the key doesn't appear on the stool. I have reloaded my save and still does not show.

  • ADPH09
    1 posts

    There’s no key after I paid the kid to distract Maximilian. I can’t finish the quest.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    Hi all,

    Thank you for reporting this to us.

    We are aware of issues with being able to progress this Quest, and it's currently being looked into by the development team.

    Official Response
  • Uniquities
    11 posts

    @ubi-baron thank you! I actually found a new bug today and I just made a post about it.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @ADPH09 Thank you for reporting this to us, we're sorry to hear that's been the case.

    Do the same lines get repeated over and over again?

    We are aware of some issues with this Quest, and it's currently being looked into.

    Do you have an older Save you could try reloading, to see if the same thing occurs? Do you see the key there before he is distracted?

    Official Response
  • Poorkenny
    43 posts

    Talked to Maximilian
    Went away. Talked to the kid, asked him to distract Maximilian
    Spent an hour trying to figure out what I was supposed to do.
    spoiler
    The quest is stuck. Biggest bug so far for me.


  • iralos13
    1 posts

    @poorkenny I'm in the same boat as you. Now Maximilian and the girl are stuck talking to each other and I don't have a save to go back to.

  • SamBH22
    4 posts

    I went to do this quest and I talk to Maximus about the statue Octavian wants and of the 3 options I hit leave and go talk to the girl that distracts him but there is no key on the stool where there should be. At first I thought I couldn’t find it but then I looked up the quest and it’s supposed to be on the stool beside Maximus but it’s not there!

  • THE_HAUNZ
    2 posts

    I am also receiving this same issue.

  • babateru
    1 posts

    @andygordon68 Okay...

Suggested Topics

Community Details

94
Online
192.5k
Users
32.4k
Topics
162.3k
Posts