ubisoft discussions

Quick Suggestions

  • 0 Likes/205 Replies/34778 Views
    43 posts

    @serbassassin29 Thanks, I'll try that!

  • EROCK0295
    1 posts

    I’m having the same issue, still no fix 10 days after bug report

  • Poorkenny
    43 posts

    Update: As I came back to try @serbassassin29's suggestion, Maximilian had returned to his original spot. I have no idea what triggered that. This happened maybe 20-30 game hours after the issue originally occurred, and I had checked on Maximilian a couple of times before.
    It could be that travelling from one continent to another causes the NPCs to be "reloaded".
    For those still stuck and who can't/don't want to use the Dive of the Valkyries trick, try travelling to Norway and back, for example.
    No guarantee, just a hunch.

  • Madyew
    1 posts

    I hit this bug as well

  • Ubi-Raziel
    197 posts

    Hello everyone!

    I can see there were a lot of threads created about this issue so I have merged you all together.

    Our dev team are currently looking into it! Please keep an eye out for this issue in our future patch notes.

    All the best!

  • jakesylvester
    1 posts

    So I had the same bug where the key didn't spawn. I went to the nearby bandits and grabbed a red pot and threw it onto maximus and the kid. Maximus died and now when I reload the game his dead body spawns with the key but I get a message saying I can't take the key until he is distracted.

  • thesarge134
    8 posts

    @ipaidfortrash Same here. I just came across the mission last night. I also tried to load a saved game before that mission but all that was available was a save from 2 hours ago. This is 2 missions I am unable to complete. Viking for Hire is the second. I don't mind small glitches in the game but not being able to complete missions is frustrating.

  • Flopx89
    1 posts

    im unable to finish the A Rivalry for the ages mission. the key to the door isnt showing up at all

  • guest-X9ipsd2F
    1 posts

    When I tried to pay Maximus for the key or distract him with the kid nothing happened. No key to open the door to be found.

  • LordLenry
    2 posts

    This guy helped me loads. You can break your way in from the outside.

  • Emac0455
    7 posts

    The key to open Maximilian's house doesn't appear when I pay the girls to distract him.

  • AndyGordon68
    4 posts

    @lordlenry I couldn't equip a longsword and axe at the same time as I don't have that skill yet but I was able, after many attempts, to break the bar on the door using a two-handed axe on its own. Thanks for posting the video, I'm glad that I can now move on with this quest.

  • fLasHiiiiii
    1 posts

    Thank you, that worked for me.

  • LordLenry
    2 posts

    @andygordon68 You're welcome glad you were able to move on! 🙂

  • Theshmee1
    3 posts

    I watched a video on this and in the comments different people had there own way of solving this problem though the key did not spawn for them either one person said if you grab a fire Barrel and throw it at the barred door it would break it and you can open it that did not work for me another person said if you use the fire trap then it would blow up the thing to make it where you can open it and it didn't work another person said if you use the piercing arrows you can shoot through the door that did not work for me either someone said that you could blow it up basically that didn't work either but I to come across this bug but luckily I had to save where I had to fight ivarr and I just loaded from there

  • McStog222
    3 posts

    Same problem here, like so many hundreds of ofter people complaining across myriad forums. PS4, in my case.

    Hunting down super rare and obscure bugs is one thing, but I always thought that basic QC and quest testing to make sure the most fundamental requirements of the quest actually function, was something all game studios did before release.

    I guess I shouldn't assume.

  • jolliee
    3 posts

    Same problem ps4
    No key around the building
    Litle kid and max are talking .

  • sgoudie71
    6 posts

    The quest called Rivaly for the ages is glitch i miss the key to pick up also some other bugs so how this game got gold status i have no idea also i miss the dealy or week rewards from rena in my camp thats another bug i rather wait 2 more month before the game release at least it is less buggy so plz fix it i spent a lot of money for the collector edition and get [censored] for my money

  • IIcemoke
    1 posts

    You can break back door with two two handed weapons/

  • SmudgyStatistic
    5 posts

    @jxckskye pay the children on the corner to distract him

Suggested Topics