Welcome to discussions

Quick Suggestions

  • 0 Likes/205 Replies/31574 Views
    Poorkenny
    43 posts

    @iralos13 Not to mention how annoying it is to hear the same 3 lines of dialog in a loop every time you're around that place 😂

  • IPaidForTrash
    1 posts

    I've had numerous bugs and crashes throughout my play through but none this game breaking. I talked to this girl to distract the guy so I can steal the statue and the key thats supposed to be on his stool is no where to be found. And just so conveniently my game hasn't autosaved in 2 hours so if I want to reload, everything I've done today is gone. Done playing the game for now.

  • SlightlyErotix
    2 posts

    This has happened to me on Xbox as well. Paid the kid, key isn’t where it is Supose to be. Please fix Ubisoft!

  • Dead-Decoy
    1 posts

    I started the quest a rivalry through the ages. I got to Lunden and found Maximilian and used the child to distract him. I hadn’t stolen the key to his house and once the child distracted him the key wasn’t there. The interaction between him and the child just keeps looping. I can’t do anything. I wish I could abandon the quest then restart it. I don’t have a save game from before the interaction was started so I’d have to start the whole game again. I hope this still allows me to complete the game and this bug is fixed in an update allowing me to complete the quest.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @dead-decoy Hello there! I'm so sorry to hear you've encountered this issue with the mission 'A Rivalry for the Ages'. I'd like to have you open a case with our technical support team, in order to have things looked into a bit further.

    Official Response
  • Poorkenny
    43 posts

    @slightlyerotix At least we know it's not a PS4-specific bug 😅 Can you upvote my thread to give it more visibility? Unless you know another one that's more popular

  • drewvicious777
    4 posts

    During the quest to retrieve the statue I chose to use the little girl to distract Maximus however the key that’s supposed to be on the stool is not there. I tried closing the game and restarting but it appears stuck that way. The game is stuck in the loop of the little girls dialogue with Max and will not reset to let me choose another method.

  • o8sideus
    10 posts

    I attempted to steal the item, and had the child distract Maximilian - however, there was no key to unlock the door. Left the area and returned to use charisma and get the statue, but he's just gone. I have returned several times over a few hours, and he has not yet re-appeared.

  • o8sideus
    10 posts

    I should also note that I spent a lot of time trying to get creative - including dropping from the roof and trying to shoot through the door hole (after about 30 minutes of this I realized the arrow wasn't actually going through the hole on the door, no matter from which direction). And blowing the back door hoping that maybe it'll bug and break the brace preventing it from opening. 😑

  • Willowisp830
    1 posts

    I have a similar problem. I paid the kid and the key was nowhere to be found. I left to raise charisma, hoping I could talk the key out of the guy. Finished that, came back. Now, I cant speak to either character. The kid keeps repeating the 3 same sentences like stuck on a loop. There is no room for interaction whatsoever.

  • MRK_Pirate
    1 posts

    I chose to use girl to distract owner. No key on the seat near the door. Quest does not reset if you go away and come back

  • Comeongeeze
    9 posts

    In a rivalry for the ages there is no key on the stool when I have the little girl distract him, and the quest never resets so I can try a different approach.

    A seers solice still works t work even after the Hot fix, he just stands in the boat next to the shore and does nothing.

  • o8sideus
    10 posts

    @willowisp830 Yeah, after paying kid the key wasn't there. And I, too, had to raise charisma 😛

    Should also note that when the kid distracted Maximilian, they both got on my horse.... and stayed there... until I killed a guard and then Maximilian ran away into the stables and subsequently poofed into thin air.

  • sloesoe12
    1 posts

    After distracting maximus with the child the key isn’t spawning at the chair

  • SamBH22
    4 posts

    Same issue with me I posted the same thing on the 18 and no replies from Ubisoft or anything. Ubisoft needs to get their game in order!

  • hani74
    1 posts

    Same problem in PC

  • jdwhite76
    1 posts

    There's one with a chin like a brick! So annoying

  • robertp42
    1 posts

    I have this same issue, the key is not there beforehand either. Loading an old save doesn't help.

  • bleachor
    2 posts

    I would like to mention that there is a severe bug with "A rivalry for the ages" quest, where when you choose option 3, talking to the little girl and make her distract Maximilian, the key isn't anywhere to be found. It is mentioned it is supposed to be on the stool where he is standing, but no key in game. I can take video as well as picture. Prompt me a place to upload if needed.

    Nevertheless, seems like this isn't console spesific from the tiny Google research I did on the matter, so please attend to it!

  • serbassassin29
    1 posts

    Use valkryie ability level 2 on back door it worked for me !

Suggested Topics

Community Details

215
Online
195.3k
Users
33.0k
Topics
165.0k
Posts