Welcome to discussions

Quick Suggestions

  • Ashgard34
    1 posts

    I cant get Mentors armor chest piece due to buged shelf...

  • jhookbone
    2 posts

    The obstacle appears to be floating in the air, and can't be moved to access the armor chest.
    undefined

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @jhookbone Hello there! I'm sorry to hear about this issue. I'd like to know if this persists if you perhaps fast travel away and return after completing other objectives? If so, we'd appreciate a video of the issue occurring to forward for review. Additionally, you can also help investigate this by creating a support case with our dedicated support team, and attaching your game's save files for review. Please be sure to come back here and let me know your new case number!

    Official Response
  • WolfBlade_321
    2 posts

    I v encountered an immovable shelf in Saint Lewinna's Church in Guildford, in Suthsexe. There is nothing blocking it ( I already destroyed the few boxes that were ) but still, the shelf doesn't move. It's blocking the only access to an armor piece. Evidence attached below. Please fix this. Thank you 🙂
    undefined

  • Salakor
    24 posts

    bug still exists. having the same problem today no idea how to fix it.
    I've tried,

    • reloading/reverting to prior saves
    • fast travel away and coming back
    • saving and quitting to reload game resources.


  • Salakor
    24 posts

    @ganthegoon same issue as well.
    I've tried:

    • reloading/reverting to prior saves
    • fast travel away and coming back
    • saving and quitting to reload game resources. (someone said this fixed it for them on another thread though this did nothing for me)


  • Salakor
    24 posts

    @cailanjackson

    I've tried the following -

    • reloading/reverting to prior saves
    • fast travel away and coming back
    • saving and quitting (reload game from desktop) to reload game resources. (someone said this fixed it for them after numerous attempts, I did this and notice the thing move a bit but not enough to move it.)


  • millerbrewed
    1 posts

    Hello.

    I play AC: Valhalla on the PC. There appears to be a bug in the town of Guildford, inside of Saint Lewinna's Church. Getting in is simple enough. I am staring at a simple, moveable shelf that blocks the door leading into the side room containing a chest with the Mentor's Robes in it (I only know this because I googled what it was after realized I cannot obtain it).

    The problem is that the moveable shelf... doesn't move. After a few dozen google/youtube/ubisoft forum searches, I haven't encountered anybody else who has come forward with this problem. I have tried everything. When watching videos of other players moving the shelf, it moves just fine. When I do it, Eivor heaves and ho's, but it just doesn't budge. Nothing is blocking it. I have tried *everything.* Yes, I even uninstalled and reinstalled the game, all in the hopes of obtaining this one piece of armor (to be fair, this is -- would be my favorite set in the game).

    Do note that, in many of the videos I've watched, people are able to squeeze in to the tiny area on the right side of the shelf and grab it and pull it from the side. I am not able to fit into that space, no matter what I try. There is a white dot/icon, acting as though I could approach it and grab it, but it will not let me. I can only grab it from the front, and the shelving will not move in any direction whatsoever.

    Attaching a photo for precise reference.


    I just wanted to make you (and other players who might be experiencing the same issue) aware of the bug. I hope it gets fixed soon, the robes do look lovely.

    Thank you for your time!

    undefined

  • GremlinOW
    1 posts

    I've been trying to collect everything before I finish the game, and the last thing I need to collect is the Mentor's Robes, located in Saint Lewinna's church in Guildford. However, when I go in to move the shelf out of the way to enter the area they're in, I can't move it because of the bug where the shelf floats making it immovable. I would really like to grab it before I finish the game.

  • Morfofo
    6 posts

    @gremlinow yep i have the same issue still no fix tho as i can see

  • Bleriuiop
    1 posts

    As if this hasnt been fixed yet.
    Honestly.

    Ive done all the above glitches to 'fix' this but none have worked.
    As if you have to fix a glitch with a glitch anyway.

    How about you get rid of the door so it cant clip through anything Ubi.
    Its taken almost a month for you guys to fix a door. And its still not fixed

    I get there are way to man bugs to count/fix given its new but how about instead of focusing on nerfing farms which people are going to get regardless.

    You could fix the [censored] that actually prevents you from playing the game.

    I just dont get it.

  • AntivanAssassin
    2 posts


    What it says on the tin; I can't move the large shelf/crate thing to access the armor piece in Guildford, Suthsexe. Cleared all the stuff around the shelf but it won't move from the doorframe, and reloading earlier saves didn't fix it. (Not urgent or game breaking by any means, but I really want that armor lol)

  • Centor2018
    4 posts

    Hello, i have the same problem

  • Ryniu3001
    2 posts

    It's worked for me. It's just fine to limit your FPS. I recorded the video to help visualise the method.

  • Ryniu3001
    2 posts

    Workaround:

  • fuder134
    3 posts

    Credit to Ryniu3001.

    A workaround post by Ryniu3001 (https://discussions.ubisoft.com/topic/85630/mentor-s-robes-not-obtainable-pc/1) worked for me on PS5
    Here is how I workaround it on PS5

    1. Went to Settings --> Screen And Video --> Resolution --> Select "720p"
    2. Went to Settings --> Saved Data and Game/App Settings --> Game Presets --> Performance Mode or Resolution Mode --> Select "Performance Mode"
    3. Went back to the game, I was able to move the shelf and got Mentor's Robe.


    Thank you.

  • KiII28
    1 posts

    I have the same issue, even after the update. Any known workaround? Thanks

  • Attekush
    2 posts

    @ryniu3001 thank you very much finally got in to the room 🙂

  • Outlander1982
    123 posts


    Still not fixed😕

  • MychaelForsyth
    3 posts

    There are 2 wealth chests I am completely unable to access in Suthsexe. 

    The first is the gear chest in Saint Lewinna's Church in Guildford.

    The second is the wealth chest (unknown type) in Portcestre, the lower left corner of the keep.

    In both cases, there is a sliding shelving unit which I am completely unable to move in any way, and upon zooming in I can see it is partly within the wall. I have checked online and this seems to be an issue for a large number of players.

Suggested Topics

Community Details

81
Online
196.2k
Users
33.2k
Topics
166.0k
Posts