Welcome to discussions

Quick Suggestions

  • Blauman619
    6 posts

    @hidden1ne If that ends being the case that will be a new low even for Ubisoft if they dont fix that!

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein the Yule gear would be lost from a player's inventory is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    This update will prevent players from losing these items in the future. If you have already lost these items, you will need to reclaim them again via the Godly Reward Pack for them to be added back to your inventory.

    If anyone is encountering additional issues with the Godly Pack and Yule gear following TU 1.2.1, please don't hesitate to reach out!

    Thanks! 😊

    Official Response
  • Scythesabre
    4 posts

    I'm not sure if this applied from just the update or as a result of claiming the godly pack. I've lost my many thousands of silver that I was saving up and am now stuck with a measly 64.
    Issue also applies when loading an older save, silver is set to 64.

  • Scythesabre
    4 posts

    @scythesabre I should add that I loaded a save first to check if my Modraniht items were downgraded in quality and noticed I had a lot of extra crafting materials and all items from that set were gone from my inventory.
    I have helix credits and was able to redeem the godly reward but when I went to check on what else changed in the game I noticed my silver was gone.

  • HIDDEN1NE
    89 posts

    @blauman619, I hear ya, but I believe they’ll soon fix it, the twitter account already said they were investigating as much, and so hopefully they were just looking for the factor causing this. I doubt they intended for a free pack to cost credits, so maybe they can see that it’s the credits that are the problem.

  • JCar4327
    617 posts

    So, I will verify that having helix credits will fix the issue. I decided to go ahead and allow the purchase of an outfit. Once the credits were on the account for the profile getting the error I checked to see if the Godly pack could be redeemed. It was almost automatic.

  • HIDDEN1NE
    89 posts

    @jcar4327, Hey thanks for doing that 🤙 so it just seems like a small oversight that they didn’t realize credits would have. With this being the case they could even fix this by tomorrow or the next day, so here’s hoping!

  • oltawi
    1 posts

    After updating today, when my recent save loaded I received an assorted amount of materials and ingots. When I looked at my inventory I noticed the weapon in my main hand was no longer equipped. All of my gear from the Yule Festival(and potentially other things) is gone. I tried loading various earlier saves, and while in the loading screen I can see the Modraniht Ceremonial Seax in my main hand. However as soon as the game loads it vanishes from my belt.

  • GlassyCelery532
    14 posts

    Exactly the same here.

    Also, my Jomsviking leuitenant resets its appearence everytime I do a River Raid and my River Raid longboat shields are bugged, showing the ones I picked in the main longboat.

  • JCar4327
    617 posts

    @hidden1ne No biggy. I don't usually spend money in the store, the only exception being for map packs. However, someone wanted a very ugly outfit with fire all over it; I'll never understand why because it doesn't really fit with the game, but he wanted it. Plus I don't have to listen to crying about both the purchased outfit and the missing free outfit. Think I made out better on that deal.

  • SnapeSlytherin
    6 posts

    @dlmthree Same issue, same error code. PC / keyboard / mouse. I also have 0 Helix credits (spent already on the maps). Participated in the Yule event, bought some but not all of the items in the Godly Reward.

  • RaithHunter2000
    1 posts

    I hope they fix this bug soon really want Altair Armor been playing every Assassin's Creed since beginning hate that it's bugged.

  • timmyd111
    10 posts

    After downloading new update and find that the godly rewards are not working giving a online service error message saying you already have maximum amount possible for this item (0x70000d03) ::::::but nothing is in my inventory what's the deal....... I'm on gold pack so I don't understand why it won't work.

  • cavveman
    77 posts

    I get the same error on PC @Ubi-Borealis

  • First_Prophet
    29 posts

    I haven't even read the whole forum post yet, but I lost my free Helix credits, and after receiving the error that when trying to redeem this reward, all of my fully upgraded Modraniht armor, Shield and dead are gone from my inventory. Poof, all that stuff that I upgraded, completely gone. Also, the decorations that I bought before are gone. When you fix this, am I going to get those back fully upgraded, because I don't know if you know this or not you be soft, but the grind of this game is not fun and I put the time in to upgrade that stuff and I would like to get it back upgraded. Plus, I would definitely love to get that Altair outfit that we have been waiting for. Funny that Ezio's wasn't put in here. here's the pack for all of you people who stuck by us, by the way it's going to mess up your inventory and it's all stuff that we gave away already up to this point, thanks for your support! Sorry, super jaded at this point. I know there are going to be the people out there saying that we don't have anything to complain about, but whatever. Voicing my opinion. I have screenshots if you need them, but I'm sure you have enough examples. How long is this Godly reward pack going to be up, so I can get my stuff back?

  • RivereyesGR
    11 posts

    Same thing happened here on PC. I also had a full Yule armor set.

  • Hefeydd_
    23 posts

    Hello,

    Only do this if you cannot see the Godly reward, uninstall and reinstall AC Valhalla this will force through the Godly Reward. I restarted the game and my console and each time all I could see was Become a better Viking! GamePlan has got you covered.

    Godly Reward is not showing up not matter how many times that you restart AC Valhalla or your console. However, I have found a workaround to force the Godly Reward to show up but it does require uninstalling the game and then reinstalling the game again, which I know sounds a bit drastic but it does work... this isn't the first time that I have experienced problems with free content and this looks to be an issue server side or client side with regards to your account.

    By uninstalling the game which I know is an absolute pain in the backside, but you will not lose anything so do not worry... on either platform PlayStation or XBX uninstall the game and then reinstall it again, unfortunately this does mean you will have to download the update which depending on the platform the size of the update is about 72.72GB for the XBX depending on your connection speed how long it will take to download the update again.

    When I loaded the game after reinstalling the Godly Reward was present for me.

  • undeadaaa
    1 posts

    I have the same problem. When I tried to get the reward, the knife, which was already equipped as a secondary weapon, disappeared. So in short, instead of getting something, I lost something, the beautiful reward he offered you.

  • kingoshus
    17 posts

    When I try to redeem it it comes with the message "online service error you already have the maximum amount possible for this item [0x700000d03]
    I only have 120 opal so I can't have the maximum amount of that
    The altair outfit hasn't been available so I can't have that
    And I didn't even log into the game for the whole period of the yule festival so I have none of those items




  • kingoshus
    17 posts

    @jcar4327 I played the game at launch, then didn't play at all during the yule event, then picked the game up again a few weeks after the event ended, still got the bug

  • tri5tram
    1 posts

    Same error on PC!
    Played for a number of hours with multiple fast travels and saves before noticing the claim free gear. Could not claim, got error code, lost stuff!!!!
    Thanks.........

    Buggiest Assassins game I have ever played!!!
    Thanks..........

Suggested Topics

Community Details

90
Online
141.8k
Users
25.0k
Topics
129.8k
Posts