Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @alespla2 Hello, and welcome to the forums! I completely understand how frustrating this audio error is, but please rest assured this should be addressed in a future patch. Details will be posted here as soon as we have any specific dates to provide.

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 1451 posts
    Best Answer

    Hello there!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue with missing sounds when riding your mount should be fixed in TU 1.2.1. This update was deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with missing sounds when using your mount following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue still occuring in-game.


    Thanks! 😊

    Official Response
  • ItsRyanBennett
    3 posts

    I cannot believe this still hasn’t been fixed after 3 weeks and a patch. I bought a PS5 for the sole reason of playing Valhalla and I’m finding myself not wanting to play until this is fixed.

    It’s not like you can just avoid your horse due to the size of the world, so you’re constantly reminded of this bug every 10 minutes. Please fix ASAP!



  • hheywood
    46 posts

    @itsryanbennett


    Worse, it was working fine. This is a big that was introduced just recently but for some reason seems incredibly difficult to fix.

  • Ubi-Mark.
    Ubisoft Support Staff 500 posts

    Hello @ItsRyanBennett

    Sorry to hear that you are also affected by this issue.

    As @UbiExcellent mentioned, this issue will be resolved in a future patch 🙂 Once the fix is pushed live, we are going to let everyone know through the patch notes.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • Jadedsneak
    2 posts

    Literally kills the immersion. It's taking way too long to fix something so little.

  • Leonru8012
    1 posts

    PS5: when you ride your horse no sound is produced aside from when you leap over a fence or ruffle leaves/grass through bushes. Reported to the support team

  • Magraciaz
    2 posts

    Just bought my PS5 and started Valhalla last night. Began riding a horse and there was no sound. Found this thread and it looks like this has been an issue for a month and a half with no resolution? What is the hold up?

    Disappointing that such a core aspect of the game isn't functioning and doesn't seem to get priority for a patch.

  • Ubi-Borealis
    Ubisoft Support Staff 1451 posts
    Best Answer

    Hello there!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue with missing sounds when riding your mount should be fixed in TU 1.2.1. This update was deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues with missing sounds when using your mount following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue still occuring in-game.


    Thanks! 😊

    Official Response
  • Magraciaz
    2 posts

    @ubi-borealis BLESS, just installed the update and the issue is patched. NOW I'm ready to sink hours into this game! Thank you

  • Ubi-Borealis
    Ubisoft Support Staff 1451 posts

    Thanks for updating us, @Magraciaz! I'm glad to hear that the issue has been resolved for you 😄

    Official Response

Suggested topics

Community details

9
Online
124.8k
Users
21.5k
Topics
111.0k
Posts