Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ImaginaryRuins
    352 posts

    I do understand that this is not an urgent matter and it is not game-breaking, but I would appreciate it if there can be any response from the dev. team.

    Each time I manually save I do so in Eivor's quarters in the longhouse, and each time I close and open the game and head outside, it is raining, regardless of the weather when I last saved the game.

  • alx1231
    Original poster 14 posts

    Any updates on this? It's been a while and I don't even see it on the known issues list. Like others have mentioned, I understand the issue isn't the most game breaking but it would be nice if it was acknowledged as an issue.

  • auridulis
    29 posts

    Another update.

    I extracted some older manual game saves from my PC's backup system, and I did some troubleshooting.

    In short, it looks like everything was still fine when I pledged to Snotinghamscire. The rain bug appeared in the next save file, where the last completed quest was “Reporting on Snotinghamscire”. I finished the whole region (the main quest and all the side activities) prior moving to the next one so it might be that the breaking point was in that region. It happened in Update 1.1.2 as the save files are from March 13 & 14, 2021. I have submitted the aforementioned game saves and a few other files in the support ticket # 14496166.

  • Ubi-Mark.
    Ubisoft Support Staff 400 posts

    Hello Vikings,

    Thank you for your continuous updates.

    I just checked this for you and I can see that this issue is still being investigated. Once we have an update, we are going to let everyone know through the patch notes in our News and Announcements section.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • Ryusennin
    59 posts

    Not specific to consoles, it's been happening on PC from release date. For some reason, it used to be limited to Ravensthorpe. But since a few weeks, it seems to rain every single time I load a save game whichever the location.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @ryusennin Thanks for making that clarification! I've passed this along to our teams for their on-going report. 😊

    Official Response
  • alby37
    3 posts

    I can confirm that the rain bug happens during the Snotinghamscire saga.... It's extremely annoying so please fix it

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @alby37 Hey there and welcome to the forums! Thanks for reporting that it constantly rains for you upon launch during the Snotinghamscire saga. I've shared this with the appropriate teams, in hopes it helps them reproduce this error on their end.

    Official Response
  • alby37
    3 posts

    @ubiexcellent It's not "during" but "since" the Snotinghamscire saga, even after it's completed and you move on with the story. You don't notice it while you're in Snotinghamscire because it doesn't rain in the snow.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @alby37 Ah, understood! Thanks for clarifying this.

    Official Response
  • auridulis
    29 posts

    Any news?

    Did my submitted game saves prior to and post the Snotinghamscire reach the devs?

    Would you also mind adding this thread (and maybe merging in other similar threads) to the list of the mega threads?

  • alby37
    3 posts

    Does anybody know if going back to before Snotinghamscire and replaying the game from there could solve the issue? Or is going to be the same no matter what?

  • sorenssorensen
    3 posts

    I just wanted to add some details to this as I was experimenting with it yesterday. I don't think anyone has mentioned that the weather isn't just rain, it's also strong wind, which causes big waves on the ocean, which makes coastal fish despawn. That's the most annoying part of it. I'm on PC. It seems to consistently stop raining after approx. 6 minutes in the game though. Also it's not exactly like it's already raining when you load in, but it seems normal for <1 second and then the weather immediately turns bad.

    It happens when loading in a save when in England and Vinland, but not Norway (maybe except if it's snow instead of rain). I can make it happen simply by restarting the game. But it also happens to me when traveling to England from either Vinland or Norway.

    Video of restarting, so you see it wasn't raining before:


  • Garbo3
    323 posts

    I opened a topic as wasn't aware of this one. Am experiencing the same issue and is becoming really annoying.

  • auridulis
    29 posts

    @sorenssorensen Thanks for the additional details.

    I'm also experiencing the normal weather conditions for a fraction of a second right upon loading in England, and then it starts raining for ~6 minutes.

    Did you by any chance notice if the rain bug started happening during or after the Snotinghamscire arc?




  • Garbo3
    323 posts

    @auridulis I think Ostaras festival
    Here a video
    Skip to Minute 4 17 seconds

  • auridulis
    29 posts

    @garbo3 Agreed. It's such a weird and subtle, yet increasingly annoying bug. It's not game breaking, but it makes the game unnecessarily dark and depressing which slowly pushes you away from the game...

  • auridulis
    29 posts

    @garbo3 Thanks for the video.

    I did think that it might have been caused by the Ostara festival. But then I checked my older game saves. I found that it was all good when I started the Snotinghamscire arc. The game save made right after I finished that region had the rain bug. The game saves are from March 13 and 14, so that's a few days before the Ostara festival and Title Update 1.2.0 were released. At least that's my experience so far. 🙂


  • Garbo3
    323 posts

    @auridulis Probably you are right. I don't remember when I did that arc . Maybe when Ostara was on.

  • sorenssorensen
    3 posts

    I don't think I had @auridulis , but not sure. It's ages ago since I did that arc. But I remember a lot of people mentioning the same issue, and that was long ago, a different version I think. I only found out it was happening to me too after they stopped posting about it. Not sure when it started, I'm afraid.

    Also, it seems to happen when I return after a river raid too. But not sure if it's consistent.

Suggested topics

Community details

10
Online
123.3k
Users
21.2k
Topics
109.3k
Posts