Welcome to discussions

Quick Suggestions

  • FeistyGorilla80
    2 posts

    The settlement decorations have all disappeared and my jomsviking keeps going back to default gear. Please fix this bug. This started happening now in the Ostara festival update. 1.2.0

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for the Jomsviking loadout resetting in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with the Jomsvikingr loadouts following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Spades1961
    35 posts

    To me this happens with weapon and bow: when I assign a spear and a bow to my Jomsviking, it resets to the default axe and bow. It does not matter how often I 'assign' my Jomsviking, the moment I go raiding the weapons are set back to default.Also, after raiding, I can't talk to the raid quest giver, only after a reload I can speak to him again.

    Also I see some Jomsvikings of other players having the same problem: they don't carry weapons and bows whilst others do. I see this regularly, it's not one player wanting to fight barehanded, there are more Jomsvikings showing up unarmed at the same time.

    Needless to say my Jomsviking gets hardly hired anymore 😞

  • Kormac67
    613 posts

    @spades1961 River raid JomsVikings are auto generated. You can't use players' JVs because they are always only lvl1.

  • Erinace
    3 posts

    Thank you for raising this issue. I thought that I might be the only one having it.
    For me, reset of my Jomsviking's gear also occurs when going on a River Raid: Before the longboat leaves Ravensthorpe, the Jomsviking wears the individual gear. When the longboat arrives at the River Raid, the Jomsviking's gear is reset.
    It also seems as if this reset of gear happens to other player's Jomsvikings who can be hired in Ravensthorpe. With one exception they all look the same - clad in the basic gear.

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @erinace,

    Thank you for the update! No worries, we're here to help!

    Are you able to provide us with a previously requested video of this occurring, so we can pass it along to the ongoing investigation? Many thanks and if you have any additional questions, please let us know.

    Official Response
  • Erinace
    3 posts

    Hello @ubi-mark ,

    I am new to providing such a video. So I hope this link


    to YouTube works and does not infringe any IPR or similar. Please let me know if this is not Ok.
    The video shows how my Jomsviking is equipped, then that the gear is still Ok when starting the River Raid and being in the transgression (a bit small but visible, I think), then that the Jomsviking is in standard gear when arriving at the river and travelling back, finally that the gear is also reset in the inventory when returning to Eydis.

    Thank you for your support.

  • Erinace
    3 posts

    @ubi-mark

    Hello again.

    I made another video to show the impact of loading a previous save.



    The game was saved manually (Manuelles Speichern 7) at 17:59. When this save was made, my Jomsviking was in her individual gear.
    Loading this save several times in sequence shows a strange effect: When my Jomsviking wears her individual gear, loading the save switches to basic gear. But when the same save is loaded again after the switch to basic, the gear is back to individual.

  • Spades1961
    35 posts

    @spades1961 Addendum - Yesterday evening I changed my complete outfit and assigned it. Today I noticed the helmet and bow were set to default.

  • g222212
    6 posts

    The Jomsviking costume resets to default outfit each time on restarting the game since 1.2 update. Each time have to go to the barracks and change the costume and weapons. Sometimes, only the robe, helmet, and weapons revert to default, while sometimes it is the entire outfit.

  • OrcBeard92
    Original poster 141 posts

    https://discussions.ubisoft.com/topic/96326/jomsviking-gear-resets-after-patch-1-2-0/2?_=1616330483606

    The problem has been acknowledged by mods and they sent a report to the devs.

  • GlassyCelery532
    14 posts

    @g222212 same happens to me. Or when I start a River Raid.

  • Nnaralia
    1 posts

    Since 1.2.0 the outfit of the jomsviking resets. It seems like that only certain weapons/armor pieces will be saved when I start the game again. For example; every piece of the berserker armor set gets removed, but some armor pieces (mödraniht gloves) remain. Other players seem to have the same issue (reported on reddit)
    It seems to reset when I restart the game.

  • MarcinG_89
    4 posts

    @nnaralia
    I can confirm that.

  • rctx81
    7 posts

    @g222212 had it happen to me on PS4 as well

  • SpirantCrayon22
    316 posts

    All Jomsviking in the River Raid longhouse have the same appearance.

  • Sharingan_boi
    1 posts

    My Jomsviking’s armor keeps resetting! Anyone else’s?

  • Reav1123
    1 posts

    My jomsviking keeps changing its clothing after I customize it a certain way each and every time i close the game and open it back up. Dont know when this started happening, but I noticed it over the last week and it's very frustrating. Is there any way I can make sure my jomsviking stays in the same clothing i set him in? I am on xbox series x running patch 1.2.0

  • Ubi-Orion
    Ubisoft Support Staff 161 posts

    Hey there folks.

    Thanks for reporting this to us. If possible could I ask one of you to provide video of this particular issue we could take a look at please?

    Official Response
  • GlassyCelery532
    14 posts

    @ubi-orion I have a video but can't upload it, says I don't have enough privilegies for that action. I can mail it if you please provide an e-mail address and instructions.

  • Smrtiak.SVK
    135 posts

    @glassycelery532 you just need to copy-paste link from that video....

Suggested Topics

Community Details

40
Online
139.0k
Users
24.4k
Topics
126.2k
Posts