Welcome to discussions

Quick Suggestions

  • Barney_1104
    20 posts

    Same issue here since 1.2.0, my level 3 Jomsviking resets to default gear at game load.

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts
    Best Answer

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for the Jomsviking loadout resetting in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
    If you are still encountering issues with the Jomsvikingr loadouts following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • Draeoth
    27 posts

    @ubi-keo i was mistaken. i tried fast traveling to and from different viewpoints and ports. i tried quitting to title screen and reloading save and both didnt change the gear. however closing and reopening the game changed all gear to default except the primary weapon.

  • Konata10101
    4 posts

    Me and a lot of others are experiencing an issue where our customized jomsvikings reset out of nowhere and automatically equip default clothing and weapons. Please fix.

  • Kennyannydenny
    131 posts

    I noticed that every time I quit the game and relaunch it, when going back into the Jomsviking customization menu, my Jomsviking's appearance partially resets. Her chestpiece stays hidden like I did and one of the weapons (left one) stays the same. But her pants, and gloves reset to the default, and the weapon in the other hand (right one) keeps resetting to the default shield.

    So every time I launch the game I have to re-customize my Jomsviking 😞

  • Ubi-Keo
    Ubisoft Support Staff 1198 posts

    @Konata10101 @kennyannydenny I'm sorry to hear that you are experiencing this. I have merged your post with this megathread as this is a known issue that is being investigated by the development team. Please keep checking here, the known issues list and the news and announcements page for updates.

    @Spades1961 The development team have been unable to reproduce this issue when testing, but are still investigating.

    Official Response
  • ImaginaryRuins
    407 posts

    @ubi-keo What I noticed, however, is that many of the other players' Jomsvikings are wearing customized clothing in my world, despite this issue. That means the data of Jomsvikings is properly sent and saved on the Valhalla server right?

    I am playing on Xbox One. In my case, it is also closing and reopening the game that causes all my Jomsviking's gear to reset to default; fast-travelling does not trigger it, and the issue happens no matter I start the game offline or online.

    I pretty clearly remember that this issue had yet happened with the introduction of River Raid (since it concerns Jomsvikings the most). My guess is probably patch 1.2.0 has coding which has messed up with data retrieval of the most-recently-saved Jomsviking setting when loading up the game for the first time on a console. Or it may be like, even though we again customise our Jomsviking gear, it is only saved like on RAM but not on the hard disk? That is why it is not saved permanently and is lost upon each time the console is shut down? (just a guess; I'm no programmer)

  • azullFR
    742 posts
    This post is deleted!
  • OrcBeard92
    Original poster 141 posts

    @ubi-keo I think it is somehow linked to the transmog system. Ask the devs to change the appearance of gear pieces, then give those pieces to the Jomsviking. That is where I have noticed the easiest way to reproduce the bug.

    Items which are not edited will remain on the Jomsviking.

  • isuwhat
    188 posts

    @orcbeard92 i haven't used the transmog system at all and my gear resets every-time. But its certainly only been happening since transmog was brought in

  • OrcBeard92
    Original poster 141 posts

    @isuwhat Yeah, you're right. I'm just trying to think of the best way they can replicate the bug, if they are claiming they can't replicate it themselves. (Which is honestly kind of baffling, who is testing these bugs?)

  • azullFR
    742 posts

    Exactely !
    Same case for me 🙂
    Never used transmog, but all Jomsviking stuff (Armor and Weapons) resets to system default at each new start 🙂

  • ImaginaryRuins
    407 posts

    @isuwhat Same here; I haven't touched transmog at all (I don't need it, in Odyssey or in Valhalla). The gear-reset bug still happens.

  • Rowannicus
    8 posts

    DITTO - Jomsviking gear constantly resets to the default rubbish.

    ALSO My jomsviking doesn’t have all of my gear,

    At first I thought he didn’t have certain items like Mjolnir, Thor’s armour, Ragnar’s Drengilir dagger, or Excalibur because they are unique one-off items, but he also doesn’t have the soldier’s flail and a number of other things from the later game.

    This is really frustrating. Another thing I hate about River Raids is how raiders are always blowing themselves up - they run around with torches (before the enemy combatants have been killed) and walk straight into those big red oil flagons. Drives me insane.

    Only managed to get this far by editing someone else’s save because I was one of the lucky ones to get the game-breaking Brewing Storm bug.

    Valhalla has way more bugs than Cyberpunk 2077 ever did.
    And at least CDPR fixes their bugs.
    Ubisoft releases a [censored] broken festival and more goddam cats.

  • Rowannicus
    8 posts

    In my case the longship also resets to default (as well as my Jomsviking)

    On river raids lately my longship has the hideous Raven Clan sail etc.

    None of the customisations for the entire River Raids component are being saved.

  • eproxima
    1 posts

    Hello all. This is my experience with the issue.

    I started ACV and selected "Continue" just to find my Jomsvikings outfit back to default.
    I reapplied my chosen style to the Jomsviking and saved the game manually in main menu. (Save #11)

    Test 1:
    Keeping the game active (same session), I selected "Quit to Title Screen" to check theese variants:
    Continue Game. Result: Jomsviking has my applied outfit.
    Load Game. Result: Jomsviking has my applied outfit. (Save #11)

    Test 2:
    I shut down the game (exit to dashboard and assured that i had closed the game) and then launched the game again.
    Continue Game. Result: Jomsviking resets.
    Load Game. Result: Jomsviking has my applied outfit. (Save #11)

    So even if my new game session got my Jomsviking reset, it seems that you can work this out by saving manually before ending your session, and choose "load game" when you start your next session. Then you keep your custom outfit on your Jomsviking.

    I have upload the video to Live to Ubisoft if it helps out.
    There you can see a fresh start with the Continue result and the Load Game result.


  • Spades1961
    35 posts

    "The development team have been unable to reproduce this issue when testing, but are still investigating."

    Are you sure they are testing Valhalla, not Odyssee? 'Coz everyone else has this problem, right from the start >.<

  • Yesin069
    554 posts


    This feels really strange and i cant believe that. Everyone I know who plays that game has this issue and it is as easy as breathing to reproduce:

    1. Put other than default gear on your Jomsviking!
    2. Play the game and it will work but at some point you will end the game and go working or sleeping or eating!
    3. Reload the game and see that the Jomsviking gear is back to default!
    4. Voila, you have reproduced a "very complex" bug!

    When such a small issue takes the devs so much effort and time to fix, i am really not surprised that there are still many day 1 bugs that are not fixed. Are there actually the real devs working on bugfixes for this game or is it outsourced and the real devs work on the DLC and new games? It really feels strange and like amateurs or people that arent familar with the tools of this game work on handling bugfixes for this game. This is also seen when looking at many bugfixes that get mentioned in more than one patchnote article because it wasnt fixed in the patch before.

    Also where are minor fixes for things like wrong written stats in the details page of the Berserker armor and the St. Georges armor, or missing "Updated Codex" pop-ups in the PC version? Those fixes can be done within minutes at the side? It just feels unprofessional, letting bugs like that for months in a game that isnt titled an early access release.

    I think the actual devs that made this game in the first place wouldn have that many problems in fixing such issues, like 2 missing fish types or gear always reverting back after relaunch. Open your engine a little bit and any modder will fix those issues in a day or two without knowing the source code of this engine or how the game works.

  • K.Dizzy
    2 posts

    Every time i re-enter the game, the equipment of the follower will become the default appearance,and it has no effect even if i save it,it will become the default appearance again when
    i enter the game next time.
    AND another question:When equipped with a two-handed weapon and a one-handed weapon at the same time, can i hide the second sword sheath on the back

  • Ubi-Keo
    Ubisoft Support Staff 1198 posts

    @k-dizzy To confirm are you referring to the Jomsviking's appearance? If so I can confirm that this is a known issue that is being investigated by the development team.

    Regarding your query about the swords, it is not possible to sheath one of your swords, both are equipped during combat.

    Official Response
  • Pedr0P0d
    1 posts

    I have this issue. Only the armor gets reset. I have my jomsviking in a full magister set, and every time I restart the game it has reset back to default gear. The weapons are unaffected for me. I gave her a sepulcher axe and a kite shield and they remain in her load out after restart. None of the items have been enhanced or transmogrified in any way. It's baffling that this can't be reproduced when it seems to be happening to so many people if a quick Google search is anything to go by...

Suggested Topics

Community Details