Welcome to discussions

Quick Suggestions

  • justinlouwiesse
    1 posts

    Same problem with fiery ambush, quest located on top of the map and no merchants left to kill or no where to find. Xbox one S

  • axelcaroli
    4 posts

    @ubi-mark I am sorry to tell you that your answer is far from being satisfactory.

    A lot of people are stuck for a clear ubisoft problem, and there seems to be no clear reaction.

    Please take the actions to solve the glitch RAPIDLY !!!

  • cgpwhite83
    6 posts

    @ubi-mark yes I’ve been able to progress. I basically did everything else possible until that mission needed to be finished. Went back and the cut scene started.

  • Treemanstu
    3 posts

    @cgpwhite83 I've just done the same thing... Completed every other alliance, even recruited bjorn the berserker. Went back to Oxford, slaughtered everyone there, then took slow ride to barn to meet fulke, on approach cut scene finally kicked in.. Laid oil traps for merchants, task complete.
    Good luck to everyone else, hope it helps.

  • ubi-smash
    Ubisoft Support Staff 794 posts

    @guest-uxrbtedc Hey there! Our team is looking over this issue and have also requested save files from players. Make sure that your most recent save file is uploaded to the Cloud (There will be a cloud icon on your save slot). This will allow the team to check your save file for their investigation.

    Official Response
  • ReakQuiroga
    1 posts

    Wow! I waited some months to buy this game just to avoid this kind of stuff...
    I killed the merchant and now the quest it's unable to complete. I came to this forum expecting to find the solution and the devs are still working on it, this is ridiculous.
    If you need a save file on the cloud with this quest bugged, check my account.

  • ManOverboard424
    2 posts
    Hello everyone,

    Thank you for your continued patience. I just checked the status of this issue and I can see that it's still being investigated by the development team. Once we have an update, we are going to let everyone know through the patch notes. Apologies for any inconvenience caused by this.

    @cgpwhite83, thank you for sharing this! Can you please confirm if you're able to continue with your progress now?

    @guest-uXRbTeDc, I'm afraid that we don't have any ETA yet, but as soon as we have an update, we are going to update this megathread as well.

    @ubi-mark - Is there any update on this patch yet? I have done everything else I possibly can and cannot progress any further. This mission has been broken for me for a while now and I'd like to finish the game. Having the same problem as everyone else - I got to Eatun Barn, blew up the pots, now it says kill all the merchants with the quest marker being all the way at the top of the map. I looked around and there are no enemies to kill up the road. Just completely stuck.

  • danielherrera06
    2 posts

    I've killed every soldier, wolf, deer, civilian (I even killed an Order of the Ancients member called Patrick by accident) and the game is stuck. Not only I can't seem to find this standalone soldier along any of the roads (as some of my fellow Jomsviking friends suggest here in the forum), but the music... THAT ANNOYING MUSIC FROM THE MISSION IS STUCK! I can't reload a previous save because from a Reddit forum I read that pledging to another territory, doing a mission, and then returning to this GAME BREAKING MISSION should fix the bug, but guess what... Rhodri is going down in a Fiery Ambush mood! 🙂 (and surely any other king that stands in my way while Ubisoft IS KIND ENOUGH TO FIX A SIMPLE BUG...)

    PS: Seriously Ubisoft. Don't be so lazy and expect your customers to find workarounds to solve your own mistakes. Fix the issue, or look for an alternative (such as incorporating a restart mission option. Already have this feature is AC Origins, so it can't be hugr magic for you...)

  • danielherrera06
    2 posts

    And before you suggest to kindly reinstall the game to solve the issue. Already did it. FIVE TIMES TOTAL!

  • guest-uXRbTeDc
    5 posts

    @ubi-smash yes there is a Cloud savings.

  • guest-LdAQibfR
    1 posts

    Is there any update on this? I have the same issue where I have destroyed all the carts, but the quest won't update past "Kill the merchant". I've spent an hour going up and down the roads and around the forest killing everyone I find but nothing is progressing the quest. Help!..

  • guest-V09fDmfX
    1 posts

    Please pleeease fix this damn bug. Added to the mission not working, the fight music keeps going on in other missions. Also the textures from trees, raspberry bushes and mushrooms are now disappearing (the text is visible so at least I know what's where). But here I am on the supply line mission with the damn fight music from fiery ambush in the background non stop. Where is the "restart the mission" option from, was it Odyssey? This is not good.

  • guest-uXRbTeDc
    5 posts

    @ubi-smash and everyone else! Finally bug is gone. I finished Lunden, Going to Deeper Quest and Jotuheim (only Steinbjorn left) and Sciropescire. I been always collect all chests, wealths, mysteries at all areas. Now I came back to Randvi choosed Oxford once again and notice that quest mark didnt appear north of the map. So I Fast Travelled to Buckingham took a ride to Eatum Barn. About 300-500m before Eatum demo kicked in and convoy of enemies arrived after I placed jars. Wuhuu!


  • monkeyinpodship
    2 posts

    Exact same issue happening for me. Cannot complete quest and the landscape disappears as I approach. Fight music plays continuously. Playing on PS5. Submitted claim: https://support.ubisoft.com/en-US/Cases/14567802

  • ubi-smash
    Ubisoft Support Staff 794 posts

    @guest-uxrbtedc Thank you for the update and glad to hear you were able to proceed!

    @monkeyinpodship Sorry to hear this, but thank you for sharing your ticket here and providing the team with further information. Are you able to share a video clip of the issues you have encountered during your playthrough? Any additional information we can share with the game's team to investigate would be greatly appreciated!

    Official Response
  • ManOverboard424
    2 posts
    This post is deleted!
  • axelcaroli
    4 posts

    @ubi-smash this clearly means ubisoft did not find any solution, and this after months people are reporting the same exact problem. This is unacceptable to pay for a game that doesn't work.

  • kcvriess
    2 posts

    Same issue here. Can't finish the Fiery Ambush mission.

    My mistake was (I guess) that I started destroying the supplies first.
    I mean, I overheard the Fulke arguing with the merchants so I thought, let's expedite this situation.
    Now the merchants are dead, but I can't speak to Fulke and there are no soldiers coming.

    Some people are suggesting to pledge to another territory on the conquest map, finish that story arc and then getting back Fiery Ambush mission. They say that it helped them and that the right cut scene was triggered.
    Ok, I tried. I pledged to the last available territory on the map but the music from the Fiery Ambush mission is playing on a loop and the quest marker is still there, stuck in the top right of the compass HUD.

    This problem has been reported since November 2020. Why hasn't it been fixed yet?

    I'm really hoping for a fix in the next big patch (April 27th?)

  • kcvriess
    2 posts


    Yuss! Today's patch instantly solved the Fiery Ambush quest bug for me.
    The quest wasn't visible anymore though. I went to the location, found Fulke and the cut scene of the approaching soldiers started.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello all!

    Thank you for continuing to update this thread with your experiences with "Fiery Ambush." I would like to provide you all with a status update of the ongoing investigations taking place regarding this quest:

    "Fiery Ambush" doesn't update after killing the Merchants

    • Status: Pending fix
    • Comment: The development team intends to resolve this issue in a future update. We don't yet have a definite ETA for this update. As soon as we have more information to share with you all, this will be posted within this thread and in the News & Announcements forum.

    Unable to proceed in "Fiery Ambush" after eliminating the reinforcements

    • Status: Under investigation (Additional videos and save files welcome)
    • Comment: The development team are still investigating this issue further. If you have been affected by this issue, please ensure that you have an up-to-date save uploaded to the cloud. You can check for this by looking for the cloud icon on your save slot. This will allow the development team to check your save file as part of the investigation.

    @axelcaroli - Thank you for sharing your feedback with us. I'm sorry for any disappointment that has been caused. Rest assured that the development team are looking into this quest further. As soon as we have any updates from either investigation, we will be sure to let you all know within this thread as soon as we are able to.

    @kcvriess - Thank you for sharing your report with us. I'm glad to hear that you've been able to proceed in "Fiery Ambush."

    If you have been able to proceed in "Fiery Ambush" following TU 1.2.1, please don't hesitate to let us know.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details