Welcome to discussions

Quick Suggestions

  • Dillinger604
    3 posts

    please see title, i am going to edit this with relevant info as this website keeps marking my post as spam.

    Edit: Theres a camp called Hyvlatonna, with a berserker in a stone circle. I assassinated the berserker and looted his body, i recieved two items from him but i did not receive the Carbon Ingot, it still shows up on my map as a yellow dot and is missing for the area completion for the Wealth/Mysteries/Artificats tracker.

    when i use the raven - the raven identifys the yellow dot map tracker on the berserkers dead body, however all i can do is pick up, move and throw the body around.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello all!

    This issue wherein the wealth couldn't be looted from the enemy NPC in Hyvlatonna has been marked as resolved by the development team. As we have had no new reports of this issue still happening in-game, we have marked this issue as resolved and will be locking this thread.

    If you encounter any new issues in Hyvlatonna, or are unable to collect wealth, please feel free to open a new thread so we can investigate further. When opening a new thread, please include a video that shows the issue you're encountering in-game.

    Thanks! 😊

    Official Response
  • FieserMoep
    19 posts

    I killed the half naked berserker at Hyvlatonna in Rygjafylke and looted the Ingot from him. After that I still get a Wealth Marker on his corpse and the Region wont get completed.

  • Dillinger604
    3 posts

    He respawned, i killed him legitimately and i managed to get the wealth Ingot.

    I apologize if this was intended method of killing him, but i rather like assassinations.

  • pokeriks18
    4 posts

    What can I do? I killed the guy in Hyvlatonna to get wealth the ingot, but after killing him I can’t loot him and it’s still shows on the map his dead body location and the body not disappearing and it’s still showing that I didn’t fulfill the wealth quest what should I do?😱😱😭

  • Reyfel0
    1 posts

    @dillinger604 i have the same problem, how do you make him respawn?

  • XXDEATH58
    2 posts

    I killed a double axe dude with a wealth marker and now that he’s dead I can’t loot him and the marker is still on his body I can even pick him up and move the marker around too

  • Vanguard-IV
    1 posts

    @xxdeath58 Same thing happened to me, except I had looted him in the middle of fighting the other guys in the area and I didn't get the wealth credit. I tried reloading the game and fast traveling away and running back to the corpse. No joy. So I loaded up a save game that was before I had killed him and redid the area. This time it worked.

  • revzman123
    3 posts

    @fiesermoep same here plus a few posting on reddit. Seems common no matter if you assassinate or fight him. Frustrating as usual.

  • Walthareus
    5 posts

    Similar problem here, I have looted a bandit leader's corpse near Soar river, and it supposed to complete the ingot wealth, yet it still stuck on the map, it is frustrated; also if you looted an opal and re-load an earlier game save, the Opal icon would be still there but there is no opal to loot. They should add some checking regarding the looted opal. Now I am completely ruined by these 2 bugs...

  • sprff1tw
    2 posts

    There is a wealth map marker in Norway > Rygjafylke > Hyvlatonna
    The Ingot was on an elite enemy, I killed it, looted the ingot but the Wealth Map Progress did not complete and the marker is still there
    Moving the enemy corpse will move the marker around the map
    There is no way to 100% complete the map now
    Restarting console / reloading save games does not help

  • Imaginaris
    2 posts

    After some cruising for 2-4 hours, the guy resurrected. And after a combat, achievement done.

  • R2n2sid2
    1 posts

    @snorrigan Yeah i have the same bug 😞

  • LucyT86
    1 posts

    @snorrigan thanks, ive currently got a situation where the guy I need to loot is in a haystack and it won't let me loot him. Ill try coming back later like you did.

  • Andromedafly
    3 posts

    @imaginaris Yeah you're right. It is fixed by me now thanks!

  • KingOtakur
    2 posts

    I killed a guy in Hyvlatonna for the ingot. I got the ingot but didn’t get the completion for it. The indicator is still there.


    It was my last one and I don’t really want to restart my whole game just to do it all again 😞

  • Dillinger604
    3 posts

    @reyfel0

    I left for a couple of hours and came back, there was a small island in the middle with some wolves, along with a Wealth Ignot in a crushed ship (that took me way to long to figure out how to smash into, and i think i did it by accident).

    I then Fast traveled back to town/around the map and upgraded some gear with the Ingots, when i circled back to the ring of stone area he was alive and kneeling again.

    I really hope they re-spawn for you, i cheesed that guy from behind with backstab damage with a spear, the fight wasn't to difficult at that point.

  • Shnup
    1 posts

    undefinedThe mini skull crusher boss fight has glitched out at Hyvlatonna. I've killed the guy and looted the ingot from his body but the wealth marker hasn't dissappeared so it's not counting towards my total.

  • eaglezfan420
    2 posts

    as the title states the Ingot looted from the NPC in Hyvlatonna is not counting towards wealth territory completion, it is all i need left for the wealth in this area

  • eaglezfan420
    2 posts

    UPDATE: i reloaded the game and went back over there, the NPC was alive again and it gave me credit towards the area wealth!

  • Trahepac
    1 posts

    The carbon ingot on the boss was looted and the icon is still showing as it was not.

Suggested Topics

Community Details

63
Online
194.0k
Users
32.8k
Topics
163.9k
Posts