Welcome to discussions

Quick Suggestions

  • Aquaaran
    2 posts

    Not sure then. I just know I had 2 missing wealth and only one on my map. The last few things I did was grab a normal chest in a hole in the shipyard, then I went to complete a few mysteries. The last two I did was the guy that asks you to save his lord, which is a setup, and then the warlock. After that when I used the bird next I could see the wealth marker. When I got their a warlord chief, I believe it was, walked out of a house and he had an ingot on him. Maybe it was one of the other steps that triggered it. I hope you figure it out. I was stuck on it for two days.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    This issue wherein the wealth couldn't be looted from the enemy NPC in Hyvlatonna has been marked as resolved by the development team. As we have had no new reports of this issue still happening in-game, we have marked this issue as resolved and will be locking this thread.

    If you encounter any new issues in Hyvlatonna, or are unable to collect wealth, please feel free to open a new thread so we can investigate further. When opening a new thread, please include a video that shows the issue you're encountering in-game.

    Thanks! 😊

    Official Response
  • FL4MINGN4PPIES
    4 posts

    @oak3996 is it the hyvlatonna skull crusher , mines bugged I got the ingot but it never marked it as collected on the wealth list and the gold symbol at the location is on map and in game .... can't get it to pop at all

  • FL4MINGN4PPIES
    4 posts

    Hyvlatonna wealth on beserker / mini boss bugged when killed and ingot collected it doesn't register as collected on the wealth system and the gold symbols remains on map and in game

  • scarfoxnyeh
    13 posts

    Had a bug like that with a dude in a camp on the mountain, meditating or something between large stones. Killed him but his golden dot remained on the map. Killed him again later on and got the wealth and the dot disappeared.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hi there! The developers are aware of some activities not showing up on the map as collected - they are investigating it at the moment, and any updates regarding this issue will be shared when available.

    Official Response
  • myphoneisred
    1 posts

    Leaving and coming back appears to be working, but if you’re impatient and want to get to the bottom of it before moving on (like me lol) here is what worked:

    1)fast travel out of the area (I picked a location as far away from the glitched wealth as possible)
    2)create a new save
    3)exit out of game
    4)reload game
    5)return to area.

    Enemy will have respawned, wealth can be collected and the icon will disappear.

    I tried just fast traveling and then returning - that did not work.
    I tried doing everything except exiting out of the game - that did respawn the enemy and allowed me to collect the wealth BUT the icon did not disappear.
    I tried reloading a previous save before I killed the enemy that dropped the wealth - to my surprise, same scenario above occurred!

    really hope this helps. I know stuff like this bugs the heck out of completionists that are drawn to AC games.


  • Balla_Jazzuz
    100 posts

    @myphoneisred Have had this similar issue on PS4 a few times all around the map, whether it is a key or wealth attached to a soldier.that disappear after killing them and therefor can't be collected.
    The icon remains on the map, bodies gone. Then I have to fast travel and quit game, reload and the soldier with the key/wealth will be collectable again.
    Hope this will be patched up, but currently this is the way for me to work around this issue.

  • Ubi-Swaggins
    Ubisoft Support Staff 420 posts

    Hey folks,

    This has been raised to the team for further investigation.

    In order to assist can you contact our support team and provide a copy of your save file?

    Official Response
  • FL4MINGN4PPIES
    4 posts

    @ubi-spud thank you

  • Dclark5891
    5 posts

    I have an enemy in Vinland who is dead but wont let me loot him and he has wealth on him. Ive left and come back many times and he refuses to respawn. nothing i do works. It is preventing me from being able to get the trophy for completing all territories. Very frustrating. I play on ps4

  • Dclark5891
    5 posts

    So after some messing around, I found out that i set a trap on the body than brought him to an enemy to force the body to explode. Than just saved and reloaded which forced the enemy to respawn. I was than able to kill and loot him.

  • domeckquan
    2 posts

    Same issue here
    I was doing the Wenlocan Outpost in Sciropescire and I've killed the person with wealth, however, it was not set as an Ingot Wealth. After killing him, I've collected the wealth but the icon of it did no disappear.

  • LeouzX
    1 posts

    Same here but in Vinland and the enemy never respawns is just a body. I have even blown up the body and nothing 😥

  • jdufresne1
    1 posts

    Finding treasures in beginning of game is fun for me but have run into this 2 times so far. This certain NPC that is atop the really tall mountain near where you take over Kjotve castle area. Hyvlatonna area.
    The NPC that holds the treasure which is surrounded by the stones and near the firepit.
    Killing him and looting the carbon ingot the first time doesn't register as achieving the treasure. Have to leave area, wait on respawning then go back and kill him again to get it to register as collecting a treasure.

  • ddjgoa
    1 posts

    I also have this bug. Hope this doesntbprevent me from 100% the game 😡
    .


  • accgfw
    1 posts

    @leouzx

    Same here, cant loot an ingot in Vinland!

  • braincrush
    3 posts
    This post is deleted!
  • braincrush
    3 posts

    @snorrigan I’ve just managed to fix it in my game (vinland) I’ve set a trap on the body and carried it to another camp when one last enemy was still alive, enemy activated a trap that made the body disappear after a travel to England and back the guy was reapawned in the original camp and after assassination i got my final piece of wealth.

  • CptPimptastic
    2 posts

    @dclark5891 I’m having the exact same issue. It’s literally the only thing keeping me from 100% the game...

  • CptPimptastic
    2 posts

    @dclark5891 I just tried your fix, but I carried that dude around everywhere with that bomb on him and couldn’t find a single enemy alive to activate it...

Suggested Topics

Community Details

99
Online
192.5k
Users
32.4k
Topics
162.3k
Posts