Welcome to discussions

Quick Suggestions

  • Revenskrev
    20 posts


    OPALS NO LONGER SHOWING. Same game breaking bug here. At first they showed, now I've visited 10-15 opal map points in a row w/o opals being visible.

    FOX LOOT: The problem with foxes is twofold. The physics treats snowy slopes as it was super slick ice. The arrow slides with the dead fox. Loot remains at initial kill spot. Just run to blood stain and look down toward carcass, you should get a loot option then. Wish the white snow camo fur would be bloodstained for easier detection. Odin's Sight is near useless when it comes to detecting as the range is for practical purposes oftentimes shorter than the animal's detection range.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I've merged together several threads about being unable to collect opals together into a single megathread. I apologise if any ongoing discussion was disrupted by this.

    The development team has been able to resolve the issue wherein multiple opals in-game could not be collected. We will now be marking this thread as resolved and closing it.

    If you are unable to collect any other opals in-game, please don't hesitate to open a new thread so we can investigate this further. When opening a new thread, please include an image of your current map location so we can find the opal you're having trouble with.

    Thanks! 😊

    Official Response
    2 posts
  • Revenskrev
    20 posts

    Opals stopped appearing in my game. They only show on map using the raven but when I use minutes getting on the physical location, nothing shows. Super annoying.

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    @jes_mcdevlin Hello! Apologies for the inconvenience, I can see another report has reported the same issue.

    Our team has been made aware and they will work to implement a fix. Keep an eye our on our forum for future patch notes. 🙂

    All the best!

    Official Response
  • zackwee
    9 posts

    Goes for the same on PS4.

  • xfrenchex
    5 posts

    This is showing an opal icon but I have nothing I can collect? I don’t understand what I’m supposed to do. Is this a bug?

    I also can’t even attach the dam photos so that’s cool.

    ive tried for half an hour to add the photos and I can’t, anyone know how? I copy my imigur post and tried to paste it and it won’t work.

  • xfrenchex
    5 posts


    to try to explain, my raven can see the opal emblem on the map and then I go to that spot and it’s just a dirt spot in the snow with nothing there

  • Revenskrev
    20 posts

    @xfrenchex I have the same exact issue. Opal icons showing on map, but when I visit the locations there are no opals to be seen. Looks like they are placed under the ground. Never previously been to those locations. I used to be able to pick up the 3-4 opals closest to Fornburg start area, but after - not a single opal can be found despite visiting loads of places where opals are marked on the map.

    FIX this quickly please Ubisoft with sugar on top. Near game breaking bug knowing you can't upgrade equipment.

  • Revenskrev
    20 posts

    This might be part of a much greater opal bug. Haven't been able to locate any opal on the map since the early beginning. All now looks like they are placed underneath the ground.

  • Revenskrev
    20 posts

    @stoned019 Also have that issue. In fact, I can't find any opal anymore despite visiting loads of locations marked on the map. Will try the workaround suggested here and hope it doesn't screw up my save game.

  • K9davis24
    4 posts

    Been to at least four opal locations in Norway and have been unable to pickup any of them. No loot icon appears or anything like that.

  • URcries4MOMMY
    2 posts

    Unable to pickup opals mark them go to site and they are not visible. PS5 platform

  • LordReaper21
    1 posts

    Game Version: Xbox Series X
    Location: Grantebridgescire North East of Walden inside the house sitting on a shelf. Item: Opal
    So I tried many times to pick this up. Reloaded the save. Loaded a second save. Closed the game and restarted and still couldn't pick it up. Since all else has failed I figured I report it.

  • alphamachina
    42 posts

    Like the title says, there's no prompt to loot this opal northeast of Walden in Grantebridgescire. Other items in the house are lootable.
    Also when trying to upload pictures to this post, the dialog box for selecting the images pops up three times, twice after having already selected the image, but if you don't select the image every time the box pops up, it doesn't place it into the post. This is happening on Brave browser (basically Chrome).

  • hokousharingan
    10 posts

    Opal in house is not pickupable.


  • Bak2ThaBasix
    1 posts

    @revenskrev I am having the same issue, I collected the opal and then died before the auto save but when I went back to the same location where the emblem was there was no opal to collect.

  • CalabrieI
    3 posts

    Specifically, the opal in the house just northeast of Walden in Grantebridgescire cannot be picked up. The dot appears over it, but there is no collect prompt and no amount of maneuvering allows Eivor to collect it. I haven't found any other opals or items like this, but I will update this if I do.

    I want my map clean.

  • kevryl
    1 posts

    Greetings,i play with xbox one and i purchased the map icon unlocks from the shop: most of opals spread in Ledecestrescire are missing 
    L= Ledecestrescire

    L= opals missing all around ledecestre: 1 South of city,2 west of city (one of these are east to ragnarsson camp)3 North of lecestre (1 is in an old church where is a secondary mission; one a little more North than church where you find roman artifact,and another one always northern near the river,this last one is locate South West of sudwella monastery

    L= 3 more missing both North of sudwella monastery (one of these is n-east)

    G=1 missing opal in South region ,right of walden,is visible but cannot take

    G=raetborough ,1 missing little treasure chest ,map show it but is missing 

    Snotinghamscire=1 missing opal up the wenloch abbey

  • PirateLeg88
    9 posts

    The opel locations are sometime in houses or huts, situated on tables, chair or shelving, iv come across a bug were I cannot pick and opel piece off of a shelf. Very frustrating when trying to get all opel pieces

  • taeles
    1 posts

    @calabriei confirmed, very annoying.

Suggested Topics

Community Details