Welcome to discussions

Quick Suggestions

  • Troopercooper80
    47 posts

    @cavveman Hi thanks for replying, but no it have not been to Walden before.

    I tend to, as a pure autistic gamer :P, go 1 by 1 to every "thing" on the map.
    So i know i didnt pick it up yet, as i hadnt travelled to that side of the map yet.

    Anyway its simply bugged.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I've merged together several threads about being unable to collect opals together into a single megathread. I apologise if any ongoing discussion was disrupted by this.

    The development team has been able to resolve the issue wherein multiple opals in-game could not be collected. We will now be marking this thread as resolved and closing it.

    If you are unable to collect any other opals in-game, please don't hesitate to open a new thread so we can investigate this further. When opening a new thread, please include an image of your current map location so we can find the opal you're having trouble with.

    Thanks! 😊

    Official Response
  • RealTaySwift
    4 posts

    @pirateleg88 This is happening with the opel on a shelf in a house to the east of Walden.

  • VegR8derBaby
    1 posts

    Opal just northeast of Walden in Grantebridgeshire inside of farmhouse does not bring up Y button to retrieve. I’ve tried everything.

  • x3ro-Shikari
    21 posts

    I'm also seeing this

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @KingLobo150 Thank you for contacting us, apologies for the delayed response.

    Were you able to locate the Opal, or is it still missing for you?

    Official Response
  • jeje_71
    71 posts
    This might be part of a much greater opal bug. Haven't been able to locate any opal on the map since the early beginning. All now looks like they are placed underneath the ground.

    this is the only bugged one i found for now, and is really nothing new since in odyssey i had a few dozen of ore / tree non-lootable and i think i found 2 or 3 ore in valhalla in the same case

    but since opal are much more limited in quantity, i think it warrants special attentions for these ones, considering they had to be hand-placed contrary to ore which must have been auto-generated to some extent.

  • EMSISS52
    2 posts

    @irish_mandalor I faced the same problem. I can raise opals (for now). But the ones I picked up earlier don't disappear from the map and it's infuriating! (the problem on the PC)

  • EMSISS52
    2 posts

    @stoned019 I faced the same problem. I can raise opals (for now). But the ones I picked up earlier don't disappear from the map and it's infuriating! (the problem on the PC)

  • Serangels
    3 posts


    Il m'est impossible de ramasser une Opale située sur une étagère dans une petite maison au nord-est de Walden , dans le Grantebridgescire.
    L'interaction "collecter" n'apparaît pas, pourtant il y a bien un petit point blanc dessus, elle est visible avec l'œil d'Odin et par le Corbeau.

    Pourriez-vous remédier a cela s'il vous plaît ?
    Je peux fournir photos et vidéos au besoin.


  • Jayshua_Lyn
    12 posts

    Yep. Having this same issue!

  • GFY64D
    1 posts

    @atrixz I have the same issue

  • daz-lufc
    16 posts

    G=raetborough ,1 missing little treasure chest ,map show it but is missing

    I noticed this one last night- well annoying when you’re a completionist 😊

  • Srirachah
    1 posts

    same issue hope they fix soon

  • cyres41591
    1 posts

    There is an opal in Ledecsterscire that on my Xbox, Eivor cannot pick up. There is no option to hit Y to collect it. I see it on the shelf, and the white dot is there, but I cannot pick it up. It is the one in the South in a small cottage with two food pots.

    secondly, the mystery with the dancing semi-nudist colony is broken for me. After I talk to the quest giver, then to the old dancing lady and say I want to join, she says there is a box to put Eivors clothes. I watched a few YouTube videos and there is a box for me to pick up. It doesn’t even appear.

    thanks for the help!

  • KostasD95
    2 posts

    It is impossible to pick up the Opal on the image, tried everything!undefinedundefined

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey folks! I'm sorry that the Opal is not where it should be - could you provide a video of the Opal missing, along with locations on the map?

    Official Response
  • sideshowman
    2 posts

    Me too. PC gamer.

  • Olgit_aka_Tiglo
    5 posts

    North East of Waldon in Grantebridgescire - in the house, on a shelf. No Y button for xbox version of game. I've reset and checked again, to
    no avail.


    Anyone have suggestions for this Opal?

  • Demonicsixx66
    1 posts

    Yeah that one is missing in raetborough

  • DannyyJamess
    1 posts

    You say a future patch but we are playing the game now surely you can roll out a fast patch people pay so much for your games and you have such a huge fan base you could at least bring a game out that work all of your games are full of bugs when they come out cough cough unity. Cough cough watch dogs

Suggested Topics

Community Details