ubisoft discussions

Quick Suggestions

  • 0 Likes/248 Replies/9578 Views
    21 posts

    This might be part of a much greater opal bug. Haven't been able to locate any opal on the map since the early beginning. All now looks like they are placed underneath the ground.

  • Revenskrev
    21 posts

    @stoned019 Also have that issue. In fact, I can't find any opal anymore despite visiting loads of locations marked on the map. Will try the workaround suggested here and hope it doesn't screw up my save game.

  • K9davis24
    4 posts

    Been to at least four opal locations in Norway and have been unable to pickup any of them. No loot icon appears or anything like that.

  • URcries4MOMMY
    2 posts

    Unable to pickup opals mark them go to site and they are not visible. PS5 platform

  • LordReaper21
    1 posts

    Game Version: Xbox Series X
    Location: Grantebridgescire North East of Walden inside the house sitting on a shelf. Item: Opal
    So I tried many times to pick this up. Reloaded the save. Loaded a second save. Closed the game and restarted and still couldn't pick it up. Since all else has failed I figured I report it.

  • alphamachina
    51 posts

    Like the title says, there's no prompt to loot this opal northeast of Walden in Grantebridgescire. Other items in the house are lootable.
    Also when trying to upload pictures to this post, the dialog box for selecting the images pops up three times, twice after having already selected the image, but if you don't select the image every time the box pops up, it doesn't place it into the post. This is happening on Brave browser (basically Chrome).

  • hokousharingan
    10 posts

    Opal in house is not pickupable.


  • Bak2ThaBasix
    1 posts

    @revenskrev I am having the same issue, I collected the opal and then died before the auto save but when I went back to the same location where the emblem was there was no opal to collect.

  • CalabrieI
    3 posts

    Specifically, the opal in the house just northeast of Walden in Grantebridgescire cannot be picked up. The dot appears over it, but there is no collect prompt and no amount of maneuvering allows Eivor to collect it. I haven't found any other opals or items like this, but I will update this if I do.

    I want my map clean.

  • kevryl
    1 posts

    Greetings,i play with xbox one and i purchased the map icon unlocks from the shop: most of opals spread in Ledecestrescire are missing 
    L= Ledecestrescire

    L= opals missing all around ledecestre: 1 South of city,2 west of city (one of these are east to ragnarsson camp)3 North of lecestre (1 is in an old church where is a secondary mission; one a little more North than church where you find roman artifact,and another one always northern near the river,this last one is locate South West of sudwella monastery

    L= 3 more missing both North of sudwella monastery (one of these is n-east)

    G=1 missing opal in South region ,right of walden,is visible but cannot take

    G=raetborough ,1 missing little treasure chest ,map show it but is missing 

    Snotinghamscire=1 missing opal up the wenloch abbey

  • PirateLeg88
    9 posts

    The opel locations are sometime in houses or huts, situated on tables, chair or shelving, iv come across a bug were I cannot pick and opel piece off of a shelf. Very frustrating when trying to get all opel pieces

  • taeles
    1 posts

    @calabriei confirmed, very annoying.

  • thed33p
    1 posts

    Hi Ubisoft,
    i cant loot this... bye


  • Deuteromycetes
    3 posts

    Opal just west of Walden cant be picked up. There is no option no matter what angle you position yourself.

  • MaxieMilyon
    2 posts

    I can’t loot an opal in Grantebridgescire at near Walden

  • Grand_310
    32 posts

    Can't pick up this Opal



  • Tasha-Soriah
    164 posts

    @maxiemilyon i got the same issue, think theres a few opals that are bugged but this is the 1st one ive come across.

  • Spevf
    2 posts

    @thomasdunford Thats stupid. Fix you crap Unisoft!

  • Revenskrev
    21 posts

    @spevf Do you play in offline mode? Opals apparently require online mode to exist in the game. Also try logging out/in and see if that helps. My issues are solved having done both.

  • Irish_Mandalor
    1 posts

    I noticed a couple opal glitches that are driving me insane. In the beginning of the game in Norway, I collected 2 opal off a couple mountain tops near the seers hut. But the map icons won't go away. And near Walden, there's an opal in a hut that won't let me pick it up and its driving me insane. I can't find anything that shows Ubisoft knowing about this issue and fixing it. Does anyone have any ideas how to fix?

Suggested Topics